Конспект Лекций

Министерство образования республики Беларусь

Учреждение образования

«Гомельский государственный университет
имени Франциска Скорины»

Основы аппаратного и программного обеспечения сетей

Краткий конспект лекций

Гомель 2006


Домашние сети

Концепция построения домашних сетей на текущий момент еще не до конца выписана и их роль бывает различной для сетей, в состав которых они входят и для конечных пользователей.

Так для корпоративной сети внешняя домашняя сеть может стать дополнительным сегментом.

Для частной сети провайдера – объектом услуг по предоставлению сетевого оборудования, обеспечивающего связь между домашней сетью и корпоративной сетью.

Для пользователя, в зависимости от поставленных им самим задач, домашняя сеть может оказаться:

· рабочим местом служащего (концепция «домашний оффис»);
· системой управления домашним хозяйством (концепция «умный дом»);
· методом организации доступа к внешним источникам информации и материальных ценностей (посредством сети Интернет);
· центром развлечений и т.д.

Тем не менее у этого класса сетей проявляются те же характерные признаки, что и у более крупных образований:

· как правило сеть предназначена для решения фиксированного спектра задач, практически неизменных в течение долгого времени
· весь состав оборудования принадлежит одному владельцу

Быстрый рост числа домашних сетей в последнее время можно объяснить следующими фактами:

· быстрый рост производительности вычислительных систем и снижение цен на комплектующий позволяет одному пользователю приобрести в личное владение такое количество вычислительной техники, какое ему может понадобиться для решения поставленных задач;
· при появлении нового оборудования старое обесценивается настолько, что многие пользователи, приобретая новый компьютер, оставляют у себя и предыдущий, для решения вспомогательных задач;
· технологии разработки и использования распределенных вычислений стали доступными для использования отдельными пользователями в своих целях.

В 1998 г. компания Samsung Electronics представила технологию построения домашних сетей Ноmе Wide Web (HWW). Согласно спецификации HWW, с помощью интерфейса IEEE 1394 объединяются в единую сеть компьютерные системы, бытовая электронная аппаратура, устройства коммуникаций, охранные системы, противопожарное оборудование и т. п. Обмен данными в сети происходит по протоколу IP. Графический пользовательский интерфейс выполнен в соответствии со спецификацией HTML.

Рисунок 1 -

Один из вариантов совмещения информационных потоков по технологии FireWire

Остается ожидать, что в ближайшие годы именно расширение возможностей домашних компьютерных сетей создаст условия для интенсивного развития новых технологий в сфере применения вычислительных сетей.


Другие примеры активного оборудования сетей

Кроме вышеописанных широко применяются другие специализированные и многофункциональные сетевые устройства. Число таких устройств непрерывно растет по причине удобства в эксплуатации, простоты при настройке, высоким характеристикам по скорости и качеству обслуживания запросов пользователей.

Ниже кратко описаны функции некоторых из этих устройств.

Трансивер (transiever). Трансивер - двухпортовое устройство, имеющее с одной стороны, MII интерфейс, с другой – один из средозависимых физических интерфейсов (100Base-FX, 100Base-TX или 100Base-T4). Трансиверы используются сравнительно редко, как и редко используются сетевые карты, повторители и коммутаторы с интерфейсом MII.

Конвертер (convertor). Конвертер - двухпортовое устройство, оба порта которого представляют средозависимые интерфейсы. Конвертеры, в отличие от повторителей, могут работать в дуплексном режиме. Распространены конвертеры 100Base-TX/100Base-FX.

Канал (channel). Каналом называется физический или логический путь для передачи сигналов. В контексте компьютерных сетей чаще всего встречаются упоминания каналов двух типов: коммуникационных и дисковых. Коммуникационным каналом называется маршрут, по которому происходит передача данных, речи или видеоизображения. Современные технологии передачи данных позволяют организовывать несколько коммуникационных каналов внутри одного физического кабеля.

Дисковым каналом, в конфигурации с жестким диском, называются компоненты, посредством которых осуществляется взаимодействие операционной системы с накопителем на жестком диске.

Межсетевой экран (firewall). Используя технологию потоковой фильтрации, эти устройства анализируют каждый IP-пакет по отдельности, не дожидаясь загрузки всего проверяемого файла. Наряду с минимальными требованиями к размеру используемой памяти, этот процесс не требует дополнительных затрат на восстановление потока данных и не сказывается на пропускной способности и задержках, вносимых экраном, при любых размерах проверяемых файлов.

Автономный принт-сервер (print-server). Автономный принт-сервер подключается непосредственно к среде передачи (кабельной или беспроводной) настраивается администратором сети по протоколам удаленного администрирования.

Современные автономные принт-сервера работают со многими операционными системами, такими как: Windows 95, 98, ME, NT 4.0, XP, Apple MacOS совместно с AppleTalk, Linux, Solaris, SCO Unix и NetWare 5.x native NDS. Это позволяет гибко настроить принт-сервер, несмотря на используемую сетевую среду.

Сетевое хранилище (file-server). Это компактное устройство позволяет хранить десятки тысяч изображений и документов для совместного использования их по сети, при этом, не занимая много места в офисе. Кроме того, оно обеспечивает защиту данных при помощи базы данных пользователей, а совместный доступ к папке осуществляется на основе учетной записи пользователя или группы пользователей.

Современные образцы поддерживают возможность «горячей» замены, поэтому их можно подключать и отключать от сети в любой момент времени. Строго соответствуя стандарту Universal Plug-and-Play, они могут напрямую взаимодействовать с другими сетевыми устройствами, совместимыми с UPnP.

Гибридные устройства.

Сетевые администраторы часто сомневаются, что надо использовать при объединении сетей – мост или маршрутизатор. Ведь на первый взгляд, эти устройства выполняют одни и те же действия:

· передают пакеты между сетями
· передают данные по каналам глобальных сетей

Однако мост, работающий на подуровне Управления доступом к среде Канального уровня модели OSI, «видит» только адрес узла, точнее, в каждом пакете мост ищет адрес узла подуровня Управления доступом к среде. Если мост распознает адрес, он оставляет пакет в локальном сегменте или передает его в нужный сегмент. Если адрес мосту неизвестен, он пересылает пакет во все сегменты, исключая тот, из которого пакет прибыл. Для решения таких пограничных задач разработан класс комбинированных устройств «мост-маршрутизатор» (bridge-router или brouter).

Часто применяются и другие гибридные устройства. Например, «коммутатор-маршрутизатор», «файл-сервер – принт-сервер», «межсетевой фильтр – антивирусный анализатор» и прочие.


Ячеистая топология

Сеть с ячеистой топологией обладает высокой избыточностью и надежностью, так как каждый компьютер в такой сети соединен с любым возможным участником соединения отдельным кабелем, то есть реализуется принцип «каждый с каждым» (рисунок 1).

Рисунок 1 -

Пример сети, построенной по ячеистой топологии

Сигнал от передающего узла к принимающему может проходить по разным маршрутам, поэтому разрыв кабеля не сказывается на работоспособности сети.

Нередко ячеистая топология может быть реализована частично на наиболее важных направлениях, в комбинации с остальными топологиями при построении относительно больших сетей (рисунок 2).

Высокая скорость доставки сообщений в такой сети обусловлена непосредственной пересылкой от передающего узла к принимающему или по маршруту с минимальным числом пересылок, в случае отсутствия прямого пути.

Такая топология применяется только в тех случаях, когда необходимо обеспечить максимальную надежность и скорость доставки сообщений. Поэтому изначально сети данной топологии проектировались по заказу военных.

Рисунок 2 -

Пример сети с элементами ячеистой топологии

Расширяемость сети для такой топологии – очень сложная и дорогостоящая операция, по сравнению с другими топологиями.

Чаще всего отдельные элементы этой топологии реализованы в глобальных сетях, для чего используются линии связи общего доступа. Большие затраты на прокладку кабеля компенсируются высокой надежностью и простотой обслуживания.

Ячеистая топология является весьма перспективной. Сейчас она постепенно вытесняет топологию «кольцо» в структуре сетей Sonet (рисунок 3).

Рисунок 3 -

Ячеистая структура, наложенная поверх кольца SONET


Базовые примитивы передачи сообщений

Распределение системы в отличие от централизованных имеют сложный механизм реализации межпроцессной связи.

Если централизованная система имеет возможность использовать разделяемую память, то в распределенной системе похожего ресурса нет. Соответственно, механизм семафоров, используемый в централизованной операционной системе не может быть в чистом виде реализован в распределенных вычислениях.

Основой воздействия в вычислительных системах может служить только передача сообщений. В распределенной системе, в простейшем случае, может быть использовано всего 2 примитива: послать сообщение и получить сообщение.

Одна из сложностей заключается в организации эффективной системы адресации сообщений. Первые реализации адресации используют адреса-константы, известные только выполняемым программам, а потому несовместимые с любыми другими системами.

Другим способом являлось использование физических (МАС) адресов сетевого оборудования. В этом случае малейшее изменение сети может потребовать перенастройки большого числа обслуживаемых клиентов.

Вторая проблема обеих этих адресаций заключается в том, что при использовании многозадачной операционной системы неизвестно, какому именно процессу было адресовано посланное сообщение.

Альтернативная адресная система предполагает использовать адрес из 2-х частей: часть 1 адресует машину, часть 2- адресуемый процесс в рамках операционной системе адресуемой машины.

Еще одним вариантом является назначение каждому процессу уникального адреса, несвязанного с номером машины. Это требует наличия централизованного алгоритма распределения номеров процессов, т.е. требуется наличие дополнительной рабочей станции. Расширяемость системы при данной адресации также страдает.

Также было предложено, чтобы процессы произвольно выбирали себе адреса, например, из 64-битного пространства чисел. Далее процесс должен зарегистрироваться, т.е. сообщить свой адрес всем остальным. Сделать он может это только с помощью широковещательного сообщения, что снижает производительность сети.

При организации вычислений, особенно при последовательном характере выполнения операций, каждая последующая операция может начинаться только после завершения предыдущей. Таким образом, достигается однозначность получаемого решения.

В распределенной системе это означает, что после отправки запроса на удаленное вычисление, процесс прекращает любые формы деятельности до того момента, пока будет получен ответ. Эта ситуация соответствует применению блокирующего примитива послать или получить.

Если используется неблокирующий примитив, управление возвращается процессу сразу по завершении сеанса передачи. Таким образом, многозадачная система остается многозадачной, даже в распределенной вычислительной системе.

Обычно операционные системы используют только один вид примитивов. Однако выигрыш производительности неблокирующих примитивов частично отменяется тем, что процедура передачи данных может на длительное время занять системное оборудование. Но и это обходится: например, заставить ядро операционной системы копировать сообщения во внутренний буфер, где будут обрабатываться все сетевые сообщения от процессов.

Таким образом, можно выделить еще два вида деления организации примитивов: буферизуемые и небуферизуемые, надежные и ненадежные.

Для решения проблемы надежности доставки сообщений существует три подхода. Первый заключается в том, что система не берет на себя никаких обязательств по поводу доставки сообщений. Реализация надежного взаимодействия становится целиком заботой пользователя. Второй подход заключается в том, что ядро принимающей машины посылает квитанцию-подтверждение ядру отправляющей машины на каждое сообщение. Посылающее ядро разблокирует пользовательский процесс только после получения этого подтверждения. Подтверждение передается от ядра к ядру. Ни отправитель, ни получатель его не видят. Третий подход заключается в использовании ответа в качестве подтверждения в тех системах, в которых запрос всегда сопровождается ответом. Отправитель остается заблокированным до получения ответа. Если ответа нет слишком долго, то посылающее ядро может переслать запрос специальной службе предотвращения потери сообщений.


Беспроводные сети

Технология беспроводных сетей WLAN (Wireless LAN) развивается довольно быстро. Эти сети удобны для подвижных средств в первую очередь, но находят применение и в других областях (сети с мобильными клиентами, больницы, спортивные состязания и т.д.).

Беспроводные сети имеют три варианта реализации:

· локальные вычислительные сети (на беспроводном принципе);

В этом случае единственная разница обычной сети от беспроводной заключается в отсутствие кабельной системы, однако, используемое соединение точка-точка, как правило, закреплено за помещением, но и за местоположением самого помещения. В этом случае используется бесперебойная связь. Фиксированный приемопередатчик соединяется кабелем с рабочей станцией. Прием передачи может называться точкой доступа.

· расширенные локальные вычислительные сети;

В этом случае часть сети реализуется с помощью кабельной сети, а отдельные ее участники обладают большим уровнем мобильности. В некоторых случаях беспроводным соединением может быть радиомост, между сегментами кабельной сети. Обратным примером может служить беспроводная сеть, в которой кабелем соединяется система серверов.

· мобильные сети;

Это сети мобильных компьютеров. В более общем случае – это система вычислительных комплексов объединенная в сеть с помощью любого вида беспроводной технологии.

На текущий момент более популярными являются следующие виды беспроводных технологий:

· радиосоединение;
· узкополосное (одна радиочастота на всех)
· широкополосное (набор частот)

Наиболее проработанный и традиционный тип носителя беспроводной связи, несмотря на то, что технология дает плохой уровень защиты от элекромагнитных излучений.

 инфракрасное излучение;

Используется прямой сигнал и отраженный и для этого достаточно низкая скорость распространения сигнала, но высокая надежность передачи сигнала.

· лазерное излучение;

Используется только в случае наличия прямой видимости приемника и передатчика, направленными между двумя зданиями. Достаточно высокая скорость, но низкая надежность из-за того что луч может рассеиваться. Требует прямую видимость между оборудованием.

· микроволновое соединение;

Может использоваться как разновидность радиосоединения. Считается более дешевой технологией. Недостатки: низкая скорость передачи данных и малый радиус действия.

· использование сотовых сетей общего доступа;

Наиболее удобен для реализации удаленного подключения мобильной станции пользователя к сети предприятия, осуществляющего данный вид услуг.

· спутниковые системы;

Самая глобальная из беспроводных систем по охвату территории. Недостатки: высокая стоимость передающего оборудования и арендная плата за трафик через спутник.

В последние годы было принято большое количество стандартов, регламентирующих параметры различных видов беспроводных соединений (рисунок 1). Это дало толчок к разработке и широкому применению мобильных устройств связи и сопутствующих устройств.

Рисунок 1 -

Сферы использования беспроводных соединений

К сожалению беспроводные, особенно мобильные каналы крайне ненадежны. Потери пакетов в таких каналах весьма вероятны. Понижение скорости передачи, как правило, не приводит к понижению вероятности потери. Кроме того, маршруты между отправителем и получателем неоднородны и могут включать в себя сегменты с различными методами передачи данных (проводные и беспроводные).

Влияние излучений передающих устройств на здоровье пользователей сети, также вызывает серьезную озабоченность.


Введение

Целью разработки цикла изданий под общим названием «Основы сетевых технологий» является создание сквозного учебного пособия, объединяющего однонаправленные дисциплины для студентов специальности I-53 01 02 – «Автоматизированные системы обработки информации» специализации

Цикл изданий делится на следующие составные части:

Часть 1. Аппаратное и программное обеспечение сетей

Часть 2. Бизнес-Internet технологии

Часть 3. Диагностика и обслуживание сетей

Часть 4. Администрирование и настройка компьютерных сетей

Содержание данной части учебного пособия соответствует лекционному курсу «Аппаратное и программное обеспечение сетей» учебного плана студентов специальности I-53 01 02 – «Автоматизированные системы обработки информации» (Образовательный стандарт: РД РБ 02100.5.111-98).

В пособии излагаются базовые концепции построения компьютерных сетей на базе современных технологий. Материал изложен в виде кратких ответов на вопросы учебной дисциплины и снабжен необходимым иллюстративным материалом. Для успешного усвоения изложенного материала необходим базовый набор знаний об архитектуре современных вычислительных систем. Для более глубокого изучения, затрагиваемых в пособии тем необходимо изучение специализированной литературы.


Виды активного оборудования сетей

К активному оборудованию сетей относятся все виды оборудования, используемые для поддержки формы сигнала, ретрансляции, выбора или изменения маршрута продвижения пакета, преобразование формата, передаваемых данных, а также специализированное оборудование объединения и обслуживания сетей.

Разные авторы к активному оборудованию сетей относят различные устройства. Вот приблизительный их перечень:

· трансивер (TRANSIEVER);
· сетевая карта (NETCARD);
· модем (MODEM);
· повторитель (REPEATER);
· конвертер (CONVERTOR);
· концентратор (HUB, MAU);
· коммутатор (SWITCH);
· мосты (BRIDGE);
· маршрутизаторы (ROUTER);
· канал (CHANNEL);
· шлюзы (GATEWAY, BRANDMAUER).

Лучшим способом для понимания отличий между сетевыми адаптерами, повторителями, мостами, коммутаторами, маршрутизаторами и другими активными сетевыми устройствами является рассмотрение их работы относительно модели OSI.

Соотношение между функциями части из этих устройств и уровнями модели OSI показано на рисунке 1. Например, повторитель, который регенерирует сигналы, за счет чего позволяет увеличивать длину сети, работает на физическом уровне.

Функции большинства других устройств могут не умещаться в рамках одного уровня модели OSI. Например, сетевой адаптер работает на физическом и канальном уровнях. К физическому уровню относится та часть функций сетевого адаптера, которая связана с приемом и передачей сигналов по линии связи, а получение доступа к разделяемой среде передачи, распознавание МАС-адреса компьютера - это уже функция канального уровня.

Рисунок 1 -

Соответствие функций коммуникационного оборудования модели OSI

Следует знать, что чем ниже устройство находится по уровню модели оси, тем больше его производительность или ошибки в работе сказываются на производительности сети.

Единственная сеть ЛВС, которая не требует применения активного оборудования – это односегментная шина.

Назначение, функции и особенности применения сетевых устройств, которые широко применяются на текущий момент, рассмотрены далее в этой главе.


Виртуальные частные сети

Виртуальная частная сеть – Virtual Private Network, VPN, отличается от вышеперечисленных систем важным свойством: владельцы сети не являются владельцами всех ста процентов сетевого оборудования, используемых в ее структуре и тем не менее VPN – изолированная структура, это выражается в следующем:

· Независимый выбор сетевых технологий. Выбор ограничивается только возможностями производителей оборудования.
· Независимая система адресации.
· Предсказуемая производительность. Собственные линии связи гарантируют заранее известную пропускную способность между узлами предприятия или коммуникационными устройствами.
· Максимально возможная безопасность. Отсутствие связей с внешним миром ограждает сеть от атак извне и существенно снижает вероятность «прослушивания» трафика по пути следования.

Основную часть функций по поддержанию VPN выполняют пограничные устройства сети – либо потребителя, либо поставщика.

Сеть VPN, характеризуется, во-первых, тем, какие свойства объекта имитируются, во-вторых, степенью приближенности к оригиналу и, в-третьих, используемыми средствами имитации.

Практически все сети VPN имитируют собственные каналы в сетевой инфраструктуре поставщика, предназначенной для обслуживания множества клиентов.

Виртуальная частная сеть может имитировать не только физические каналы, но и более высокоуровневые свойства сети. Так, может быть спроектирована сеть VPN, способная поддерживать IP-трафик клиента с созданием эффекта изолированной IP-сети. В этом случае VPN производит некоторые дополнительные сетевые операции над клиентским трафиком – сбор разнообразной статистики, фильтрацию и экранирование взаимодействий между пользователями и подразделениями одного и того же предприятия и т. п.

Имитация сервисов прикладного уровня встречается в VPN гораздо реже, чем имитация собственно транспортных функций, но также возможна.

По приближенности сервисов, предлагаемых VPN, к свойствам сервисов частной сети оцениваются: безопасность, качество обслуживания, независимость адресного пространства.

По технологии организации VPN можно разделить на следующие:

Сети VPN на основе разграничения трафика

В технологиях разграничения трафика используется техника постоянных виртуальных каналов, обеспечивающая надежную защиту трафика каждого клиента от намеренного или ненамеренного доступа к нему других клиентов публичной сети. К этому типу технологий относятся: ATMVPN; Frame Relay VPN; MPLS VPN.

Защита данных достигается благодаря тому, что несанкционированный пользователь не может подключиться к постоянному виртуальному каналу, не изменив таблицы коммутации устройств поставщика услуг, а значит, ему не удастся провести атаку или прочитать данные. Свойство защищенности трафика является естественным свойством техники виртуальных каналов, поэтому сервисы ATM VPN и Frame Relay VPN являются на самом деле не чем иным, как обычными сервисами PVC сетей ATM или Frame Relay.

Сети VPN на основе шифрования

Еще одним классом технологий VPN являются сети VPN на основе шифрования. Они применяются в тех случаях, когда VPN строится в дейтаграммной сети, которая не может обеспечить разграничения трафика. Именно такой сетью является классическая IP-сеть. Сегодня базовой технологией VPN на основе шифрования является технология IPSec, с помощью которой создается инфраструктура защищенных каналов.

Из всех свойств частной сети виртуальные частные сети на основе шифрования имитируют только ее защищенность и изолированность адресного пространства.

Технологии VPN на основе шифрования можно применять совместно с технологиями VPN на основе разделения трафика для повышения уровня защищенности виртуальных частных сетей. Технологии VPN на основе разделения трафика иногда критикуют за недостаточный уровень безопасности, считая, что отсутствие шифрования трафика позволяет персоналу поставщика услуг получить несанкционированный доступ к данным. Действительно, такая вероятность существует, поэтому клиент услуг VPN на основе разделения трафика, может самостоятельно повысить защищенность своего трафика, применив технику шифрования.


Волноводы

Если частота передачи достаточно высока, то электрическая и магнитная составляющие сигнала могут распространяться в свободном пространстве (не требуется сплошной проводник). Для того чтобы сигнал распространялся в нужном направлении с наименьшими помехами и потерями, иногда используют такую среду как волновод.

Виды волноводов:

· металлический волновод;

Металлический волновод представляет собой полую металлическую трубку круглого (рисунок 1) или прямоугольного сечения. Плоская (для прямоугольного волновода) или цилиндрическая (для круглого) электромагнитные волны могут распространяться по волноводу, отражаясь от стенок.

Рисунок 1 -

Структура строения волноводов

В результате интерференции отраженных под определенными углами волн образуются направляемые волновые структуры с синусоидальным или близким к нему распределением поля в поперечном сечении. При этом амплитуды направляемых волн описываются функциями от поперечных координат. Такие волновые структуры называются модами (от англ. mode). В кабеле эти моды оказались мешающими, паразитными. В волноводе же при отсутствии центрального провода уже не может распространяться "кабельная" волна, но одна из мод может быть использована для передачи сигнала. Одномодовый режим работы можно осуществить, например, для круглого волновода при 1,3 d < l < 1,7 d, где d – внутренний диаметр волновода. Заметим, что здесь l = c / f. Она неравна длине волны моды в волноводе, которая имеет другое значение.

Из указанного условия видно, что в одномодовом режиме волновод может работать только в полосе частот, причем для каждой полосы частот необходим свой волновод.

Металлические волноводы получили применение в качестве линий передачи сантиметровых и миллиметровых волн. Центры полос одномодовых режимов работы стандартных волноводов соответствуют l = 10 см, 3,2 см и 8 мм. При уменьшении длины волны уменьшаются поперечные размеры волновода и возрастают потери мощности волны в стенках. Поэтому для волн с длинами порядка миллиметра и короче волноводы применяются лишь на очень короткие расстояния.

Металлические волноводы применяют на частотах от 2 до 110 ГГц для соединения сверхвысокочастотных передатчиков и приемников с антеннами. В волноводы под повышенным давлением закачивается сухой воздух или чистый азот. Это делается с целью снижения влажности, поскольку в сверхвысокочастотном диапазоне она существенно увеличивает затухания. Прокладка волноводной линии при условиях, которые требуется выполнить (прямолинейность трассы и др.), оказывается очень дорогостоящей, поэтому их применение не стало массовым.

· диэлектрический волновод;

Диэлектрический волновод – это стержень из диэлектрического материала, в котором могут распространяться электромагнитные волны с малыми потерями. Для волн миллиметрового диапазона это полистирол и полиэтилен (фторопласт), малопоглощающие, так называемые неполярные диэлектрики. Электромагнитная волна может распространяться внутри стержня, отражаясь от его границ под углом полного внутреннего отражения. Как и в металлическом волноводе, при интерференции образуются направляемые волны – моды. При этом нет потерь мощности в металле, но имеют место потери в диэлектрике. Эти потери все же достаточно велики, поэтому диэлектрические волноводы получили применение для передачи сигнала на миллиметровых волнах на сравнительно короткие расстояния (метры, десятки метров).

Однако диэлектрические волноводы оказались чрезвычайно перспективными для применения в диапазоне световых волн, точнее, в диапазоне инфракрасных волн с длиной волны порядка микрометра. Они представляют собой волокна из стекла, поэтому получили название оптических волокон или волоконных световодов.

В современных высокоскоростных сетях используется волоконно-оптический кабель, по сути являющийся диэлектрическим волноводом.


Вызов удаленных процедур

Идея вызова удаленных процедур (Remote Procedure Call - RPC) состоит в расширении механизма передачи управления и данных внутри программы, выполняющейся на одной машине, на передачу управления и данных через сеть. Таким образом, программист освобождается от рассмотрения и реализации механизма сетевого сообщения для своей программы распределенного вычисления, полностью отдавая эту проблему на откуп RPC.

В реализации RPC необходимо минимум по одному процессу на каждой машине для генераций приема-передачи запроса, а также трансляции ответа программе-отправителю, такой дополнительный процесс называется стабом.

Взаимодействие программных компонентов при выполнении удаленного вызова процедуры иллюстрируется рисунком 1.

Рисунок 1 -

Механизм Remote Procedure Call

Этапы RPC:

1 Вызов стаба
2 Подготовить буфер
3 Упаковать параметры
4 Заполнить поле заголовка
5 Вычислить CRC сообщения
6 Прерывание к ядру
7 Очередь пакета на выполнение
8 Передача сообщения по шине контроллеру
9 Время передачи по сети
1 Получить пакет от контроллера
2 Процедура обработки прерывания
3 Вычисление CRC
4 Переключение контекста в пространство пользователя
5 Выполнение серверного стаба

Если один из процессов в момент проведения вычислений потерпит крах, возникает следующая ситуация: если процесс, породивший запрос, терпит аварию, то запрос считается осиротевшим; если передающий процесс потерпел аварию, то процесс считается обездоленным родителем. Обработка, идентификация и разрешение этих ситуаций возлагается на механизм RPC. В идеале RPC должен функционировать правильно и в случае отказов.

Рассмотрим следующие классы отказов и реакции системы на них:

1 Клиент не может определить местонахождения сервера, например, в случае отказа нужного сервера. В этом случае в ответ на запрос клиента поступает сообщение, содержащее код ошибки.

2 Потерян запрос от клиента к серверу. Самое простое решение - через определенное время повторить запрос.

3 Потеряно ответное сообщение от сервера клиенту. Одним из возможных решений является приведение всех процедур к идемпотентному виду. Однако на практике это не всегда удается, поэтому может быть использован другой метод - последовательная нумерация всех запросов клиентским ядром. Ядро сервера запоминает номер самого последнего запроса от каждого из клиентов, и при получении каждого запроса выполняет анализ - является ли этот запрос первичным или повторным.

Идемпотентной называется процедура, запрос на выполнение которой можно повторить несколько раз, и результат при этом не изменится. Одно из возможных решений: приведение всех процедур к идемпотентному виду.

4 Клиент потерпел аварию после отсылки запроса. RPC-запрос становится ненужным, т.к. его результаты никто не ожидает. Такой процесс-сироту можно: уничтожить, отменить по тайм-ауту или перевоплотить

5 Сервер потерпел аварию после запроса. В данном случае имеет значение, когда произошел отказ - до или после выполнения операции.

Существует три подхода к этой проблеме:

· ждать, пока сервер перезагрузится и повторить запрос
· сразу сообщить об ошибке (гарантия, что запрос пользователя выполнится не более 1 раза)
· сервер не несет ответственности

Ни один из описанных подходов решения этой проблемы не является приемлемым с точки зрения клиента.


Гетерогенные сети

Построение крупной сети на основе одной сетевой платформы - это большая редкость. Обычным состоянием для любой вычислительной сети средних и крупных размеров является сосуществование различных стандартов и базовых технологий.

Внедрение новых технологий, таких как Fast Ethernet или Gigabit Ethernet, не означает, что из сети мгновенно вытесняются их предшественники, например, 10-Мегабитный Ethernet, Token Ring или FDDI, так как в эти технологии были сделаны огромные капиталовложения. Поэтому трудно рассчитывать на вытеснение в обозримом будущем всех технологий в пользу какой-либо одной.

Под гетерогенностью (неоднородностью) сети понимают несовместимость двух узлов, принадлежащих к одной сети, либо к смежным сегментам сети по одному или нескольким логическим признакам:

· формат кадра сети;
· способ шифрования;
· тип операционной системы;
· используемая модель безопасности и пр.

Самым распространенным средством объединения разнородных транспортных технологий является использование единого сетевого протокола во всех узлах корпоративной сети. Единый сетевой протокол работает поверх протоколов базовых технологий и является тем общим стержнем, который их объединяет. Именно на основе общего сетевого протокола маршрутизаторы осуществляют передачу данных между сетями, даже в случае очень существенных различий между их базовыми сетевыми технологиями.

В другом случае для обмена информации требуется применение посредника. Для организации бессбойного обмена на прикладном, представительском, сеансовом, транспортном, а иногда и сетевом уровне (согласно модели ISO) данных клиента. В качестве такого посредника может использоваться специализированное оборудование, перечисленное в главе 6.

При использовании шлюзов на базе современных сетевых операционных систем следует знать, что поддержка всех возможных видов и служб для этой цели нецелесообразно, т.к. весьма ресурсоемко.

Считается, что основной причинной возникновения гетерогенных сетей является объединение разнородных рабочих станций в единую сеть для реализации сетевого обмена.

Например, при объединении в сеть нескольких архитектурных поколений и платформ вычислительной техники. Тогда «букет» операционных систем в пределах одной сети может достигать 10-15 единиц.

Степень неоднородности сетевых технологий существенно возрастает при необходимости объединения локальных и глобальных сетей, имеющих, как правило, существенно различные стеки протоколов. Хотя в последние годы и наметилась тенденция к сближению методов передачи данных, используемых в этих двух типах вычислительных сетей, различия между ними все еще велики. Поэтому в пределах одной корпоративной сети обычно используется большой набор разнообразных базовых топологий и задача объединения их всех в единую сеть, прозрачную для транспортных операций конечных узлов, требует привлечения специальных методов и средств.

Взаимодействие разнородных сегментов в гетерогенных сетях осуществляется по схеме замещения запросов одной природы, (поступающие от передатчика) распознаваемая второй стороной сетевого обмена.

В этом случае оба участника сетевого обмена не знают о гетерогенной природе второго абонента и обращаются с ним как с себе подобным.

Самая большая проблема появляется при распределении пользовательских прав доступа к сетевым ресурсам. Иногда не возможно связать в автоматическом режиме даже такие операционные системы компании Microsoft с ядром NT как Windows 4.0 и Windows 2000, не говоря уже о реализации сервисов Active Directory.


Гигабитные сети EtherNet

Разработка стандарта Gigabit Ethernet началась в марте 1996 года, когда комитет IEEE 802.3 одобрил проект стандарта Ethernet для сетей, которые способны работать со скоростью 1 Гбит/с. Группа разработчиков предложила проект стандартизации IEEE 802.3z Gigabit Ethernet. В июле 1997 года был создан предварительный стандарт передачи сигналов в сети с волоконно-оптическими каналами и сегментами, находящимися на небольших расстояниях и соединенными посредством медных проводов, который утвердили в 1999 году. Параллельно шла работа специального комитета (802.3ab) для разработки стандарта передачи сигналов в медной витой паре совместимого с Gigabit Ethernet.

При разработке учитывался тот факт, что в сети Ethernet с протоколом CSMA/CD временная задержка, зависящая от максимальной длины кабеля, влияет на минимальный размер кадра.

В сетях Ethernet со скоростью передачи 10 Мбит/с максимальная длина кабеля составляла 2,5 км. В Ethernet со скоростью передачи 100 Мбит/с для сохранения масштаба кадра максимальная длина кабеля между двумя узлами была уменьшена до 250 м, а максимальное расстояние от станции до концентратора – до 100 м.

Если размер кадра не изменяется, максимальное расстояние передачи по медному проводу между двумя узлами в сети Gigabit Ethernet не должно превышать 25 м, чего недостаточно для эффективного использования данной технологии.

С целью обеспечения совместимости с предыдущими версиями Ethernet, в которых расстояние передачи 100 м, в стандарте Gigabit Ethernet все кадры, длина которых меньше 512 байт, заполняются специальными дополнительными символами, что необходимо для функционирования механизма обнаружения коллизий. Такой метод называется расширением носителя.

Рисунок 1 -

Формирование кадра данных по методу расширения носителя

Очевидно, что, когда фактическое количество передаваемых данных меньше или равно 512 байт, подобная передача малоэффективна, а производительность сети ненамного выше производительности Fast Ethernet.

Другой метод, предназначенный для повышения производительности, известен как передача пакетов блоками.

При передаче пакетов блоками станция, имеющая два и больше пакетов для передачи, отправляет первый пакет (если его длина меньше 512 байт) с использованием техники расширения носителя. Если этот пакет передается без коллизий, то все последующие пакеты поочередно отсылаются в течение времени, необходимого для передачи блока длиной 1500 байт. Если станция не успеет полностью переслать какой-либо из пакетов, она это сделает по истечении данного периода (смотри рисунок 2).

Рисунок 2 -

Технология передачи пакетов блоками

Если вы применяете сеть Gigabit Ethernet с целью соединения двух коммутаторов ЛВС или с целью соединения рабочих станций и серверов непосредственно с портами коммутаторов ЛВС, то коллизий в таком соединении не будет. Другими словами, для гарантии того, что коллизии будут обнаружены в течение заранее определенного периода времени, нет необходимости расширять кадр, то есть применять технику передачи блока пакетов не требуется.

Хотя сеть Gigabit Ethernet и не использовали все свои возможности, уже реализована технология 10 Gigabit Ethernet (IEEE 802.3ae, 10GBase-LW или 10GBase-ER). Этот стандарт утвержден в июне 2002 года и в случае использования для построения региональных каналов соответствует спецификациям OC-192c/SDH VC-4-46c (WAN). В протоколе 10 Gigabit Ethernet предусмотрен интерфейс chip-to-chip (802.3ae-XAUI - буквы ае означают здесь Ethernet Alliance - www.10gea.org). Такие скоростные каналы могут использоваться и в локальных сетях для соединения переключателей сетевых кластеров. Соединение организуется по схеме точка-точка.

Сейчас обсуждается возможность построения сетей 100 Gigabit Ethernet.


Глобальные вычислительные сети

Глобальные вычислительные сети (Global/World Aref Network - GAN/WAN) охватывают максимальные территории. Теоретически эти сети могут объединить все вычислительные системы на земном шаре для решения одной общей задачи.

Глобальные сети решают задачи управления хозяйством в наиболее крупном размере, например, расписание движения международного транспорта, предварительный заказ билетов, бронирование мест в гостинницах, Internet-магазины и т.п.

Глобальные сети можно разделить на распределенные и централизованные. Централизованные лучше защищены от несанкционированных акций, распределенные отличаются большей надежностью при передаче данных. Распределенные отличаются большей живучестью.

Свойства глобальных сетей удобнее рассматривать в сравнении их с локальными вычислительными сетями:

· Протяженность и качество линии связи

Локальные сети, по определению, отличаются от глобальных небольшими расстояниями между узлами сети. Это в принципе делает возможным использование в локальных сетях более качественных линий связи.

· Сложность методов передачи данных

В условиях низкой надежности физических каналов в глобальных сетях требуются более сложные, чем в локальных сетях, методы передачи данных и соответствующее оборудование.

В глобальных сетях считается, что соединения не могут быть постоянными. Нередко используются коммутируемые соединения, но и другие виды соединений имеют ярковыраженный временный характер.

· Число информационных ресурсов в глобальных сетях значительно больше.
· Скорость обмена данными в локальных сетях, существенно выше чем в глобальных.
· Высокие скорости обмена данными позволяет предоставлять пользователю в локальных сетях более широкий спектр услуг.

Глобальные сети нередко используются сетями меньшего масштаба в качестве средства связи между локальными, корпоративными и другими видами сетей.

Рисунок 1 -

Обмен данными между сетями с использованием структуры WAN

Рисунок 1 -

Взаимодействие разноуровневых типов сетей


Городские сети

Местные, региональные, муниципальные или городские сети (Site/Metropolitan Area Network – SAN/MAN) - это структура, объединяющая компьютеры и вычислительные системы, сосредоточенные на территории одного региона, включающего в себя общие объекты или субъекты управления.

Такие крупные системы практически невозможно разработать и внедрить одному собственнику, тем более, что их окупаемость достаточно невелика. Сети SAN/MAN решают задачи управления хозяйством в границах некоторого географического региона. К их числу можно отнести: расписание движения общественного транспорта, управление рынком вакансий, функция информирования населения, Internet магазины и т.п.

Современная сеть SAN/MAN имеет диаметр около 40-50 км, обладает двумя или более маршрутами доставки сообщения между узлами сети, применяет широкий спектр современного коммуникационного оборудования.

Можно утверждать, что чаще всего сети SAN/MAN – это пример сообщества, состоящего из более мелких сетей: локальных, частных, домашних, а также вычислительных систем отдельных пользователей.

Способы их объединения могут быть различными, основываться на применении различных типов передающих сред и иметь различные источники финансирования. Тем не менее, мотив объединения всегда один – ускорение и удешевление информационного обмена и получения доступа к сетевым услугам.

Желание пользователей получить доступ к сфере развлечения, в том числе сетевому телевещанию и компьютерным играм особенно часто приводит к бурному росту сетей данного вида.

Следует заметить, что качество и количество технологий, применяемых для организации связи между сетями непрерывно растет. Одновременно меняются требования к надежности и безопасности передаваемой информации. Таким образом сети SAN/MAN сегодняшнего дня сильно отличаются от своих предшественников, а через год-другой они сами уже могут потребовать серьезной модернизации.

Детальное рассмотрение технологии SAN/MAN не являются предметом рассмотрения данного учебного пособия.

Самым распространенным примером муниципальной сети является система кабельного телевидения. Она стала правопреемником обычных антенных телесетей в тех местах, где по тем или иным причинам качество эфира было слишком низким. Общая антенна в этих системах устанавливалась на вершине какого-нибудь холма, и сигнал передавался в дома абонентов.

Вначале стали появляться специализированные, разработанные прямо на объектах сетевые структуры. Затем компании-разработчики занялись продвижением своих систем на рынке, начали заключать договоры с городским правительством и в итоге охватили целые города. Следующим шагом стало создание телевизионных программ и даже целых каналов, предназначенных только для кабельного телевидения.

Когда Интернет стал привлекать к себе массовую аудиторию, операторы кабельного телевидения поняли, что, внеся небольшие изменения в систему, можно сделать так, чтобы по тем же каналам в неиспользуемой части спектра передавались (причем в обе стороны) цифровые данные. С этого момента кабельное телевидение стало постепенно превращаться в муниципальную компьютерную сеть. В первом приближении систему MAN можно представить себе такой, как она изображена на рисунке 1. На этом рисунке видно, что по одним и тем же линиям передается и телевизионный, и цифровой сигналы. Во входном устройстве они смешиваются и передаются абонентам. Мы еще вернемся к этому вопросу позднее.

Рисунок 1 -

Муниципальная сеть на базе кабельного ТВ

Впрочем, муниципальные сети — это не только кабельное телевидение. Недавние разработки, связанные с высокоскоростным беспроводным доступом в Интернет, привели к созданию других MAN, которые описаны в стандарте IEEE 802.16.


Кабель "витая пара"

Витая пара так же как и коаксиальный кабель применяется для передачи электромагнитных сигналов. В этом случае для компенсации внешних электромагнитных полей применяется метод естественной компенсации. Помеха отклоняет амплитуду сигнала на один провод пары и компенсирует его за счет вторичной наводки с обратным знаком на второй провод пары. Чем больше число витков на единицу длины, тем эффективнее работает данный принцип. Технологическое изготовление витой пары любой категории немного дешевле, чем изготовление коаксиального кабеля, однако, применение сложной схемы подключения делает более дорогим применение и монтаж.

Витая пара делится на:

· экранированную (shielded twisted pair – STP);
· изолированную (screened twisted pair - ScTP)
· неэкранированную (unshielded twisted pair – UTP).

Экранированная витая пара (STP) намного дороже, поэтому на текущий момент проектирование не применяется.

Рисунок 1 -

Витая пара STP, ScTP и UTP

Витую пару UTP принято классифицировать по категориям. В качестве UTP категории 0 может быть использован двойной провод в жесткой оболочке, применяемый в аналоговых сетях, например телефонных. Сравнительно недавно, одновременно с разработкой стандартов для гигабитных технологий передачи данных, производители стали предлагать кабели с улучшенными частотными свойствами, которые стали позиционироваться как кабели категорий 5e, 6 и 7. Электрические характеристики этих кабелей значительно превосходят характеристики других кабелей UTP (рисунок 2).

Витую пару применяют в топологиях: кольцо, звезда, ячеистая. Максимальный скоростной режим для современных локальных сетей с использованием UTP определяется как 1 Гбит/с.

Примеры сетевых архитектур на базе «витой пары»

Сетевой стандарт | Тип кабеля | Тип кода | Метод доступа | Максимальная длина сегмента, м | Максимальная скорость, Мбит/с
1Base-5 (starlan) | UTP Cat 2 | манчест. | CSMA/CD | 250 | 1
ArcNet | UTP Cat 2 |  | маркер | 125 | 20
AppleTalk | UTP Cat 3 |  | CSMA/CA | 1500 | 0,23
10Base-T | UTP Cat 3 | манчест. | CSMA/CD | 100 | 10
100VGAnyLAN | UTP Cat 3 | 5B/6B | приоритет | 100 | 100
100Base-T4 | UTP Cat 3 | 8B/6T | CSMA/CD | 100 | 100 (4x25)
100Base-T2 | UTP Cat 3 | 4B/5B | CSMA/CD | 100 | 100 (2x50)
100Base-TX | UTP Cat 5 | 4B/5B | CSMA/CD | 100 | 100
TokenRing | STP IBM T 1,2 | манчест. | маркер | 366 | 4
TokenRing | UTP Cat 3,4 | манчест. | маркер | 366 | 16
1000Base-CX | STP CX | 8В/10B | CSMA/CD | 25 | 1000
1000Base-TX | UTP Cat 5e,6,7 | 8В/10B | CSMA/CD | 100 | 1000 (4x250)

Рисунок 2 -

Зависимости затухания сигнала (Attenuation) и перекрёстных помех (NEXT) для UTP категорий 5 и 6

Для коммуникации применяется комбинация настенных розеток, в том числе встроенные в pach-панели, и соединительные штекеры
RJ-45 (рисунок 3), в устаревших системах (например, ArcNet) - RJ-11.

Рисунок 3 -

Кабель «витая пара» c коннектором RJ-45

Для соединения настенной розетки с сетевым адаптером или pach-панели с хабом применяются кабели patch-cord (прямая расшивка).

Для соединения между хабами или между двумя сетевыми адаптерами применяются кабели cross-cord (перекрестная расшивка).


Классификация сетевого программного обеспечения

К понятию сетевого программное обеспечения следует относиь все виды исполняемых программных кодов, служебных библиотек, наборов баз данных и приложений, используемых для управления, настройки сетевого оборудования, эмуляции виртуальных сетевых устройств, серверов и т.д.

С точки зрения, реализации и принципов работы все сетевое программное обеспечение можно разделить на три класса:

· сетевое программное обеспечение локального действия;
· сетевое программное обеспечение для совместного использования (разделение ресурсов);
· распределенное сетевое программное обеспечение (распределенное, хранение и/или обработка данных).

Сетевое программное обеспечение локального действия. Эти программы решают задачи в пределах узла или активного оборудования локальной вычислительной сети. Их работа не связана с передачей информации по сети, но качество их работы может существенно снизить или повысить производительность сетевого оборудования.

К числу подобных программных систем можно отнести:

· драйвера сетевых устройств;
· локальные конфигураторы оборудования;
· программы по обслуживанию сетевых устройств.

Сетевое программное обеспечение для совместного использования. Это наиболее широкий класс ПО. Пользователь, как правило, сталкивается с ними и работает в среде данных программ.

К их числу можно отнести:

· сетевые интерфейсы операционных систем;
· многопользовательские версии программного обеспечения (Microsoft Office, базы данных SQL);
· клиентские оболочки сетевого программного обеспечения (браузеры, почтовые клиенты, системы антивирусной защиты);
· менеджеры сетевых ресурсов (сетевые файловые системы, web-сервера, почтовые сервера и прочее);
· протоколы сетевого обмена и т.д.

Распределенное сетевое программное обеспечение. Данный вид программного обеспечения подразумевает распределенную обработку и/или хранение информации. Географическое положение сервера относительно клиента, как правило, не имеет значения.

Можно привести такие примеры:

· чат сервера (ICQ, MAIL.RU);
· игровые сервера (спортивные симуляторы, виртуальные казино, виртуальные пространства боевых состязаний многие другие);
· поисковые сервера (Yandex, Rambler, Google, TYT);
· системы распределенного вычисления (распределенный рендеринг, расчет графической или научной информации).

Рисунок 1 -

Принципиальная схема кластера

Все эти три класса сетевого программного обеспечения жестко связаны друг с другом, либо используют друг друга в процессе работы. Например, локальные конфигураторы могут получать параметры для изменения режима работы устройств методом взаимодействия с сетевыми протоколами.

Права пользовательского доступа в каждом из этих классов могут настраиваться с помощью индивидуальных средств, либо базироваться на общесистемных алгоритмах авторизации и разграничения доступа. Т.е. системы авторизации доступа программ локального действия могут работать по алгоритму:

1 Локальный ввод данных.
2 Удаленная проверка.
3 Разрешение локального и/или удаленного допуска.

По вышеупомянутым и некоторым другим причинам любую из анализируемых программ бывает довольно трудно однозначно отнести к тому или иному классу. Взаимодействие с локально установленным программным обеспечением, как правило, еще больше усложняет картину, а иногда и вообще делает бессмысленным сетевое взаимодействие.


Классификация сетей

Классификаторы компьютерных сетей многочисленны и, нередко, охватывают несмежные и/или пересекающиеся области (рисунок 1).

С точки зрения масштаба охвата территории, а также функционального назначения сетей, все сети можно разделить на следующие виды:

· глобальные вычислительные сети;
· городские (муниципальные) сети;
· локальные вычислительные сети;
· корпоративные вычислительные сети;
· частные вычислительные сети;
· виртуальные частные вычислительные сети;
· домашние сети.

С точки зрения организации способа передачи и форм сигналов сети можно разделить следующим образом:

· кабельные:
1. оптические;
2. электрические;
· беспроводные;
1. радиосигналы;
2. лазер;
3. инфракрасные системы;
4. микроволновые системы;
5. сети сотовых операторов.

По функциональной направленности сети можно разделить:

· сети управления производством;
· сети информатизации и оповещения;
· сети с совместным использованием данных.

По методу организации доставки данных:

· сети с единственным маршрутом;
· маршрутизируемые системы с коммутацией пакетов;
· маршрутизируемые системы с коммутацией потоков (каналов).

Применение сетей и связанных с ними технологий растет, поэтому приведенный перечень далеко не полон.

В течение жизненного цикла сеть может перейти из одного типа в другой без серьезных изменений в своей структуре и оборудовании клиентской части. Такая ситуация изображена на рисунке 2.

Рисунок 1 -

Сферы применения, стандарты и технологии кабельных сетей

а)

б)

Рисунок 2 -

Изменение типа сети с одноранговой на терминальную систему

а) обычная информационная сеть

б) сеть с использованием терминалов


Коаксиальный кабель

Коаксиальный кабель (COAX) применяется для передачи электромагнитных сигналов. Это наиболее дешевый вид среди передачи данных представляет собой центральную медную жилу в защитной оболочке поверх которой нанесена металлическая оплетка и все защищено внешней защитной оболочкой (рисунок 1). Для обеспечения большей гибкости центральная жила может быть набрана из нескольких проводов малого сечения. Используется при топологии шина, то есть должно быть обязательное использование терминаторов.

Различают два вида коаксиального кабеля: толстый (около 1 см в диаметре) и тонкий (около 5 мм в диаметре).

Тонкий коаксиальный кабель применяется для монтажа во внутренних помещениях, а толстый для магистральной линий внутри зданий и между ними (в шахтах, тоннелях и в пленумных полостях).

Встречается реализация коаксиального кабеля с дополнительным внешним экраном. Он толще, дороже и сложнее при монтаже, а потому сфера его применения крайне ограничена.

Если применять коаксиальный кабель для прокладки между зданиями различают два вида:

· для прокладки в туннелях, шахтах или коробах;
· для воздушного монтажа (в этом случае с кабелем сращивают специальный тонкий металлический трос).

Эффективная длинна сегмента зависит от удельного сопротивления кабеля, толщины центральной жилы и типа материала, который идет на изготовление центральной жилы.

Например, при удельном сопротивлении 50 Ом (Novell/Ethernet) медный коаксиальный кабель имеет эффективную длину: тонкий около 200 м, толстый около 500 м. При удельном сопротивлении 93 Ом (ArcNet) – более 610 м.

Для подключения сетевого адаптера к коаксиальному кабелю используются высокочастотные разъемы. Тип соединения зависит от типа кабеля: тонкий подключается в разрыв с помощью Т-коннектора, а для толстого применяется контактная врезка (то есть на кабель устанавливается специальный разъем типа «вампир» или «зуб», который в свою очередь подключается к сетевому адаптеру с помощью внешнего трансивера) (рисунок 2).

Возможности коаксиального кабеля пока не исчерпаны современными сетевыми технологиями, таким образом его использование в обозримом будущем будет продолжаться (таблица 1).

Рисунок 1 -

Структура коаксиального кабеля

а) б)

Рисунок 2 -

Подключение коаксиального кабеля к сетевому адаптеру:

а) тонкий коаксиальный кабель; б) толстый коаксиальный кабель

Таблица 1 - Примеры сетевых архитектур на коаксиальном кабеле

Сетевой стандарт | Тип кабеля | Волновое сопротивление Ом | Метод доступа | Максимальная длина сегмента, м | Максимальная скорость, Мбит/с
10Base5 | RG-8/RG-11 | 50 | CSMA/CD | 500 | 10
10Base2 | RG-58 | 50 | CSMA/CD | 185 | 10
e-net | RG-58 | 50 | CSMA/CD | 700 | 10
10Broad36 | RG-59 | 75 | CSMA/CD | 3600 | 1
Hiperchannel | RG-59 | 75 | CSMA/CD | 3500 | 50
IEEE 802.4 | RG-59 | 75 | маркер | - - | 1/5/10/20
ArcNet | RG-62/ RG-71 | 93 | маркер | 610 | 2,5
PX-net | RG-62 | 93 | маркер | 7000 | 1

При применении коаксиальных кабельных систем в сетях Ethernet следует помнить правило 5-4-3: «сеть может состоять максимум из пяти кабельных сегментов, соединенных максимум четырьмя повторителями, при этом число сегментов, к которым можно подключать сетевые узлы будет равно трем».


Комбинированные топологии

Уровень надежности и стоимость обслуживания кабельной системы в топологии «звезда» обусловили появления популярных комбинаций ее с другими топологиями.

В комбинированных топологиях в качестве центрального элемента используются специализированные устройства: концентраторы, коммутаторы, мосты, маршрутизаторы, их комбинации или гибриды.

Поскольку физически реализована топология «звезда», выход из строя одного компьютера не оказывает никакого влияния на сеть – остальные компьютеры по-прежнему взаимодействуют друг с другом и лишь выход из строя центрального элемента повлечет за собой остановку подключенных к нему компьютеров и/или подчиненных центральных элементов.

Логическое управление сетью скрыто внутри центрального элемента и может соответствовать любому другому типу топологии.

К наиболее распространенным видам комбинированных топологий относятся следующие:

Звезда-шина (star-bus) – это комбинация топологий «шина» и «звезда» (рисунок 1). Логически это выглядит так: несколько сетей и даже отдельных узлов с топологией «звезда» объединяются при помощи магистральной линейной шины. Физически такое объединение осуществляется «начинкой» центрального элемента топологии «звезда».

Звезда-кольцо (star-ring) кажется несколько похожей на звезду-шину. Отличие в том, что в звезде-кольце объединяемые элементы (подсети или отдельные узлы сети) на основе центрального элемента образуют логическое кольцо (рисунок 2).

Применение в качестве центрального элемента активного устройства, рассчитанного на объединение с себе подобными в плоскостные или иерархические структуры (рисунок 3), серьезно удешевляет стоимость сети по сравнению с первоначальной топологией «звезда». Этот факт позволил комбинированным топологиям серьезно потеснить применение последней при проектировании локальных сетей.

Принципы работы некоторых из устройств, применяемых в качестве центрального элемента, рассмотрены в главе 6.

Рисунок 1 -

Пример сети с топологией «звезда-шина»

Рисунок 2 -

Пример сети топологией «звезда-кольцо»

Рисунок 3 -

Каскадное объединение центральных элементов для увеличения масштаба сети


Корпоративные сети

Корпоративные сети называют также сетями масштаба предприятия, что соответствует дословному переводу термина "enterprise-wide networks", используемого в англоязычной литературе для обозначения этого типа сетей. Такие сети объединяют большое количество компьютеров на всех территориях отдельного предприятия. Они могут быть сложно связаны и способны покрывать город, регион или даже континент. Число пользователей и компьютеров может измеряться тысячами, а число серверов - сотнями, расстояния между сетями отдельных территорий бывают такими, что приходится использовать глобальные связи (рисунок 1).

Рисунок 1 -

Пример реализации корпоративной сети

Логически корпоративная сеть представляет собой структуру управления аналогичную локальной вычислительной сети.

Физически корпоративная сеть международного концерна сопоставима по масштабу охвата с глобальными сетями. Таким образом, для выполнения своих задач корпоративные сети должны использовать каналы связи других сетей.

Самые простые корпоративные сетевые системы, являются примерами расширенной локальной вычислительной сети с функцией удаленного доступа к сетевым ресурсам пользователям данной сети, подключающимся, например, с домашнего компьютера.

Главной задачей корпоративной сети при использовании публичных каналов связи является обеспечение защиты передаваемых данных от несанкционированного доступа. Как и в системах VPN эту задачу можно решать аппаратными средствами и с помощью программных решений.

Для корпоративной сети характерны:

· масштабность - тысячи пользовательских компьютеров, сотни серверов, огромные объемы хранимых и передаваемых по линиям связи данных, множество разнообразных приложений;
· высокая степень гетерогенности - различные типы компьютеров, коммуникационного оборудования, операционных систем и приложений;
· использование глобальных связей - сети филиалов соединяются с помощью телекоммуникационных средств, в том числе телефонных каналов, радиоканалов, спутниковой связи.

Типовое решение по построению корпоративной сети предусматривает использование иерархического подхода. Такой подход при проектировании сетевой структуры позволяет:

· обеспечить высокую отказоустойчивость и целостность сетевой инфраструктуры в случае выходе из строя единичных устройств уровня доступа или магистрали здания;
· сохранить вложенные инвестиции при дальнейшем развитии сети по мере повышения требований к производительности, надежности и масштабируемости.

Обычно корпоративные сети строятся на базе двух уровней:

· уровне доступа;
· уровне ядра.

Сетевое оборудование, относящееся к уровню доступа, предназначено для подключения пользователей к корпоративной сети.

Сетевое оборудование уровня ядра обеспечивает доступ к корпоративным серверам, высокоскоростное взаимодействие между пользователями, направление потоков данных по назначению за счет использования функций маршрутизации. Здесь же находится магистральное оборудование, которое обеспечивает пересылку данных между главными точками концентрации трафика в сети.

Для совместного выполнения каких-либо проектов организации могут организовывать многоуровневое взаимодействие своих сетей. Такое объединение корпоративных сетей, взаимодействующих друг с другом посредством Internet называется extranet (экстрасеть).


Локальные вычислительные сети

Локальные вычислительные сети (Local Area Network - LAN) - это структура, объединяющая компьютеры, сосредоточенные на небольшой территории. Обычно радиус удаления не превышает 1-2 км, хотя в отдельных случаях локальная сеть может иметь и более протяженные размеры. В общем случае локальная сеть представляет собой коммуникационную систему, принадлежащую одной организации.

Функциональное назначение сети или спектр решаемых ею задач узко направлен. Например, использование файлов, хранящихся на дисках других компьютеров сети, совместное использование устройств печати, модемов, факсов, доступ к единой базе данных, внутренняя электронная почта.

Локальная сеть может применяться для управления производственным процессом конкретного предприятия. Причем эти задачи могут начинаться с обычного документооборота и заканчиваться удаленным управлением любыми технологическими процессами.

В последнее время появилось также возможность по контролю и управлению деятельностью любого сотрудника организации, подключенного к локальной сети, посредством использования свойств Intranet-сервисов.

Более сложные задачи предъявляют высокие требования к надежности процесса передачи информации. Например, такая функция как распределенная обработка данных требует наличия механизма установления однозначной последовательности выполняемых действий, т.е. необходимо решение задачи синхронизации в распределенной системе, что далеко не просто.

Однако большинство локальных сетей ориентированы на решение простых пользовательских задач. В простейших случаях каждая рабочая станция или узел сети автономно обладает необходимыми ресурсами для решения поставленных перед нею задач, а ресурсы локальной сети необходимы для получения задания и отправки результатов, хранения больших объемов данных статистики, совместного использования дорогостоящих устройств. Пример такой сети представлен на рисунке 1.

Жизненный цикл локальной сети можно разбить на шесть этапов, каждый из которых включает в себя набор инженерных задач.

Этапы 3-5 этого цикла должны регулярно повторяться. В противном случае, либо сеть перестанет соответствовать современным стандартам, либо начнется процесс ее саморазрушения и сворачивания.

Рисунок 1 -

Пример локальной сети

Таблица 1 – Примерный жизненный цикл локальной сети

1

Разработка проекта
· предпроектное обследование объекта
· составление, оформление и согласование технического задания
· выбор необходимой конфигурации серверов и рабочих мест для использования их в составе информационной системы компьютерной сети
· выбор необходимого сетевого оборудования
· подготовка полного проекта сети в соответствии с Вашими требованиями.

2

Монтаж
· осуществление проекта и монтаж структурированной кабельной системы
· установка и настройка активного сетевого оборудования
· установка и настройка сетевого программного обеспечения на серверы и рабочие места
· установка систем защиты информации от несанкционированного доступа

3

Тестирование
· проведение анализа работы сети для определения «узких мест» и их устранение
· анализ информационной безопасности сети
· проверка систем защиты информации от несанкционированного доступа
· проверка работы активного сетевого оборудования

4

Обслуживание
· построение систем резервного копирования информационных ресурсов предприятия
· формирование политики безопасности предприятия, реализация систем разграничения доступа к информационным ресурсам
· проведение обучения персонала по работе с ЛВС на рабочих местах
· гарантийное и после гарантийное обслуживание элементов сети

5

Модернизация
· установка сетевых операционных систем нового поколения
· установка дополнительного прикладного программного обеспечения
· установка дополнительных или более новых версий систем управления и мониторинга сетей
· обновление системы защиты информации от несанкционированного доступа
· расширение возможностей использования современных технологий, в частности, системы электронного документооборота, сетевых баз данных, приема/передачи факсов, доступа в Интернет.

6

Демонтаж
· уведомление пользователей с последующим отключением их от сети
· отключение доступа к сетевым ресурсам
· демонтаж и утилизация активного оборудования
· демонтаж и утилизация элементов структурированной кабельной системы


Локальные сети Apple Talk

Сетевая архитектура AppleTalk предложена компанией Apple Computer в 1983 г. в качестве фирменной сетевой архитектуры для небольших рабочих групп. Сетевая топология сетей AppleTalk «шина» или «дерево». Стандартная рабочая группа AppleTalk состояла из двух рабочих станций и принтера. Метод доступа в данной сетевой архитектуре – CSMA/CA. В сети AppleTalk чаще всего используются экранированные витые пары, однако возможно также использование волоконно-оптических кабелей и неэкранированных витых пар.

Рисунок 1 -

Формат кадров Apple Talk Phase II (в скобках размеры в байтах)

Каждый компьютер, подключаемый к сети, ищет хранимый адрес, который он использовал в предыдущем сеансе. Если компьютер находит этот адрес, то использует его. В противном случае он присваивает себе адрес, случайно выбранный из набора предлагаемых адресов. Затем компьютер сообщает этот адрес всем другим компьютерам, чтобы определить, использует ли его еще кто-нибудь. Если да, то процесс поиска адреса повторяется. Если нет, то компьютер сохраняет этот адрес для использования в следующих сеансах.

Программная модель данной сети (стек протоколов) позволяет наиболее гибко реагировать на взаимодействие с другими сетями:

· сеть AppleTalk делиться на «зоны» (рисунок 2). В каждой зоне может присутствовать до 32 устройств, в модификации до 254.
· сервер программной части стека протокола - AppleShare.
· клиенты имеют произвольный выбор для подключения к сетевым серверам одной из следующих частей стека протокола:
· для работы с AppleShare – LocalTalk;
· для подключения к Ethernet – EtherTalk;
· для подключения к TokenRing – TokenTalk.

Рисунок 2 -

Пример сети AppleTalk

Сеть AppleTalk типа Phase 1 являлась изначальной архитектурой протокола AppleTalk, разработанной для поддержки сетей для небольших рабочих групп. Тип Phase 1 поддерживает только одну физическую сеть, с одним сетевым номером и одной зоной.

Большие сети AppleTalk не являются едиными физическими сетями, в которых все компьютеры подключены к одной и той же физической линии связи. Вместо этого они представляют собой объединенные сети, которые являются многочисленными маленькими сетями, соединенными между собой посредством маршрутизаторов.

В сети AppleTalk типа Phase 2 усовершенствованы службы маршрутизации и имен AppleTalk. Это приводит к снижению сетевой нагрузки и упрощению выбора маршрутизаторов. Благодаря этому стало возможным создание сетей AppleTalk, поддерживающих более 254 узлов и включающих множество зон.

Любая сеть LocalTalk должна принадлежать одной зоне, а для сетей EtherTalk и TokenTalk можно назначить несколько зон. Отдельные узлы сети можно включить в одну из этих зон.

Каждый компьютер клиента, принтер, сервер и маршрутизатор является узлом сети AppleTalk. Теоретически в сети AppleTalk типа Phase 2 может быть до 254 узлов, но на самом деле их количество ограничено 32 или меньшим числом, что определяется производительностью сетевых сред. Сети EtherTalk и TokenTalk могут иметь по 253 узла на каждый номер в диапазоне номеров сети, но не больше 16,5 миллионов узлов.

Согласно стандарта пропускная способность сети AppleTalk по сравнению с другими видами сетей невелика – 230,4 Кбит/с, поэтому в ней невозможно реализовать высокоскоростные приложения.


Локальные сети ArcNet

Среда ArcNet (Attached resource computer Network – Вычислительная сеть с присоединенными ресурсами) была разработана Datapoint Corporation в 1977 г. Это простая, гибкая и недорогая сетевая архитектура для сети масштаба рабочей группы.

Первые платы ArcNet были выпущены в 1983 г. Технология ArcNet – предшественница стандартов IEEE Project 802, но в целом она соответствует категории IEEE 802.4. В ней определяются стандарты для сетей с топологией «шина», с методом доступа с передачей маркера, построенных на основе кабеля для модулированной передачи. Сеть ArcNet может строиться только на топологии «звезда» или «шина».

Сети ArcNet используют метод доступа с передачей маркера, топологию «звезда» «шина» и работают на скорости 2,5 Мбит/с. Преемница сети ArcNet – ArcNet Plus работает на скорости 20 Мбит/с.

В сетях ArcNet маркер проходит не по физическому пути на основе расположения компьютеров, а от одного компьютера к другому согласно закрепленной по их нумерации последовательности. Поэтому ArcNet является довольно неэффективной средой: для достижения адресата данные могут проходить намного больший путь, чем необходимо.

Рисунок 1 -

Маршрут движения маркера в сети ArcNet

Стандартным для ArcNet считается коаксиальный кабель с полным сопротивлением 93 Ом. ArcNet поддерживает также витую пару и оптоволоконный кабель. Расстояние между компьютерами зависит от кабельной системы топологий. При использовании коаксиального кабеля с BNC-коннекторами и активными концентраторами максимальная длина кабеля от компьютера до концентратора 610 м (2000 футов), если сеть построена по топологии «звезда», и – 305 м (1000 футов), если сеть построена по топологии «шина». При использовании неэкранированной витой пары с соединителями длина кабеля между устройствами не более 244 м (800 футов) как при топологии «звезда», так и при топологии «шина».

Каждый компьютер соединяется с концентратором кабелем. Концентраторы бывают пассивными, активными и интеллектуальными (smart). Пассивные концентраторы осуществляют лишь физическую коммутацию проводов. Активные концентраторы способны восстанавливать и ретранслировать сигналы. Интеллектуальные – это активные концентраторы, обладающие диагностическими средствами.

Стандартный кадр ArcNet содержит до 508 байт данных (в ArcNet Plus – 4 096 байт данных). Его структура представлена на рисунке 2.

Рисунок 3 -

Формат кадров ARCNET

Сейчас сети ArcNet практически не применяются.


Локальные сети EtherNet

Данный стандарт является продуктом совместной разработки Xerox Corporation, Digital Equipment и Intel в 1980 году на основе разработок Xerox Corporation, сделанных еще в 1975 году.

Фактически данный стандарт разрабатывался параллельно проекту IEEE 802 и соответствует его спецификациями в части IEEE802.3.

Топология сети – «шина» и «звезда – шина».

Метод доступа к среде – CSMA/CD.

Скорость передачи данных зависит от реализации (1, 5, 10, 100, 1000, 10000 Мбит/с).

Физическая среда передачи – коаксиальный кабель, оптоволокно, витая пара и другие виды кабельных и беспроводных связей.

На физическом уровне EtherNet используют кодирование сигнала, которое для соблюдения технологии совместимости «сверху-вних», практически во всех стандартах одинаково. Это манчестерское кодирование сигнала. Исключением является стандарт – 10BROAD36, в котором используется кодирование сигнала DPSK.

Эффективная длина сегмента зависит от используемой среды передачи и колеблется от 100 м для «витой пары» до 2,5 км при использовании оптоволокна.

Формат кадра для сети EtherNet также меняется в зависимости от стандарта, но не значительно. При этом в различных вариантах длина пакета может быть фиксированной или изменяющейся (рисунок 1).

Длина поля в байтах | 8 | 6 | 6 | 2 | 46-1500 | 4
Тип поля | Преамбула | Адрес получателя | Адрес отправки | Тип протокола | Данные | CRC

Рисунок 1 -

Пример формата кадра EtherNet

Второй подход («сжатие») заключается в группировке пакетов в большие блоки. Современные скоростные сети (1 Гбит/с и выше) используют механизм группировки пакетов и увеличение частоты генерации сигналов, что накладывает дополнительные требования на среду передачи. Таким образом, среда передачи в Ethernet может использоваться следующим образом: коаксиальный кабель до 10 Мбит/с, витая пара – до 1 Гбит/с, более высокоскоростные режимы реализуются на оптоволокне.

В беспроводных сетях скорость регулируется возможностями оборудования.

Исторически первые сети технологии Ethernet были созданы на коаксиальном кабеле диаметром 0.5 дюйма. В дальнейшем были определены и другие спецификации физического уровня для стандарта Ethernet, позволяющие использовать различные среды передачи данных в качестве общей шины. Метод доступа CSMA/CD и все временные параметры Ethernet остаются одними и теми же для любой спецификации физической среды, хотя малораспространенные модификации Ethernet (например, 100 VG AnyLAN) могут отличаться по данному параметру.

Наименование модификации Ethernet расшифровывается следующим образом:

Так например, 10BaseT – это сеть Ethernet на витой паре UTP-3, методом доступа CSMA/CD и скоростью обмена данных 10 Мбит/с.

Самая распространенная ошибка в сетях Ethernet – возникновение коллизии. Домен коллизий – это часть сети Ethernet, все узлы которой распознают коллизию, вне зависимости от того, в какой части сети эта коллизия возникла.

Для того, чтобы сеть Ethernet, состоящая из сегментов различной физической природы, работала корректно, необходимо выполнение трех основных условий:

Количество станций в сети не превышает 1024 (с учетом ограничений для коаксиальных сегментов).

Удвоенная задержка распространения сигнала (Path Delay Value, PDV) между двумя самыми удаленными друг от друга станциями сети не превышает 575 битовых интервалов.

Сокращение межкадрового расстояния (Interpacket Gap Shrinkage) при прохождении последовательности кадров через все повторители не более, чем на 49 битовых интервалов (при отправке кадров станция обеспечивает начальное межкадровое расстояние в 96 битовых интервалов).

Поскольку сети этого стандарта широко распространены на территории нашей страны, рассмотрим более современные его модификации.


Локальные сети EtherNet 100 Мбит/с

Локальные сети Ethernet со скоростью передачи 100 Мбит/с принято называть сети Fast Ethernet. Впервые это название было присвоено стандарту 100 VG AnyLAN, который был совместим с существующим тогда стандартом Ethernet 10 Base T по среде передачи (витая пара категории 3), но абсолютно несовместим по оборудованию, в том числе из-за метода доступа к среде с использованием приоритетов. Большинство пользователей отказались от перспективы замены такого количества элементов своих локальных сетей, в результате чего стандарт не прижился.

Сейчас это же название закрепилось за серией стандартов Ethernet, состоящей из спецификаций, описанных в приложении IEEE 802.3u:

· 100BASE-T4
· 100BASE-TX
· 100BASE-FX

Такое разделение необходимо для обеспечения поддержки стандартом трех типов среды передачи: неэкранированной витой пары, экранированной витой пары и оптоволокна.

В этих сетях решена задача совмести по оборудованию с предыдущими сетевыми стандартами. Поскольку в каждой из них применен метод доступа к среде CSMA/CD, а также сетевых адаптеры, поддерживающие скорости передачи данных от 10 до 100 Мбит/с.

Сети 100BASE-T4 в качестве среды передачи, используют кабель с четырьмя неэкранированными или экранированными витыми парами категории 3, 4 или 5. Для своевременного обнаружения коллизий диаметр сети был уменьшен до 250 м, а максимальное расстояние между узлом сети и портом концентратора до 100 м.

С целью повышения скорости передачи для передачи сигналов задействованы три витые пары (плюс одна витая пара для обнаружения коллизий), что позволило втрое увеличить скорость по сравнению с сетью 100BASE-T. Вместо манчестерского кодирования применили схему кодирования 8В6Т, в которой 8 входных бит преобразовываются в уникальную кодовую группу из 6 троичных символов, что увеличило пропускную способность еще в 2,65 раза. Повышение тактовой частоты с 20 до 25 МГц, обеспечило увеличение пропускной способности еще
в 1,25 раза.

В результате всех перечисленных изменений 100BASE-T4 работает в 10 раз быстрее, чем 10BASE-T.

Сети 100BASE-TX также ориентированы на витую пару, но, в отличие от вышеописанной спецификации из четырех пар перевитых проводов кабеля UTP категории 5 используются только две. Одна из витых пар используется для передачи, другая служит для обнаружения коллизий и приема данных.

Применение двух витых пар вместо четырех, как в стандарте 100BASE-T4, требует изменения тактовой частоты и метода кодирования. В сетях 100BASE-TX используется тактовая частота 125 МГц и схема кодирования 4В5В, в которой каждые 4 бита данных кодируются с помощью 5 бит. Таким образом, для представления данных необходимо только 16 символов, оставшиеся символы служат в качестве управляющих.

Тактовая частота 125 МГц предъявляет требования к сети передачи – это может быть только кабель UTP категории 5 и выше.

Максимальный диаметр сети 100BASE-TX, равно как и сети 100BASE-T4, составляет 250 м, а максимальная длина кабеля от рабочей станции до концентратора – 100 м.

Сети 100BASE-FX ориентированы на использование двужильного многомодового волоконно-оптический кабеля диаметром 62,5 или 125 мкм. Передача сигналов производится в световом диапазоне 1350 нм, а длина сегмента в стандарте 100BASE-FX может достигать 412 м. Передача и прием данных разведены по отдельным жилам, которые обрабатываются одним сетевым адаптером. Схема кодирования в 100BASE-FX та же, что и в стандарте 100BASE-TX.

Рисунок 1 -

Соотношение форматов кадра 10 Мбит и 100 Мбит Ethernet


Локальные сети FDDI

Сетевая архитектура FDDI (Fiber Distributed Data Interface – распределенный интерфейс передачи данных по волоконно-оптическим кабелям) считается наследником TokenRing, разработана в национальном институте стандартизации США в 1980 г. и позволяет использовать оптоволоконные среды передачи на скорости 100 Мбит/с.

Метод доступа к среде – маркерный с возможностью одновременного циркулирования множества кадров в кольце.

Сеть FDDI строится на основе двух оптоволоконных колец, которые образуют основной и резервный пути передачи данных между узлами сети. В нормальном режиме работы сети данные проходят через все узлы и все участки кабеля первичного (Primary) кольца, поэтому этот режим назван режимом Thru – «сквозным» или «транзитным». Второе кольцо (Secondary) в этом режиме не используется.

В некоторых случаях вторичное кольцо используется для повышения пропускной способности потенциально до 200 Мбит/с. Пакеты по этим кольцам движутся в противоположных направлениях.

Сетью FDDI поддерживается 3 типа станций:

· станция с одинарным подключением (SAS);
· станция с двойным подключением (DAS);
· измененная DAS.

Обычно устройства подключаются к обоим кольцам одновременно. При возникновении сбоя (отказ в одном из узлов) активизируется и второе кольцо, что заметно повышает надежность системы, позволяя обойти неисправный участок (рисунок 1). Этот режим работы сети называется Wrap, то есть «сворачивание» колец.

Рисунок 1 -

Сворачивание FDDI при отказе

В оригинальном варианте технологии FDDI поддерживается до 1000 клиентов, со скоростью передачи данных 100 Мбит/сек. Рабочие станции могут, располагаться на расстоянии 2 км друг от друга для многомодового оптоволокна и до 4,5 км для одномодового, а вся сеть может простираться на расстояние до 200 км.

Нетрадиционным для других сетей является концентратор, используемый в FDDI. Он позволяет подключить несколько приборов SAS-типа к стандартному FDDI-кольцу, создавая структуры типа дерева. Но такие структуры несут в себе определенные ограничения на длины сетевых элементов, так при использовании повторителя удаление не должно превышать 1,5 км, а в случае моста 2,5 км (одномодовый вариант).

К кольцу FDDI могут также легко подключаться и субсети Token Ring (через мост или маршрутизатор).

Концентраторы также бывают двух типов: двойного DAS и одинарного SAS подключения. Такие приборы повышают надежность сети, так как не вынуждают сеть при отключении отдельного прибора переходить в аварийный режим обхода. Применение концентраторов снижает и стоимость подключения к FDDI. Концентраторы могут помочь при создании небольших групповых субсетей, предназначенных для решения специфических задач, то есть локализовать траффик.

FDDI позволяет работать с кадрами размером 4500 октетов, за вычетом места, занимаемого преамбулой, остается 4470 октетов для передачи данных. RFC-1188 резервирует 256 октетов для заголовков, оставляя для данных 4096 октетов. Маршрутизатор, поддерживающий протокол FDDI должен быть способен принимать такие длинные пакеты. Посылаться же должны дейтограммы не длиннее 576 октетов, если не ясно, сможет ли адресат принимать длинные кадры.

Рисунок 2 -

Формат пакета протокола FDDI

На текущий момент этот стандарт вытесняется с рынка сетями с ячеистой топологией и высокоскоростными (Gigabit Ethernet) сетями, также использующими оптоволокно в качестве среды передачи данных.


Локальные сети TokenRing

Сетевая архитектура TokenRing предложена IBM в 1984 г. для объединения IBM-совместных компьютеров, в том числе:

· персональных станций
· малых и средних ЭВМ
· майнфреймов и сред SNA

Топология сети «кольцо», «звезда-кольцо». TokenRing в качестве метода управления доступом станций к передающей среде использует – маркерное кольцо. Архитектура описывается стандартом IEEE 802.5.

Кабельная система – коаксиальный кабель, экранированная или неэкранированная витая пара (UPT или SPT) или оптоволокно. Максимальная длина кабеля сегмента зависит от типа кабеля и находится в пределах от 45 до 200 метров.

Скорость передачи данных от 4-16 Мбит/с и выше.

Каждый компьютер сети, получающий такой пакет, проверяет по адресу назначения копировать данные в буфер сетевого адаптера или не делать этого. Если пакет предназначен ему, то операция копирования проедена успешно и были выполнены все проверки. Состояние фрейма измениться на состояние «доставлено». Пакет следует дальше по кольцу, пока не достигнет станции отправителя. Тот по состоянию фрейма решает, что делать дальше:

· прекратить передачу и выпустить маркер из-за успешной доставки сообщения
· прекратить передачу из-за отсутствия адресата
· повторить передачу

Схема адресации TokenRing – физическое кольцо, реализованное с помощью кабеля, либо внутри концентратора MAU. Все сетевые адреса базируются на MAC-адресах. MAC-адреса закреплены фирмой-изготовителем.

В IВМ Тоken Ring используются три основных типа пакетов:

Пакет «Управление/Данные» (Data/Соmmand Frame). С помощью такого пакета выполняется передача данных или команд управления работой сети.

Пакет «Маркер» (Token). Станция может начать передачу данных только после получения такого пакета.

Пакет «Сброса» (Abort). Посылка такого пакета называет прекращение любых передач.

Рисунок 1 -

Структура информационной связи в сети TokenRing

Признак начала | Управление доступом | Признак конца
8 | 8 | 8

Управление фреймом | Адрес назначения | Адрес источника | RIF | DSAP | SSAP | CTRL | Данные | FCS | Состояние фрейма
8 | 16 или 48 | 16 или 48 | 144 | 8 | 8 | 8 или 16 | >0 | 32 | 8

Стартовый разграничитель | В кадре Token Ring играет ту же роль, что и преамбула в кадре Ethernet.
Поле управления доступом | Указывает, является ли кадр маркером или кадром данных. Определяет также приоритет кадра.
Поле управления кадром | Содержит информацию об управлении доступом.
Адрес назначения | Адрес компьютера, на который передается этот кадр.
Адрес источника | Адрес передающего компьютера.
Данные | Передаваемая информация (например, содержимое передаваемого файла).
FCS | Frame Check Sequence. Проверочное поле с битами CRC.
Конечный разграничитель | Отмечает конец кадра.
Поле состояния кадра | Указывает, был ли адрес распознан, а кадр скопирован (заполняется принимающим компьютером перед отправкой кадра обратно в кольцо).

Рисунок 2 -

Форма кадра TokenRing

Для сетей Token Ring характерны высокая надежность и устойчивость, однако вследствие более высокой стоимости и меньшей пропускной способности они менее популярны, чем Ethernet. Существует также внутренний стандарт IBM High Speed Token Ring – 100-155 Мбит/с. В настоящее время разрабатываются спецификации для Gigabit TokenRing. Следовательно, эта архитектура считается перспективной.


Метод доступа к среде CSMA/CA

Carrier Sense Multiple Access with Collision Avoidance – множественный доступ с контролем несущей и предотвращением коллизий.

Данный метод доступа практически аналогичен CSMA/CD. В нем компьютеры также конкурируют за право передачи и для этого постоянно ведется контроль несущей. Отличие заключается в том, что для разрешения передачи информации отправитель запрашивает подтверждение от всех компьютеров в сети, для этого он формирует и передает в сеть сигнал запроса на передачу – RTS (Request to Send). Получив пакет RTS, компьютер, который не собирается сам передавать информацию, сразу отправляет разрешение.

Если компьютер сам собирается передавать информацию и уже отправил свой RTS, то он сравнивает временные отметки своего RTS и полученного, после чего решает: высылать разрешение или поставить пришедший RTS в очередь.

В этом случае вероятность возникновения коллизии минимально, но в сети большое количество широковещательных сообщений. Поэтому эффективность использования канала связи у CSMA/CA ниже, чем у CSMA/CD.

Чаще всего этот метод используется в иерархических топологиях (звезда, дерево).

CSMA/CA практически снимает все проблемы от ошибок критичных для CSMA/CD, но взамен он обладает следующими существенными недостатками:

· сеть оказывается загруженной широковещательными сообщениями;
· и, как следствие этого, скорость существенно ниже.

Данный метод доступа применялся в стандарте сетевой архитектуры AppleTalk.

Обновленная версия CSMA/CA, которая также называется функцией распределенной координации (distributed coordination function), применяется в беспроводных сетях. Для увеличения скорости и избавления от широковещательного трафика механизм его работы претерпел существенные изменения.

В этом случае станция, ожидающая возможности передачи, прослушивает частоту коммуникаций и определяет ее занятость, проверяя уровень индикатора мощности сигнала в приемнике (Receiver Signal Strength Indicator, RSSI). В тот момент, когда передающая частота свободна, наиболее вероятно возникновение конфликтов между двумя станциями, которые одновременно захотят начать передачу. Как только передающая частота освобождается, каждая станция ждет несколько секунд (число которых определяется параметром DIFS), чтобы убедиться в том, что частота остается незанятой.

DIFS — это аббревиатура от термина Distributed coordination function's Intra Frame Space (интервал между фреймами функции распределенной координации), который определяет заранее установленное время обязательного ожидания (задержки).

Если станции ожидают в течение времени, определенного интервалом DIFS, вероятность возникновения конфликта между станциями уменьшается, поскольку для каждой станции, требующей передачи, вычисляется разное значение времени задержки (отсрочки), по истечении которого станция снова будет проверять занятость передающей частоты.

Если на момент истечения DIFS:

частота остается незанятой, то передачу начинает станция, имеющая минимальное время отсрочки;

частота оказывается занятой, то станция, требующая передачи, ждет пока частота не освободится, после чего простаивает еще в течение уже вычисленного времени отсрочки.

При определении времени отсрочки длительность заранее заданного интервала времени умножается на случайное число. Временной интервал — это некоторое значение, хранящееся в базе управляющей информации, имеющейся на каждой станции. Значение случайного числа лежит в диапазоне от нуля до величины максимального размера окна конфликтов, который также хранится в базе управляющей информации станции. Таким образом, для каждой станции, ожидающей передачи, определяется уникальное время отсрочки, что позволяет станциям избегать конфликтов.


Метод доступа к среде CSMA/CD

Carrier Sense Multiple Access with Collision Detection — множественный доступ с контролем несущей и обнаружением коллизий.

Несущая (Carrier) – это информационный сигнал, транслируемый любым сетевым устройством во время передачи данных. Если узел, готовящийся начать передачу, опознает несущую (Carrier-Sense, CS), то он откладывает передачу своего кадра данных до окончания чужой передачи, и только потом пытается вновь его передать.

Компьютеры постоянно конкурируют за право передачи. Для этого все сетевые адаптеры, независимо от того собираются они передавать информацию или нет, «прослушивают» среду передачи, стремясь обнаружить передаваемые данные.

Это позволяет решить следующие задачи:

· любой компьютер сети находится в постоянной готовности принять информацию адресованную ему;
· производится поиск момента, когда среда передачи освобождается, ведется только отправителем.

Метод используется в топологиях шина, звезда и звезда-шина.

Все данные, передаваемые по сети, помещаются в кадры определенной структуры и снабжаются уникальным адресом станции назначения. Затем кадр передается по кабелю. Все станции, подключенные к кабелю, могут распознать факт передачи кадра, и та станция, которая узнает собственный адрес в заголовках кадра, записывает его содержимое в свой внутренний буфер, обрабатывает полученные данные и посылает по кабелю кадр-ответ. Адрес станции-источника также включен в исходный кадр, поэтому станция-получатель знает, кому нужно послать ответ. Между двумя последовательно передаваемыми по общей шине кадрами информации должна выдерживаться пауза в 9.6 мкс; эта пауза нужна для приведения в исходное состояние сетевых адаптеров узлов, а также для предотвращения монопольного захвата среды передачи данных одной станцией.

Основная ошибка в CSMA/CD - это коллизия (collision, столкновение пакетов). Возникает в случае одновременной попытки передачи информационных пакетов от двух и более компьютеров одновременно. В этом случае, передаваемые данные взаимно разрушаются.

Вероятность возникновения коллизии тем выше, чем дальше находится друг от друга участники соединения и чем большее число компьютеров подключено к сегменту сети. Вероятность возникновения повторной коллизии намного выше, вероятности первичной коллизии.

Обнаружение коллизии может осуществляться по увеличению амплитуды отклонения от несущей (рисунок 1).

Рисунок 1 -

Возникновении коллизии в сети с общей шиной

Чтобы корректно обработать коллизию, все станции одновременно наблюдают за возникающими на кабеле сигналами. Если передаваемые и наблюдаемые сигналы отличаются, то фиксируется обнаружение коллизии (Collision Detection, CD). Для увеличения вероятности немедленного обнаружения коллизии всеми станциями сети, ситуация коллизии усиливается посылкой в сеть станциями, начавшими передачу своих кадров, специальной последовательности битов, называемой jam-последовательностью. После обнаружения коллизии передающая станция обязана прекратить передачу и ожидать в течение короткого случайного интервала времени, а затем может снова сделать попытку передачи кадра. Узел делает максимально 16 попыток передачи этого кадра информации, после чего отказывается от его передачи. Величина задержки выбирается как равномерно распределенное случайное число из интервала, длина которого экспоненциально увеличивается с каждой попыткой – такой выбор величины задержки снижает вероятность коллизий и уменьшает интенсивность выдачи кадров в сеть при ее высокой загрузке.

Метод доступа CSMA/CD применяется в стандарте сетевой архитектуры Ethernet, что определяет его широкую популярность в настоящий момент.


Метод доступа к среде с использованием маркера

Метод с передачей маркера неконкурентный – в нем два компьютера не могут начать передавать сигнал одновременно. Второе название «эстафетная палочка».

В этом случае пакет специальной формы курсирует по строго определенной траектории. Если какой-либо из компьютеров нуждается в разрешении провести передачу, он дожидается момента, когда этот пакет (маркер) приходит к нему, наполняет его информацией и отправляет дальше. Получившийся пакет следует по тому же маршруту, что и маркер, достигает или не достигает пункта назначения.

Когда пакет достигают компьютера, адрес которого указан в заголовке, сетевой адаптер компьютера копирует данные, добавляет к пакету подтверждение об успешном приеме и передает дальше по кругу. Компьютер, передавший эти данные, получает пакет с подтверждением, после чего или передает еще один пакет, или освобождает маркер, т.е. возвращает его к исходному виду.

На рисунке 1 описанный алгоритм доступа к среде иллюстрируется временной диаграммой. Здесь показана передача пакета А в кольце, состоящем из 6 станций, от станции 1 к станции 3.

Рисунок 1 -

Принцип действия маркерного доступа

Время удержания одной станцией маркера ограничивается тайм-аутом удержания маркера, после истечения которого станция обязана передать маркер далее по кольцу. В сетях Token Ring 16 Мб/с используется также несколько другой алгоритм доступа к кольцу, называемый алгоритмом раннего освобождения маркера (Early Token Release). В соответствии с ним станция передает маркер доступа следующей станции сразу же после окончания передачи последнего бита кадра, не дожидаясь возвращения по кольцу этого кадра с битом подтверждения приема. В этом случае пропускная способность кольца используется более эффективно.

Каждая станция применяет механизмы обнаружения и устранения неисправностей сети, возникающих в результате ошибок передачи или переходных явлений (например, при подключении и отключении станции).

Не все станции в кольце равны. Одна из станций обозначается как активный монитор, что означает дополнительную ответственность по управлению кольцом. Активный монитор осуществляет управление тайм-аутом в кольце, порождает новые маркеры (если необходимо), чтобы сохранить рабочее состояние, и генерирует диагностические кадры при определенных обстоятельствах. Активный монитор выбирается, когда кольцо инициализируется, и в этом качестве может выступить любая станция сети. Если монитор отказал по какой-либо причине, существует механизм, с помощью которого другие станции (резервные мониторы) могут договориться, какая из них будет новым активным монитором.

Для различных видов сообщений передаваемым данным могут назначаться различные приоритеты. Каждый кадр или маркер получает приоритет, устанавливаемый битами приоритета (от 0 до 7). Станция может воспользоваться маркером, если только она получила маркер с приоритетом, меньшим или равным, чем ее собственный. Сетевой адаптер станции, если ему не удалось захватить маркер, помещает свой приоритет в резервные биты маркера, но только в том случае, если записанный в резервных битах приоритет ниже его собственного. Эта станция будет иметь преимущественный доступ при последующем поступлении к ней маркера.

Чаще всего методы с использованием маркера применяются в сетях с кольцевой топологией (например, Token Ring и FDDI), однако ничто не мешает передавать маркер и в сетях с другими видами топологий (например, ArcNet).


Метод доступа к среде с использованием приоритетов

В этом случае применяется топология «звезда». Центральный элемент - активный концентратор.

Каждый компьютер участник сетевого соединения имеет характеристику, называемую приоритетом (статические, динамические). В одних сетях предполагалась, что они назначались администратором, а в других сетевыми менеджерами. Например, если компьютер долгое время не участвовал в соединении его приоритет можно повысить.

В данном случае компьютеры тоже прослушивают несущую и когда она освобождается отправляют свои пакеты.

При использовании более сложных устройств в качестве центрального элемента связь осуществляется только между компьютером посылки, концентратором и компьютером адресата.

Передачи не являются широковещательными на все другие компьютеры сети. Компьютеры не борются самостоятельно за доступ к среде, но работают под централизованным управлением концентратора.

В случае если два компьютера одновременно отправляют свою информацию, активный концентратор сравнивает приоритеты сообщений, и транслирует лишь ту из них, которая имеет более высокий приоритет. При равном приоритете сохраняемое сообщение выбирается произвольным образом, второе – блокируется (рисунок 1).

Рисунок 1 -

Предотвращение коллизии в методе доступа Demand Priority

Этот метод доступа основан на факте, что повторители и конечные узлы являются двумя компонентами, которые составляют все такие сети. Активные концентраторы управляют доступом к сети, делая циклические опросы всех конечных узлов на сети, проверяя их работоспособность и переопределяя приоритеты.

Метод доступа Demand Priority разрабатывался как альтернатива CSMA/CD для сетей Fast Ethernet – 100 Anylan Voice Guide с использованием витой пары категории 3 и оптоволокна. При использовании UTP все четыре пары кабеля используются для передачи данных. Каждая пара работает на скорости 30 Mbs с использованием схемы кодирования 5B/6B. Содержимое MAC-кадра сегментируется на квинтеты. После кодирования они передаются по 4-м каналам в круговом порядке. Такой способ требует полной замены всего активного оборудования.

Согласно определению 100VG-AnyLAN конечным узлом может быть компьютер, мост, маршрутизатор, или коммутатор.

В спецификации сети IEEE 802.12, соответствующему 100VG-AnyLAN, предписывается, что MAC-протокол построен на принципе голосования. На рисунке 2 изображена последовательность управляющих сигналов при процедуре передачи фрейма.

Рисунок 2 -

Процедура передачи фрейма

Стандарт практически не применялся и на текущий момент не используется, но практически все положительные свойства этой технологии можно найти в современных сетевых стандартах.


Методы доступа к среде в беспроводных сетях

Беспроводные или бесконтактные соединения между устройствами становятся все более популярными ввиду их высокой эффективности при малых и средних потоках данных на малых расстояниях удаления.

Стандарты, реализующие данную технологию внедряются и распространяются отдельными производителями устройств, но отдельные из них уже утверждены в качестве официальных (таблица 1).

Таблица 1 – Параметры некоторых технологий мобильной связи.

Параметры | IEEE 802.11a | IEEE 802.11b | HomeRF | Hiperlan | DECT/ DCT | ZIGBEE 802.15.4 | Bluetooth 802.15 | WiMAX 802.16a
Количество устройств | Tbd | 128/1024 | 128 | - | 12 | 255 | 7 (>106 в теории) | сотни и тысячи
Голосовые каналы | Voice over IP | Voice over IP | 6 | Voice over IP | 12 | none | 3 |
Скорость передачи | 54 Мбит/с | 11 Мбит/с | 2 Мбит/с | 50 Мбит/с | 1.15 Мбит/с | 22 Кбит/с и 200 Кбит/с | 11 Мбит/с | 70 Мбит/с
Диапазон | 5.15-5.85 ГГц | 2.45 ГГц ISM | 2.45 ГГц ISM | 5.15-5.85 ГГц | 1.99 ГГц и 2.4 ГГц | 2.45 ГГц ISM | 2.45 ГГц ISM | 2-11 ГГц
Дальность | 50м | 50м | 50м | 50м | 30 - 300м | <25м | 10 - 100м | ~50 км
Выходная мощность | 100mW | 100mW | 100mW | 10-1000mW | 250mW | 1-10mW | 1-100mW |

Рассмотрим методы доступа к среде некоторых из них:

Стандарт IEEE 802.11 предусматривает использование стандартных методов доступа к среде CSMA/CD и CSMA/CA, но в некоторой вариации. Стандартом 802.11 предусмотрены две основные топологии. Самой простой является топология с набором независимых базовых служб (Independent Basic Service Set (IBSS) topology), образуемая двумя или несколькими станциями беспроводной связи, которые могут взаимодействовать друг с другом. Сеть такого типа в некоторой степени непредсказуема, поскольку новые станции часто появляются неожиданно. IBSS-топология образуется произвольными одноранговыми коммуникациями между WNIC-адаптерами отдельных компьютеров.

По сравнению с IBSS-топологией, топология с расширенным набором служб (Extended service set (ESS) topology) имеет большую область обслуживания, т.к. в ней имеется одна или несколько точек доступа. На базе ESS-топологии можно создать небольшую, среднюю или большую сеть и значительно расширить зону беспроводных коммуникаций. Похожий механизм работы применяется в работе протокола совместного беспроводного доступа HomeRF (HomeRF Shared Wireless Access Protocol - SWAP).

Технология HiperLAN обеспечивает качество обслуживания (QoS), предоставляя гарантированный уровень коммуникаций для различных классов обслуживания (например, для передачи речи или видеоизображений). Это возможно благодаря тому, что точки доступа централизованно управляют беспроводными коммуникациями и планируют все сеансы передачи информации.

Сеть HiperLAN2 работает в двух режимах. Непосредственный режим (direct mode) представляет собой топологию одноранговой сети, которая образуется только взаимодействующими станциями. Другой режим называется централизованным (centralized mode), поскольку он реализуется в больших сетях, где имеются точки доступа, концентрирующие сетевой трафик и управляющие им. Методом коммуникаций для обоих режимов служит дуплексная передача с временным разделением канатов (TDD).

В технологии Bluetooth применяется дуплексная передача с временным разделением каналов (time division duplexing, TDD), при которой пакеты передаются в противоположных направлениях с использованием временных интервалов. Один цикл передачи может задействовать до пяти различных временных интервалов, благодаря чему пакеты могут передаваться и приниматься одновременно. Этот процесс напоминает дуплексные коммуникации. Когда устройства обмениваются информацией, одно из них автоматически выбирается ведущим (master). Это устройство определяет функции управления (например, синхронизацию временных интервалов и управление пересылками). Во всех других аспектах коммуникации Bluetooth напоминают одноранговую сеть. Bluetooth поддерживает синхронный и асинхронный режим обмена.

Управление доступом в WiMAX осуществляется по технологии множественного доступа с разделением по ортогональным частотам (OFDMA), которая также делит несущую на множество поднесущих (OFDM) и дополнительно группирует поднесущие в подканалы. Один клиент может для передачи данных занять все подканалы внутри диапазона, или каждый из множества клиентов вправе при передаче использовать часть от всего количества подканалов.

Недостатком всех этих технологий является то, что некоторые частоты беспроводной связи также используются радиолюбителями, военными, силовыми ведомствами, операторами сотовых сетей и телевизионными компаниями, в результате чего на этих частотах возникают помехи от различных источников.


Механизмы построения стеков протоколов

В компьютерной промышленности из всего разнообразия стеков протоколов в качестве стандартных моделей применяют ограниченное количество. Вот наиболее важные из них:

· набор протоколов ISO/OSI;
· IBM System Network Architecture (SNA);
· Digital DECnet;
· Novell NetWare;
· Apple AppleTalk;
· набор протоколов Интернета — TCP/IP.

Для представления взаимного соотношения сетевых протоколов и систем обычно используется эталонная модель OSI (Open System Interconnect), разработанная международным комитетом по стандартизации ISO (International Organization for Standardization). Выстраивание подобных соотношений довольно условно, так как трудно четко разграничить функции всех частей программного обеспечения.

Модель OSI допускает два основных метода взаимодействия абонентов в сети:

· метод взаимодействия без логического соединения или метод дейтаграмм (рисунок 1.а);
· метод взаимодействия с логическим соединением (рисунок 1.б).

а) [image] б)

Рисунок 1 -

Методы взаимодействия абонентов в сети

а) метод дейтаграмм

б) метод с логическим соединением

Согласно метода дейтаграмм каждый пакет рассматривается как самостоятельный объект. Пакет при этом методе передается без установления логического канала, то есть без предварительного обмена служебными пакетами для выяснения готовности приемника, а также без ликвидации логического канала, то есть без пакета подтверждения окончания передачи. Дойдет пакет до приемника или нет – неизвестно (проверка факта получения переносится на более высокие уровни).

Примеры протоколов, работающих по методу дейтаграмм - это протоколы IP и IPX.

При методе с логическим соединением пакет передается только после того, как будет установлено логическое соединение (канал) между приемником и передатчиком. Каждому информационному пакету сопутствует один или несколько служебных пакетов (установка соединения, подтверждение получения, запрос повторной передачи, разрыв соединения). Логический канал может устанавливаться на время передачи одного или нескольких пакетов.

Метод с логическим соединением, гораздо надежнее, поскольку к моменту ликвидации логического канала передатчик уверен, что все его пакеты дошли до места назначения, причем дошли успешно. Не бывает при данном методе и перегрузки сети из-за бесполезных пакетов. Недостаток метода с логическим соединением состоит в том, что довольно сложно разрешить ситуацию, когда принимающий абонент по тем или иным причинам не готов к обмену, например, из-за обрыва кабеля, отключения питания, неисправности сетевого оборудования, сбоя в компьютере. При этом требуются алгоритм обмена с повторением неподтвержденного пакета заданное количество раз, причем важен и тип неподтвержденного пакета. Еще этот метод не может передавать широковещательные пакеты, так как нельзя организовать логические каналы сразу со всеми абонентами.

Примеры протоколов, работающих по методу с логическим соединением - это TCP и SPX.

Именно для того, чтобы объединить достоинства обоих методов, эти протоколы используются в виде связанных наборов: TCP/IP и IPX/SPX, в которых протокол более высокого уровня (TCP, SPX), работающий на базе протокола более низкого уровня (IP, IPX), гарантирует правильную доставку пакетов в требуемом порядке.

В качестве примера на рисунке 2 схематически показано соотношение протоколов, используемых популярными фирменными сетевыми операционными системами, и уровней стандартной модели OSI.

Рисунок 2 -

Соотношение стеков протоколов с уровнями модели OSI


Модель доменов и Active Directory

Так как база данных SAM не подходит для поддержки сетевых приложений типа Exchange Server, то, когда была выпущена четвертая версия Exchange Server, она имела свою собственную службу каталога - Exchange Directory, которая была предназначена для поддержки вычислительной среды больших предприятий, в более поздних версиях она основывалась на открытых стандартах Internet. Например, она удовлетворяет спецификации облегченного протокола службы каталогов (LDAP) TCP/IP и имеет легкий программный доступ.

Служба Active Directory заменила базу данных SAM в качестве службы каталога для сетевых сред от Microsoft. Она направлена на преодоление ограничений службы Windows NT 4 SAM и обеспечивала дополнительные выгоды сетевым администраторам. Главная выгода Active Directory в реализации Windows 2000 состоит в том, что она масштабируема. Новый файл базы данных учетных записей может достигать 70 Тбайт.

Фактически Active Directory была реализована в испытательной среде в модели отдельного домена, содержащей более ста миллионов объектов. Сетевые администраторы больше не должны делить свои среды на несколько доменов, чтобы обойти ограничения размеров службы каталога.

Сложные доменные модели, которые преобладали ранее, теперь могут быть объединены в меньшее количество доменов с помощью организационных единиц (OU - organizational unit), предназначенных для группировки содержимого ресурсного или регионального домена Windows NT 4. На рисунке 1 показана типичная модель отдельного домена системы Windows 2000.

Рисунок 1 -

Модель отдельного домена («лес») системы Windows 2000

Любые изменения в инфраструктуре Active Directory должны быть тщательно реализованы в соответствии с проектом Active Directory, который предусматривает такой рост.

В Active Directory претерпел механизм реализации функции контроллера домена. Здесь нет деления на первичный и вторичный контроллеры домена, изменения могут вноситься на любом из серверов, а их синхронизация осуществляются в обоюдном направлении. Этот процесс часто занимает много времени.

Физическое проявление службы Active Directory состоит в наличии отдельного файла данных, расположенного на каждом контроллере домена в домене. Физическая реализация службы Active Directory описывается местоположением контроллеров домена, на которых расположена служба. При реализации службы Active Directory можно добавлять столько контроллеров доменов, сколько необходимо для поддержания служб каталога в данной организации. Имеется пять определенных ролей, которые может играть каждый из контроллеров домена. Все они выполняют роли FSMO (Flexible Single Master Operations - гибкие операции с одним хозяином):

· хозяин схемы;
· хозяин именования доменов;
· хозяин относительных идентификаторов RID;
· хозяин эмулятора PDC;
· хозяин инфраструктуры.

Одно из ограничений базы данных Windows NT 4 SAM состояло в том, что административные права были доступны только в виде «все или ничего». Чтобы дать пользователю любую степень административных прав требовалось, чтобы вы сделали пользователя членом группы Domain Admins. Этот уровень административных прав давал пользователю безграничную власть в пределах домена, включая право удалять других пользователей из группы Domain Admins.

Active Directory предоставляет администраторам возможность делегировать административные права. Используя мастер Delegation Of Control Wizard (Делегирование управления) или устанавливая определенные разрешения на объекты Active Directory, администраторы могут предлагать тонко настроенные административные права. Например, можно назначить определенной учетной записи пользователя административное право сбрасывать пароли в домене, но не создавать, удалять или как-либо изменять пользовательский объект.

Это далеко не полный перечень свойств Active Directory.


Модель OSI и ее место в описании компьютерных сетей*

Для компьютерных сетей модель OSI – это «модель моделей». Она разработана в 1974 году Международной организацией стандартизации ISO и регламентирует взаимодействие локальных и глобальных сетей. На текущий момент это наиболее удачный (или компромиссный) вариант стандартизации сетевых аппаратных и программных средств.

Модель OSI позволяет решать следующий ряд вопросов:

· обеспечение передачи информации между различными типами локальных и глобальных сетей;
· стандартизация сетевого оборудования, что позволяет устройствам одного производителя взаимодействовать с устройствами других производителей;
· сохранение капиталовложений пользователей, обеспеченное возможностью взаимодействия старого сетевого оборудования с новыми устройствами;
· разработка программного и аппаратного обеспечения, использующего общие интерфейсы для передачи как внутри сети, так и между различными сетями;
· возможность появления всемирных сетевых коммуникаций, в первую очередь – Интернета.

Модель OSI состоит из семи уровней, расположенных один поверх другого: физический, канальный, сетевой, транспортный, сеансовый, представительский, прикладной. Передача информации начинается на прикладном уровне. Затем информация претерпевает ряд преобразований и определенных приращений на более нижних уровнях до тех пор пока данные не достигнут физического уровня и не будут по сети переданы второму участнику соединения - приемнику. Тот принимает данные на физическом уровне и передает их для проверки и расшифровки более высоким уровням. И так до тех пор, пока данные не достигнут прикладного уровня. Нижние уровни модели OSI выполняют функции, относящиеся к передаче физического сигнала. Средние уровни координируют сетевые коммуникации между узлами. Верхние выполняют задачи, влияющие на прикладные программы и представление данных. В совокупности набор уровней называется стеком.

Взаимодействие между уровнями OSI изображена на рисунке 1.

Рисунок 1 -

Модель взаимодействия уровней в OSI

Общий цикл преобразования информации, передаваемой по каналам связи, руководствуясь требованиями модели OSI, можно представить следующей схемой (рисунок 2).

Рисунок 2 -

Формирование пакета данных согласно модели OSI


Модель сетевого описания ATM

У сетей ATM есть своя эталонная модель, отличная от моделей OSI и TCP/IP. Эта модель показана на рисунке 1.

Рисунок 1 -

Эталонная модель ATM

Как видно, модель состоит из трех уровней: физического, ATM и адаптационного ATM-уровня, — а также включает верхние уровни, используемые пользователем.

Физический уровень взаимодействует с физической средой передачи данных: напряжениями, длительностями битов и т. п. ATM не предписывает на этот счет каких-нибудь правил. Напротив, сообщается, что ячейки ATM могут передаваться по проводам или по оптоволоконным кабелям сами собой, а также в упакованном виде в качестве данных по любому другому носителю. Другими словами, ATM разрабатывалась как независимая от физического носителя система.

ATM-уровень имеет дело с ячейками и их передачей. Он описывает схему ячейки и значение полей заголовков. Кроме того, этот уровень занимается установлением и освобождением виртуальных каналов связи. Здесь же осуществляется управление перегрузкой.

Поскольку большинство приложений не желают работать напрямую с ячейками, уровень, расположенный над уровнем ATM, был разработан для предоставления пользователям возможности посылать пакеты, превосходящие размер ячейки. Интерфейс ATM разбивает такой пакет на ячейки, передает их по отдельности, после чего вновь собирает из них пакет на противоположной стороне. Этот уровень называется уровнем адаптации ATM, или уровнем AAL.

В отличие от более ранних двумерных эталонных моделей, модель ATM является трехмерной, как показано на рисунке 1. Плоскость пользователя занимается транспортировкой данных, управлением потоками, исправлением ошибок и другими функциями. Задачей же плоскости управления является управление соединениями. Управляющие функции уровней и плоскостей занимаются управлением ресурсами и межуровневой координацией.

Физический уровень и уровень AAL подразделяются на два подуровня; нижний подуровень выполняет работу, а верхний (подуровень конвергенции) предоставляет вышестоящему уровню соответствующий интерфейс. Функции уровней и подуровней приведены на рисунке 2.

Рисунок 2 -

Уровни и подуровни ATM, их функции

Зависящий от физического носителя подуровень PMD (Physical Medium Dependent) обеспечивает интерфейс с физическим кабелем. Он пересылает биты и управляет временными параметрами сигналов. Этот уровень будет различным для различных носителей и кабелей.

Другим подуровнем физического уровня является подуровень конвергенции передачи (Transmission Convergence, TC). Уровень конвергенции передачи пересылает ячейки в виде последовательности битов уровню PMD и принимает в обратную сторону. Он выполняет все задачи, связанные с определением начала и конца ячеек во входном потоке. В модели ATM эти функции относятся к физическому уровню. В модели OSI, а также во многих старых сетях превращение сырого потока битов в последовательность кадров или ячеек выполнялось уровнем передачи данных.

Уровень AAL состоит из двух подуровней: подуровня сегментации и повторной сборки (Segmentation And Reassembly, SAR) и подуровня конвергенции (Convergence Sublayer, CS). Нижний подуровень разбивает пакеты на ячейки при передаче и восстанавливает пакеты из ячеек при приеме. Верхний подуровень обеспечивает предоставление системами ATM определенных услуг различным приложениям (например, перенос файлов и видео по заказу предъявляют ряд требований, включая обработку ошибок, временные параметры и т. д.).


Модель сетевого описания DoD

Модель DoD (иногда ее называют моделью TCP/IP) была разработана в 70-х годах, как явствует из ее названия, по заказу Министерства обороны США.

Модель DoD разрабатывалась вместе с протоколом TCP/IP как часть проекта ARPAnet. Это достаточно простая модель. Она содержит всего четыре уровня (рисунок 1).

Уровни модели DoD выполняют описанные ниже функции:

· Уровень приложений/процессов. Верхний уровень модели DoD выполняет функции трех верхних уровней модели OSI: прикладного, представления и сеансового. В источниках по TCP/IP можно встретить утверждение, что уровень приложений (прикладной) шифрует данные, создает точки проверки и управляет сеансом связи. Если вы будете помнить, что речь идет не о прикладном уровне модели OSI, то избежите путаницы.
· Уровень обмена между хостами (транспортный уровень). Во многих источниках, включая четырехуровневые диаграммы DoD, этот уровень называется так же, как соответствующий ему уровень модели OSI - транспортный. На этом уровне работают протоколы TCP, UDP и служба DNS.
· Межсетевой уровень. Этот уровень довольно точно соответствует сетевому уровню модели OSI. На межсетевом уровне выполняется маршрутизация сигнала на основе логических адресов. Протокол ARP (Address Resolution Protocol) преобразует логические адреса в МАС-адреса. Это преобразование необходимо потому, что расположенные ниже уровни могут работать только с МАС-адресами.
· Уровень сетевого интерфейса. Этот уровень выполняет функции канального и транспортного уровней модели OSI. На уровне сетевого интерфейса работают протоколы
физического и канального уровней стандартных реализаций Ethernet и Token Ring.

На текущий момент сетевая модель DoD в чистом виде нигде не используется, но именно ее базовые положения легли в основу при разработке сетевых моделей Internet и TCP/IP (рисунок 2).

Рисунок 1 -

Соответствие четырех уровней модели DoD уровням модели OSI

Модель DOD | Протоколы TCP/IP и Internet
Уровень процессов/приложений | Telnet | FTP | LDP | SNMP
 | TFTP | SMTP | NFS | X Window
Уровень взаимодействия хостов | TCP |  | UDP
Уровень Internet | ICMP | BootP | ARP | RARP
 | IP
Уровень доступа к сети | Ethernet | Fast Ethernet | Token Ring | FDDI

Рисунок 2 -

Соответствие протоколов Internet уровням модели DoD


Модели представления сетевых объектов и устройств

Слово «модель» имеет много значений, например: «модель -схематическое описание предмета (системы, теории или явления), которое включает известные свойства предмета и может быть использовано для его дальнейшего изучения». В этом определении присутствует одно из назначений сетевых моделей: помочь описать и понять процесс сетевой коммуникации.

Другое значение слова «модель» - «пример для подражания или сравнения» - тоже неплохо подходит для сетевых моделей, поскольку они служат основой стандартизации оборудования и программного обеспечения сети.

Если разные поставщики сетевых продуктов используют одну и ту же модель, то их продукты будут совместимы друг с другом. В модели представлено, как должны происходить процессы коммуникации. Если поставщики придерживаются стандартов на каждом уровне, то их оборудование будет совместимо с оборудованием других поставщиков на других уровнях. Стандарты также облегчают процесс разработки и производства коммерческих продуктов. С точки зрения потребителя, стандартизация обеспечивает надежность и качество продуктов и услуг.

Практически все сетевые стандарты, применяемые на текущий момент основаны на одной из нижеописанных сетевых моделей или учитывают свойства нескольких.

Далее будут рассмотрены свойства следующих сетевых моделей и проектов стандартизации:

· Модель OSI (Open System Interconnection)
· Модель DoD (Department of Defense [USA])
· Модель ATM (Asynchronous Transfer Mode)
· Проект IEEE 802.x

Некоторые поставщики сетевых операционных систем используют для описания работы компонентов своих систем – собственные сетевые модели. Так на рисунке 1 представлена сетевая модель Microsoft.

Наиболее значительным органом стандартизации считается ISO, однако это далеко не единственная организация, разрабатывающая и публикующая стандартизирующие спецификации на компьютеры и сетевые компоненты.

В таблице 1 приведены наиболее известные из них.

Таблица 1 - Организации, учреждающие сетевые стандарты

ISO -

International Standardization Organization представляет собой всемирную федерацию национальных органов стандартизации. В нее входят по одному полномочному представителю более чем от 100 стран. ISO была создана в 1947 году для разработки международных стандартов в самых разных областях.

ISO тесно сотрудничает с другими международными организациями, такими как IEC (International Electrotechnical Commission), WTO (World Trade Organization) и ITU (International Telecommunications Union).

IEC -

International Electrotechnical Commission (Международная комиссия по электротехнике) существует с 1906 года, т.е. дольше чем ISO, однако ее специализация более узкая. В то время как ISO учреждает стандарты любого вида, целью IEC является стандартизация в области электротехники и электроники.

В состав IEC входят 47 национальных комиссий. В 1967 году IEC заключила соглашение с ISO о совместной разработке стандартов и спецификаций

ITU -

International Telecommunications Union (Международный союз телекоммуникаций) занимается финансированием конференций, публикацией документов и учреждением стандартов на продукты и услуги в области телекоммуникации

IETF -

Internet Engineering Task Force входит в состав IAB, который, в свою очередь, является технической консультативной группой в составе ISOC (Internet Society).

Основной задачей групп IETF является разработка и подача проектов Internet, которые затем преобразуются в официальные документы RFC (Requests for Comments — запросы на комментарии). Документы RFC, пройдя процесс официального утверждения, становятся стандартами Internet

IEEE -

Institute of Electrical and Electronics Engineers (Институт инженеров по электротехнике и электронике) занята содействием обмену информацией и разработкой стандартов и спецификаций для нижних уровней сетевых технологий (т.е. физического и канального).

Рисунок 1 -Модель сетевой коммуникации Microsoft для сетей Windows


Мультиплексирование каналов

Изначально общедоступная коммутируемая сеть создавалась для передачи речи, поэтому она обладает низкой скоростью, а модемы, которые необходимы для связи по коммутируемым аналоговым линиям, также не увеличивают скорость. Поскольку общедоступная коммутируемая сеть – сеть с коммутацией каналов, качество соединения неустойчиво. Каждый сеанс связи полностью зависит от качества каналов, подобранных для этого конкретного сеанса. При больших расстояниях качество каналов может резко меняться от сеанса к сеансу. Логичным выходом из этой ситуации является мультиплексирование нескольких каналов связи для передачи данных в одном направлении.

При использовании цифровых методов мультиплексор формирует из n входных последовательностей одну выходную, состоящую из повторяющихся групп по n одноименных блоков, сформованных за тайм-слот. Если в качестве входного используется сигнал основного цифрового канала DS0 со скоростью 64 кбит/с, то с помощью одного мультиплексора типа n:1 теоретически можно сформировать потоки со скоростью n*64 Кбит/с. Если считать этот мультиплексор первым в системе каскадного соединения из нескольких мультиплексоров второго, третьего и т.д. уровней типа m:1, l:1, k;1, … то можно сформировать различные иерархические наборы цифровых скоростей передачи или цифровые иерархии, позволяющие довести этот процесс мультиплексирования (уплотнения) каналов до необходимого уровня, дающего требуемое число каналов DS0 на выходе, выбирая различные коэффициенты кратности n, m, l, k,… .

Стандарты, реализующие данный принцип известны под общим названием плезиохронных цифровых иерархий (PDH) (таблица 1).

Таблица 1 - Три схемы иерархий: американская (АС), японская: (ЯС) и европейская (ЕС)

Уровень цифровой иерархии | Скорости передачи, соответствующие различным схемам цифровой иерархии, Кбит/с
 | AC | ЯС | ЕС
0 | 64 | 64 | 64
1 | 1544 | 1544 | 2048
2 | 6312 | 6312 | 8448
3 | 44736 | 32064 | 34368
4 | - - - | 97728 | 139264

Некоторые виды технологий, которые реализуют такую связь, или альтернативные виды связи, кратко описаны в таблице 2.

Таблица 2 – Технологии коммутации каналов связи

Название технологии | Расшифровка аббревиатуры и краткое описание организации
PSTN |
IDSN |
DSL |
DDS |
Т-носители | Т-носители (T – transmission, передача данных) представляют собой системы медных проводов, коаксиальных кабелей, оптоволокна и даже беспроводных средств связи, при этом каждая из линий обеспечивает связь 64 Кбит/с. Иногда этот тип линии называют DS (data signal). Т-линии арендуются большими компаниями для передачи больших объемов данных с высокой скоростью. Стоимость этой услуги довольно высока, поэтому допускается арендовать такое количество DS-линий, которое необходимо для организации качественной связи.
Switched 56 |
ATM | асинхронный режим передачи
OC-SONET | Synchronous Optical NETwork – синхронные оптические сети. SONET не ограничивается исключительно оптическими каналами. Спецификация определяет требования для оптического одно- и мультимодового волокна, а также для 75-омного коаксиального кабеля CATV 75.
SDH | Synchronous Digital Hierarchy - синхронная цифровая иерархия. Разработан в Европе, предназначен для замены иерархии асинхронных линий E-1/E-3, представляет собой модификацию американского стандарта на передачу данных по каналам связи SONET.
ISDN | Integrated System Digital Network - интегрированные цифровые сети. Основное назначение ISDN - передача 64-кбит/с по 4-килогерцной проводной линии и обеспечение интегрированных телекоммуникационных услуг. ISDN предполагает, что по телекоммуникационным каналам передаются цифровые коды, следовательно аналоговые сигналы в случае телефона или факса должны быть преобразованы соответствующим образом, прежде чем их можно будет передать.

Сравнительный анализ технологий Т-канал, Sonet/STS и SDH позволил составить таблицу 3.

Таблица 3 – Соотношение некоторых стандартов многоканальной связи

Стандарты многоканальных систем, («название стандарта»-«число линий в пакете») |  |  |  | Скорость передачи
Т-носители | E-носители | Sonet / STS | SDH
Частная линия Т-1/ DS-0 | - - | - - | - - | 64 Кбит/с
Т-1 / DS-1 | - - | - - | - - | 1,54 Мбит/с
- - | E-1 / ZM | - - | - - | 2,05 Мбит/с
Т-1C / DS-1C | - - | - - | - - | 3,15 Мбит/с
Т-2 / DS-2 | - - | - - | - - | 6,31 Мбит/с
- - | E-2 / M2 | - - | - - | 8,45 Мбит/с
- - | E-3 / M3 | - - | - - | 34,37 Мбит/с
Т-3 / DS-3 | - - | - - | - - | 44,73 Мбит/с
Т-3ст. | - - | OC-1/STS-1 | - - | 51,84 Мбит/с
Т-3С / DS-3С | - - | - - | - - | 89,47 Мбит/с
- - | E-4 / M4 | - - | - - | 139,26 Мбит/с
- - | - - | OC-3/STS-3 | STM-1 | 155,52 Мбит/с
Т-4 / DS-4 | - - | - - | - - | 274,18 Мбит/с
Т-5 / DS-5 | - - | - - | - - | 400,35 Мбит/с
- - | - - | OC-9/STS-9 | STM-3 | 466,56 Мбит/с
- - | - - | OC-12/STS-12 | STM-4 | 622,08 Мбит/с
- - | - - | OC-18/STS-18 | STM-6 | 933,12 Мбит/с
- - | - - | OC-24/STS-24 | STM-8 | 1244,16 Мбит/с
- - | - - | OC-36/STS-36 | STM-12 | 1866,24 Мбит/с
- - | - - | OC-48/STS-48 | STM-16 | 2488,32 Мбит/с
- - | - - | ОС-96/STS-96 | STM-32 | 4976,64 Мбит/с
- - | - - | ОС-192/STS-192 | STM-64 | 9953,28 Мбит/с
- - | - - | OC-256/STS-256 | - - | 13,271 Гбит/с


Назначение методов доступа к среде

Передача данных по сети состоит из решения двух задач:

· поместить данные в кабель без «столкновения» с данными, уже передаваемыми по нему;
· принять данные с достаточной степенью уверенности в том, что при передаче они не были повреждены в результате коллизии.

Метод доступа к среде – это набор правил, согласно которым определяется приоритет и очередность между всеми участниками сетевого обмена по приему и передаче сообщений. Они действуют на канальном уровне модели OSI.

Все компьютеры, подключенные к одному сегменту сети, должны использовать один и тот же метод доступа. В противном случае неизбежно возникнет ситуация, когда клиенты сети с разным доступом к среде будут одновременно пытаться генерировать в сеть свой служебный трафик, порождая взаимные критические ошибки передачи.

Наиболее распространены и просты в описании четыре следующих метода доступа к среде:

· метод доступа с использованием маркера;
· множественный доступ с контролем несущей и обнаружением коллизий (CSMA/CD);
· множественный доступ с контролем несущей и представлением коллизий (CSMA/CA);
· множественный доступ по приоритету запроса;
· выделенные каналы связи (фиксированные слоты).

Эти методы доступа к среде характерны для локальных вычислительных сетей. Они служат для предотвращения одновременного доступа к передающей среде нескольких компьютеров.

При передаче данных на дальние расстояния, например в глобальных сетях, наоборот возникает необходимость одновременного направления информационных потоков по единственному каналу связи пролегающему в необходимом направлении. В этом случае предполагается использование одного из следующих методов доступа с уплотнением или мультиплексированием среды передачи:

Множественный доступ с временным разделением (уплотнением) каналов (time division multiple access, TDMA). Время доступа к сети делится на интервалы, каждому интервалу назначается конкретный узел, он имеет право передавать свою информацию другим узлам именно в этот интервал. Метод слабо заполняет среду передачи, также важна точность синхронизации работы узлов.

Множественный доступ с частотным разделением каналов (frecuency division multiple access, FDMA). Каждый узел прослушивает независимую частоту, каждая из которых может считаться отдельным подканалом, коммутатор ретранслирует сигналы на разных частотах, быстро переключаясь между ними.

Множественный доступ с кодовым разделением каналов (code division multiple access, CDMA) каждый сеанс связи разбивается на отдельные пакеты, которые передаются по индивидуальным оптимизированным маршрутам. Пакеты содержат код идентификации, позволяющий осуществить правильную сборку в пункте приема.

Статический множественный доступ (statical multiple access). Этот метод не ориентируется на строгое закрепление узла по времени или частоте. Коммутатор непрерывно анализирует каждый канал и определяет наличие запросов на передачу данных. Эффективность использования среды передачи намного выше, чем в TDMA или FDMA, поскольку реализован «доступ по требованию». Характеристики необходимой полосы пропускания также анализируются коммутатором и удовлетворяются полностью или частично в зависимости от занятости среды передачи.

Коммутация каналов (circuit switching). Здесь коммутатор отвечает за организацию физической линии связи между передающим и принимающим узлами. Принцип такой же, как в телефонных сетях. После завершения сеанса связи канал разъединяется и коммутатор сможет обслужить следующую пару узлов.

При коммутации сообщений (message swithing) для передачи данных используется метод промежуточного хранения. Данные передаются от одного узла к другому, где они временно запоминаются до тех пор, пока не будет доступным канал к точке назначения этих данных. Количество ретрансляций может быть довольно значительным.

Коммутация пакетов (packet switching) представляет собой комбинацию методов коммутации каналов и сообщений. Канал связи, организуемый на весь период сеанса связи является логическим (виртуальным), реализованным с помощью промежуточных узлов пересылки. Маршрут продвижения информации будет выбран наиболее оптимальным для текущего момента времени и участников соединения. Данный метод является наиболее производительным и эффективным.


Одноранговые сети и сети на основе сервера

Различают два варианта организации управления компонентами сети - одноранговые сети и сети на основе сервера, что соответствует децентрализованной и централизованной системе управления.

Одноранговые или пиринговые сети (peer-to-peer, P2P - равный с равным) - это компьютерные сети, основанные на равноправии участников. В таких сетях отсутствуют выделенные серверы, а каждый узел (peer) является как клиентом, так и сервером.

В качестве клиента (потребителя ресурсов) каждая из машин может посылать запросы на предоставление каких-либо ресурсов другим машинам в пределах этой сети и получать их. Как сервер, каждая машина должна обрабатывать запросы от других машин в сети, отсылать то, что было запрошено, а также выполнять некоторые вспомогательные и административные функции.

Любой узел данной сети не дает гарантии своей постоянной работы в режиме on-line. Он может подключаться к сети и выходить из нее в любой момент времени, вынуждая подключенных клиентов искать другой узел, предлагающий такой же сетевой ресурс или сервис.

При достижении определённого критического размера сети наступает такой момент, когда в сети могут дублироваться функции и некоторые виды ресурсов, что приводит к путанице при определении исполнителя запроса.

Помимо чистых P2P-сетей, существуют так называемые гибридные сети, в которых существует по крайней мере один сервер, используемый для координации работы (в сетях Bittorrent, eDonkey) или для предоставления информации о существующих машинах сети, а также их статусе: on-line, off-line и т. д. (например, в сети ICQ).

Сейчас одноранговые сети условно разделяют на следующие два подмножества: пиринговые файлообменные сети и пиринговые сети распределённых вычислений.

Сети клиент-сервер (Сlient/Server) — сетевая архитектура, в которой устройства являются либо клиентами, либо серверами на постоянной основе.

Клиентом (front end) является запрашивающая машина (обычно ПК), сервером (back end) — машина, которая отвечает на запрос. Оба термина (клиент и сервер) могут применяться как к физическим устройствам, так и к программному обеспечению.

Сети с выделенным сервером (Сlient/Server network) — сеть, в которой сетевые устройства централизованы и управляются одним или несколькими серверами. Индивидуальные рабочие станции или клиенты должны обращаться к ресурсам сети через сервер (рисунок 1).

Рисунок 1 -

Сеть с выделенным сервером

Этот принцип распространяется и на взаимодействие программ и информационных сред. Программа (среда), выполняющая предоставление соответствующего набора услуг - "сервер", а программа (среда), пользующаяся этими услугами - "клиент". Технология традиционной модели "клиент-сервер" модернизируется и совершенствуется.

Аналогично вариантам организации управления компонентами сети, также можно разделить и сетевые модели:

· разбиение сети на рабочие группы;
· построение сети на базе доменной архитектуры;
· группировка сетевых устройств по другим признакам.

Сетевая модель обслуживания пользователей в первую очередь зависит от того, какая операционная система установлена на каждом из узлов сети, а также какая операционная система управляет сетевыми потоками.

Примерами одноранговых ОС могут служить LANtastic, Personal Ware, Windows for Workgroups, Windows 95/98.

Для централизованного управления многие компании выпускают две версии одной и той же операционной системы. Одна версия предназначена для работы в качестве серверной ОС, а другая - для работы на клиентской машине. Эти версии чаще всего основаны на одном и том же базовом коде, но отличаются набором служб и утилит, а также параметрами конфигурации, в том числе устанавливаемыми по умолчанию и не поддающимися изменению. Например, Windows 2000 Professional (client) – Windows 2000 Advanced Server, аналогичны примеры и для версий XP и 2003.


Общие положения

Комплекс протоколов Internet охватывает целое семейство протоколов, прикладные программы, и даже саму сеть.

Протоколы Internet можно использовать для передачи сообщений через любой набор объединенных между собой сетей. Они в равной мере пригодны для связи как в локальных, так и в глобальных сетях. Комплект протоколов Internet включает в себя не только спецификации низших уровней (такие, как ТСР и IP), но также спецификации для таких общих применений, как почта, эмуляция терминалов и передача файлов. На рисунке 1 представлены некоторые из наиболее важных протоколов Internet и их связь с эталонной моделью OSI.

Рисунок 1 -

Модель OSI и протоколы Internet

В состав этого комплекса входят протоколы UDP (User Datagram Protocol), ARP (Addres Resolution Protocol), ICMP (Internet Control Message Protocol), TELNET, FTP (File Transfer Protocol) и многие другие. TCP и IP- наиболее удачные протоколы из комплекса протоколов Internet.


Общие положения адресации

Адресация в сетях – это процедура, состоящая из нескольких этапов преобразования для установления однозначного соответствия адреса приемника приемнику, а адреса источника источнику. Сама процедура носит название отображения или разрешения имен. Она делится три этапа, соответствующих трем уровням адресации: прикладному, транспортному и сетевому. Что легко соотносится с эталонной моделью OSI.

На верхнем уровне адресации используются специальные имена, например, идентификаторы процессов, рабочих станций или символьные доменные имена. Они предназначены для конкретных процессов, программ ими управляющих, а также для пользователей. Дополнительное назначение адресов верхнего уровня – удобство работы программистов и/или пользователей при обращении к сетевым ресурсам, что помогает существенно увеличить скорость при использовании сетевых ресурсов и управлении ими.

Адреса сетевого уровня назначаются и используются операционной системой и программами управления сетевых устройств. Здесь решаются вопросы маршрутизации, что накладывает свои требования на структуру адресных конструкций. У работающей операционной системы может быть один и более сетевых адресов. При этом, если используется несколько интерфейсных карт, то операционная система должна назначить однозначное соответствие каждого сетевого адреса конкретному порту сетевого обмена, например, сетевому адаптеру. Для этого самой нижней части адресного стека применяются физические адреса устройств (MAC-адреса).

Передача информационных импульсов по любой среде передачи может и должна быть принята любым другим сетевым устройством, которое подключено к этой среде. Таким образом, именно MAC-адреса позволяют перенаправить пакет конкретному сетевому адаптеру или модему или любому другому активному сетевому оборудованию.

Уникальный сетевой адрес присваивается каждому адаптеру сети еще на этапе его изготовления. Количество возможных адресов должно быть достаточно большим, чтобы можно было быть уверенным, что в любой сети по всему миру никогда не будет абонентов с одинаковыми адресами. Поэтому был выбран 48-битный формат адреса, что соответствует примерно 280 триллионам различных адресов. Считается, что столько сетевых адаптеров никогда не будет выпущено.

Такой подход к адресации был разработан международной организацией IEEE, занимающейся стандартизацией сетей. Он используется в большинстве сетей и рекомендован для новых разработок.

Практически все сетевые стандарты, перечисленные в предыдущей главе, используют собственные механизмы распределения адресов. Можно перечислить следующие примеры подходов к решению данной задачи:

· статические физические адреса;
· выбор из фиксированного подмножества статических адресов;
· статические адреса назначаемые администратором;
· динамические адресные системы:
· централизованные;
· децентрализованные;
· случайные адресные системы.

Классическая система адресации сводится к тому, что при установке сети каждому абоненту присваивается индивидуальный адрес по порядку, к примеру, от 0 до 30 или от 0 до 254. Присваивание адресов производится программно или с помощью переключателей на плате адаптера. При этом требуемое количество разрядов адреса определяется из неравенства:

2n > Nmax,

где n – количество разрядов адреса, а Nmax – максимально возможное количество абонентов в сети. Например, восемь разрядов адреса достаточно для сети из 255 абонентов. Один адрес (обычно 1111....11) отводится для широковещательной передачи, то есть он используется для пакетов, адресованных всем абонентам одновременно.

Именно такой подход применен в известной сети Arcnet. Достоинства данного подхода – малый объем служебной информации в пакете, а также простота сетевого оборудования, распознающей адрес пакета. Недостаток – трудоемкость задания адресов и возможность ошибки (например, двум абонентам сети может быть присвоен один и тот же адрес). Контроль уникальности сетевых адресов всех абонентов возлагается на администратора сети.

Далее рассматриваются некоторые из распространенных систем адресации, применяемых в компьютерных сетях.


Оптоволокно

Используется для передачи информационного сигнала в виде оптического импульса. Состоит из одной или нескольких стеклянных или пластиковых жил (световодов), покрытых слоем стекла которых в свою очередь заключены в поливинхлоридную оболочку.

Оптоволокно допускает использование одного световода для организации нескольких сеансов связи одновременно в обоих направлениях. Если это реализовано кабельная система называется многомодовой, если нет – одномодовой.

В многомодовом оптоволокне есть два варианта организации одновременного двухстороненнего обмена несколькими участниками соединения через один световод:

 со сдвигом фаз одной длины световой волны;
 с использованием разных длин световых волн.

Распространение оптического сигнала в кабеле проходит так как показано на рисунках 1-3, структура и способ соединения на рисунке 4.

Рисунок 1 -

Распространение световых импульсов в одномодовом оптоволоконном кабеле

Рисунок 2 -

Распространение световых импульсов во многомодовом оптоволоконном кабеле с использованием сдвига фаз

Рисунок 3 -

Распространение световых импульсов во многомодовом оптоволоконном кабеле с использованием сдвига длины волны

Для генерации световых импульсов, передаваемых по оптической нити волоконно-оптического кабеля, используется два источника света:

 светодиоды. Обычно используются в одномодовом режиме, интенсивность импульсов невелика.
 полупроводниковые лазеры. Генерируют интенсивный, хорошо сфокусированный световой импульс заданного цвета. Используются в многомодовом режиме.

Технология изготовления оптических кабелей такова, что механические характеристики их значительно превосходят медные кабели на витой паре 5-й категории (UTP). Для сравнения можно привести допустимые усилия при прокладке кабеля, которые для оптоволокна составляют 100 кг, а для витой пары – 15 кг.

Рисунок 4 -

Пример структуры оптоволокона и способа его соединения

Важное свойство оптического волокна – долговечность. Время жизни волокна, то есть сохранение им своих свойств в определенных пределах, превышает 25 лет, что позволяет проложить оптико-волоконный кабель и, по мере необходимости, наращивать пропускную способность канала путем замены приемников и передатчиков на более быстродействующие.

Применяют в топологиях: звезда, кольцо, ячейка и их комбинации.

Максимальная скорость передачи по данному виду кабеля, полученная в экспериментальных условиях, достигает 3 Тбит/с.

Примеры сетевой архитектуры Ethernet на базе оптоволокона

Сетевой стандарт | Тип кабеля | Диаметр световода/кабеля мкм | Длина волны, нм | Максимальная длина сегмента, м | Максимальная скорость, Мбит/с
10Base-F | одномодовый | 50 или 100 |  | 2000 | 10
100Base-FX | многомодовый одномодовый | 62,5/125 | 1350 | 2000 20000 | 100
1000Base-LX | многомодовый многомодовый одномодовый | 62,5/125 50/125 10 | 1300 | 550 550 5000 | 1000
1000Base-SX | многомодовый | 62,5/125 50/125 | 850 | 220-275 500-550 | 1000
10GBase-ER | одномодовый | 9/125 | 1550 | 40000 | 10000
10GBase-EW | одномодовый | 9/125 | 1550 | 40000 | 10000
10GBase-LR | одномодовый | 9/125 | 1310 | 10000 | 10000
10GBase-LW | одномодовый | 9/125 | 1310 | 10000 | 10000
10GBase-LX4 | многомодовый | 62,5/125 | 1310 | 300 | 10000
10GBase-SR | многомодовый | 50/125 | 850 | 65 | 10000
10GBase-SW | многомодовый | 62,5/125 | 850 | 65 | 10000


Организация сетевой печати

Сетевая печать – это частный случай распределенной печати. Организация распределенной печати, т.е. распределение ресурсов печатающих устройств между несколькими пользователями является наиболее популярным сервисом в локальной сети. Основной причиной этого можно считать следующую постановку вопроса:

1 Если обеспечить всех клиентов сети локальными печатающими устройствами, то их уровень загруженности будет стремиться к весьма малому значению.
2 Обслуживание такого количества печатающих устройств и контроль за их использованием по назначению – дорогостоящая и очень сложная задача.
3 Скорость и качество печати на этих устройствах будут низкими, так как большое количество дорогостоящих устройств приобретаться не будет, а дешевые и бюджетные решения – обладают низкими скоростью и качеством отпечатков.

Таким образом, для любой организации, применяющей в своем производственном процессе вычислительные сети, выгодно приобрести небольшое количество качественных печатающих устройств и организовать дифференцированный уровень доступа пользователей к каждому из них.

Распределенную печать реализуют несколькими способами:

Применением несетевых специализированных промежуточных устройств подключения к принтеру - Switcher (переключатель).

Такие устройства являются наиболее дешевым и простым с точки зрения пользователя решением данной проблемы. Компьютеры пользователей подключаются к Switcher-у с помощью стандартных портов: COM, LPT, USB (рисунок 1).

Рисунок 1 -

Схема подключения компьютеров к принтеру через Switcher

Switcher является «прозрачным» для запросов пользователя и, таким образом, принтер как бы локально подключен к компьютеру. Очередность доступа к принтеру передается последовательно между всеми портами Switcher-а. Если одно из устройств начало печатать, для остальных принтер переходит в состояние ожидания (т.е. устройство занято). Очередь печати управляется операционной системой клиента.

 Посредством использования аппаратных принт-серверных средств (принтер подключается к сети непосредственно или через специализированное коммутирующее устройство).

Если в предыдущем случае уровень физического доступа к печати был ограничен числом портов Switcher-а, то здесь все клиенты сети физически подключены к печатающему устройству посредством сети. Ограничение доступа к нему осуществляется назначением прав доступа.

а) специализированный комплекс Xerox Document Centre 425 | б) устройство сетевого расширения D-Link с двумя LPT и 1 USB выходами

Рисунок 2 -

Примеры аппаратных «print-server» устройств

· Программно-эмулируемое принт-серверное устройство.

Самый медленный способ организации сетевой печати. В этом случае часть производительной мощности сервера выделяется на обслуживание заданий печати. Очередь на печать строится в пределах операционной системы сервера. Управление заданиями печати возлагается на сервер и его администратора, но часть прав по управлению этой очередью можно передать и клиентам сети.

Права доступа к принтеру определяются двумя способами:

· авторизовано (на уровне пользователей);
· на уровне ресурсов (общий пароль доступа).

Управление правами доступа, как правило, осуществляется с помощью специализированного ПО, поставляемого вместе с аппаратным принт-сервером, либо посредством протокола удаленного управления (например, Telnet). Для пользователей назначаются права следующих видов: постановка заданий на печать; удаление заданий с печати; управление очередью печати.


Оформление структурированных кабельных систем

Декоративные настенные кабельные короба предназначены для укладки информационных и силовых кабелей различного назначения и установки розеток.

Декоративные короба используются в тех случаях, когда:

· прокладка кабелей другими способами невозможна и нецелесообразна;
· возникает потребность в защите кабелей от механических повреждений, попаданий брызг воды и других жидкостей;
· необходимо обеспечение высоких эстетических характеристик внутренней отделки офисных помещений.

Кабельные короба представляют собой полые закрытые желоба различных сечений, обязательно имеющие съемную или по меньшей мере откидную крышку и предназначенные для монтажа на любой плоской капитальной или декоративной вертикальной поверхности. Наиболее популярны прямоугольные сечения, кроме них производятся трапециевидные, треугольные и полукруглые в сечении короба и декоративные плинтусы.

Короб может быть:

· цельным – в этом случае он состоит из единого корпуса пластика и по одному из его ребер имеется разрез с пазами для крепления. С противоположной стороны пластмасса в зоне перегиба имеет меньшую толщину и за счет этого обладает повышенной гибкостью (рисунок 1.а);
· составным, то есть состоящим из двух компонентов: основания и крышки. Крышки выполняются как П-образными (рисунок 1.б), так и плоскими (рисунок 1.а);
· сборными с поворотной крышкой (рисунок 1.г);
· других конфигураций.

Рисунок 1 -

Конструкции прямоугольных коробов

а) цельный

б) составной с П-образной крышкой

в) составной с плоской крышкой

г) сборный с поворотной крышкой

д) напольный короб

Для каждого из типоразмеров короба производители предлагают более или менее полный ряд стандартных комплектующих элементов. Эти элементы существенно расширяют возможности прикладки и монтажа, а также улучшают эстетические характеристики смонтированных коробов (рисунок 2).

Рисунок 1 -

Типовые комплектующие элементы кабельных коробов

а) внутренний угол

б) внешний угол

в) плоский угол

г) отвод

д) торцевая заглушка

е) разделительная стенка

Внедрение структурированной кабельной системы всегда положительно сказывается на характеристиках качества и надежности функционирования оборудования физического уровня.

Рисунок 3 -

Вариант оформления кабельных систем

Основными материалами, из которых изготавливаются декоративные короба, являются ударопрочные пластмассы и металлы (алюминий, а также обычная, оцинкованная или нержавеющая сталь).


Понятие домена

Если рабочая группа часто ориентирована на одно помещение, то при разработке доменной архитекруры был положен принцип: любой компьютер, регистрирующийся в сети, может относиться к любому из доменов вне зависимости от его расположения (территориально) или принадлежности к какому-либо из отделов.

На каждую учетную запись пользователя ведется отдельный учет по тем правам, которые для него назначены в домене.

База данных SAM (Security Accounts Management - управление безопасными учетными записями) - главная служба каталога для нескольких вариантов систем Microsoft Windows NT (например, Windows NT 3.5 и Windows NT Server 4). База данных SAM масштабируется намного лучше, чем предыдущая архитектура службы каталога из-за введения междоменных доверительных отношений. Если текущий домен доверяет другому домену, то он имеет право назначать (дилегировать) любому пользователю или группе пользователей из этого домена права доступа к своим внутридоменным сетевым ресурсам. Как правило подобная сложная структура бывает централизованной. Управление осуществляется при помощи выделенного сервера. Выделенный сервер может нести несколько функциональных нагрузок - файл-сервер, принт-сервер, mail-сервер, сервер баз данных и прочие. Но для организации домена необходимо, чтобы он также выполнял функцию «контролера домена».

В пределах домена все администраторы имеют полный контроль над серверами и службами, которые на них выполняются. По мере роста количества доменов в организации обеспечение уверенности относительно доверительных отношений, которые делают возможным пользовательскую идентификацию для доступа к ресурсам внешних доменов, приводит к росту накладных расходов. Чтобы справиться с этой растущей сложностью доменов и доверительных отношений, сетевые администраторы реализуют одну из четырех доменных моделей (рисунок 1): отдельный домен (single domain), домен с одним хозяином (master domain), домен с несколькими хозяевами (multiple master domain) и отношения полного доверия (complete trust).

При поддержке этих моделей самая большая сложность состоит в необходимости создания и сопровождения большого количества доверительных отношений. При этом все доверительные отношения между доменами Windows NT 4 должны создаваться с двух сторон, т.е. в обоих доменах.

Рисунок 1 -

Четыре доменные модели, используемые в Windows NT 4

База SAM является самым узким местом при такой системе управления сетевыми ресурсами и все ее ограничения являются ограничения системы администрирования в целом.

Во-первых, SAM одного домена имеет ограничение размера в 40 Мбайт. В результате количество объектов учетных записей (пользователи, их группы и узлы сети) не может превышать 40000.

Второе ограничение на базу данных SAM состояло в возможностях доступа. Единственным методом доступа для взаимодействии с SAM является Windows NT Server. Этот метод ограничивает программируемый доступ и не обеспечивает конечным пользователям легкого доступа для поиска объектов.

В-третьих, функция контроллера домена, связанная с обновлением SAM достаточно сложна и имеет собственную иерархию отношений.

Первичный контроллер домена (Primary Domain Controller - PDC) обладает в сети правами единственного автора изменений SAM, то есть регистрация любого сетевого объекта должна осуществляться на PDC. Для поддержки работоспособности сетевых сегментов, территориально удаленных от PDC, в сети устанавливают дополнительные или вторичные контроллеры домена (Secondary Domain Controller - SDC), которые обслуживают запросы пользователей на авторизацию в случае отсутствия отклика от PDC.

Для выполнения своих функций SDC хранит копию SAM, внесение изменений в которую запрещены, разрешена только синхронизация этой копии с основной базой SAM, хранящейся на PDC.


Понятие и функции стека протоколов

Иерархически организованный набор разноуровневых протоколов, достаточный для организации полноценного взаимодействия узлов в сети называется стеком протоколов.

Протоколы нижних уровней часто реализуются комбинацией программных и аппаратных средств, а протоколы верхних уровней, как правило, программными средствами.

Примером протокола физического уровня может служить спецификация 10Base-T технологии Ethernet, которая определяет в качестве используемого кабеля неэкранированную витую пару с волновым сопротивлением 100 Ом, разъем RJ-45.

Протоколы канального уровня реализуются компьютерами, мостами, коммутаторами и маршрутизаторами. Протокол канального уровня обычно работает в пределах сети, являющейся одной из составляющих более крупной составной сети, объединенной протоколами сетевого уровня.

На сетевом уровне определяются 2 вида протоколов:

· маршрутизируемые протоколы - реализуют продвижение пакетов через сеть. Их имеют ввиду, когда говорят о протоколах сетевого уровня;
· маршрутизирующие протоколы или протоколы маршрутизации. С помощью этих протоколов маршрутизаторы собирают информацию о топологии межсетевых соединений, на основании которых осуществляется выбор маршрута продвижения пакетов.

Все протоколы, начиная с транспортного уровня и выше, реализуются программными средствами конечных узлов сети- компонентами их сетевых ОС.

Протоколы нижних 4-х уровней решают задачу транспортировки сообщений в составных сетях с произвольной топологией.

Оставшиеся 3 верхних уровня решают задачи предоставления прикладных сервисов.

Функции протокола сеансового уровня часто объединяют с функциями прикладного уровня и реализуют в одном протоколе.

На представительском уровне может выполняться шифрование и дешифрование данных.

Прикладной уровень - в сущности и есть набор разнообразных протоколов, с помощью которых пользователи сети получают доступ к разделяемым ресурсам, таким как файлы, принтеры, Web-страницы.

В следующей сводной таблице приведен список протоколов различных уровней наиболее популярных на текущий момент.

Уровни модели OSI

Популярные версии протоколов соответствующего уровня

Прикладной

 FTP - протокол копирования файлов
 TFTP - упрощенный протокол копирования файлов
 X.400 - электронная почта
 Telnet - удаленный доступ в сеть
 SMTP - простой протокол почтового обмена
 CMIP - общий протокол управления информацией
 SNMP - простой протокол управления сетью
 NFS - сетевая файловая система
 FTAM - метод доступа для копирования файлов

Представительский
 DNS
 LDAP
 NetBIOS/IP

Сеансовый

Сеансовый уровень редко реализуется в виде отдельных протоколов. Функции этого уровня часто объединяют с функциями прикладного уровня и реализуют в одном протоколе.

Транспортный

 TCP - протокол управления передачей
 NCP - Netware Core Protocol
 SPX - упорядоченный обмен пакетами
 TP4 - протокол передачи класса 4

Сетевой

 IP - протокол Internet
 IPX - протокол межсетевого обмена
 X.25 (частично этот протокол реализован на канальном уровне)
 CLNP - сетевой протокол без организации соединений

Канальный

 HDLC для последовательных соединений
 IEEE 802.2 LLC (тип I и тип II) обеспечивают управление доступом (MAC) для сред 802.x
 Ethernet
 Token Ring
 FDDI
 X.25
 Frame relay
 PPP

Физический

 EIA-RS-232-C, CCITT V.24/V.28 – механические и электрические характеристики несбалансированного последовательного интерфейса
 EIA-RS-422/449, CCITT V.10 - механические, электрические и оптические характеристики сбалансированного последовательного интерфейса
 IEEE 802.3 -- CSMA/CD (Ethernet)
 IEEE 802.5 -- Token Ring


Понятие информационной сети

Впервые компьютерные сети появились практически одновременно с самими компьютерами. Это было связано с тем, что ресурс машинного времени был чрезвычайно дорогим, важно было разделить его стоимость между несколькими пользователями, которые могли бы параллельно готовить свои данные для обработки, которые могли бы впоследствии последовательно обрабатываться блоками вычислительной машины, отвечающими за вычисления. Так появились принципы разделения ресурсов и системы терминалов. Такие системы широко использовались вплоть до 80-х годов ХХ века, а некоторые образцы использовались практически до начала XXI века.

Второе рождение компьютерных сетей было вызвано практической потребностью в совместном использовании данных пользователями персональных вычислительных систем.

С этой точки зрения для компьютерных сетей подходит определение – система независимых компьютеров, связанных друг с другом с целью совместного использования данных, периферийных устройств и других сетевых ресурсов.

Изначально все сети можно было разделить на два класса:

· информационные сети;
· сети обработки данных или вычислительные сети.

К информационным сетям относились системы передачи сигналов, сообщений, данных и других видов информации.

К сетям обработки данных относились системы распределенного и объединенного вычисления. Но, поскольку распределенная обработка нуждается в использовании механизмов информационного обмена, эта грань постепенно стерлась и, на текущий момент, все компьютерные сети являются одновременно информационными и вычислительными.

С точки зрения выполняющейся программы, сеть – сложная система маршрутов передачи данных и ресурсов для их обработки.

Для пользователя компьютерная сеть является инструментом доступа к сетевым ресурсам.

Для администратора сеть является средством управления производственными процессами.

Для разработчика сеть – это набор стандартов и требований которые должны быть выполнены в рамках реализации проекта.

Службы, реализуемые различными сетями, могут быть ориентированными на соединение и не ориентированными на соединение. Аналогами этих типов служб могут служить телефонная связь и почтовая служба. Вид используемого соединения выбирается исходя из необходимой надежности доставки данных и допустимых при этом накладных расходах.

Неориентированная на соединение служба (т.е. без гарантий доставки) называется дейтаграммной службой. При необходимости надежной доставки сравнительно коротких сообщений при отсутствии соединения используется служба дейтаграмм с подтверждениями.

Существует также служба запросов-ответов. Обычно данная модель обмена данными используется в модели «клиент-сервер».

Рисунок 1 -

Шесть типов служб

Вычислительная сеть, обладает возможностью распараллеливания вычислений, за счет чего достигается повышение производительности и отказоустойчивости системы.

Таким образом, локальная вычислительная сеть – это:

· отличный показатель «производительность-используемость-стоимость» вычислительных ресурсов;
· совместное использование данных и устройств;
· оперативный доступ к обширной корпоративной информации;
· использование внешних данных (например, Internet);
· интеграция информационных систем.

Однако, существуют и связанные с внедрением сетей проблемы. Например, сложное программирование для распределенных систем, обеспечение совместимости ПО, обеспечение надежности передачи информации, обеспечение безопасности.

Область использования вычислительных сетей сегодня постоянно расширяется, она включает науку, образование, бизнес, развлечения.


Понятие рабочей группы

Понятие рабочей группы

Рабочая группа – это способ реализации совместной работы нескольких связанных между собой общими информационными ресурсами компьютеров ("workgroup"), объединенных для решения какой-либо общей задачи. Это первый, основной и весьма эффективный способ управления сетевыми ресурсами в одноранговой сети.

Как правило, все пользователи рабочей группы могут иметь либо равный уровень доступа к ресурсам, либо он может регулироваться с помощью системы паролей. В Microsoft Windows эта модель использования сетевых ресурсов называется «распределение прав доступа на уровне ресурсов».

Характерные примеры операционных систем для работы в рабочей группе - Novell NetWare, OS/2 Lan Manager (2-я версия- Warp Connect), Windows95, Windows98 и Windows3.11 For Work Groups (в качестве расширения MS-DOS).

Сети Novell NetWare также реализовывали рабочие группы терминалов по управлением выделенного сервера. Данный способ позволял максимально эффективно задействовать как пропускную способность сетей тех лет, так и организовать надежную защиту данных от несанкционированного доступа.

Для поддержки сетевого обмена каждый из компонентов вынужден время от времени напоминать о себе и своих ресурсах другим участникам соединения. Каждая рабочая станция составляет карту сетевых ресурсов рабочей группы. Поэтому в таких сетях популярны широковещательные протоколы канального уровня, в том числе стеки протоколов IPX/SPX и NetBIOS. Недостатком этого метода являются существенные задержки между моментом организации (инициализации) сетевого ресурса и моментом его появления в списках доступа конкретной рабочей станции.

Так же для рабочей группы характерна следующая ситуация:

· если у машины нет сетевых ресурсов - ее не видно в сети;
· пользователи других рабочих групп не имеют доступа к чужим сетевым ресурсам.

Объединение двух рабочих групп в одной сети организуется на уровне оборудования – физическим соединением, а на уровне администрирования -

Пример. Типы рабочих групп: "Дирекция", "Бухгалтерия", "Канцелярия". Компьютерная сеть организации может объединять несколько рабочих групп. У каждого компьютера рабочей группы имеется идентификатор, имя в группе, например, по ФИО человека, на нем работающего. В рабочей группе "Бухгалтерия" может существовать компьютер (рабочее место) "Главбух" или "Иванов Сергей Николаевич".

Рабочая группа может быть и временной - для работы над конкретным проектом в пределах определенного промежутка времени.

Пример. Можно организовать рабочую группу "Презентация фирмы", которая состоит из компьютеров сотрудников фирмы, подготавливающих презентацию своей фирмы, или "Годовой отчет" - для подготовки годового финансового отчета фирмы. Все эти люди могут работать в разных отделах, но они составляют временную рабочую группу, чтобы было легко обмениваться информацией общего доступа при работе над отчетом.

Обмен информацией может происходить и между рабочими группами. Для этого не нужно физически перемещать компьютеры: чтобы сформировать рабочую группу, достаточно присвоить всем компьютерам, входящим в состав группы, ее имя.

Пример. Операционная система Windows for Workgroups позволяет выделение компьютеров в рабочие группы при ее инсталляции. Изменять состав и структуру рабочей группы затем можно из "Панели управления", запустив прикладную программу Network (сеть). При этом все компьютеры одной сети, независимо от их объединения в рабочие группы, имеют доступ к общим принтерам и общим файлам, а такие приложения как Mail (Электронная почта), Shedule+ (Ежедневник), работают только в пределах одной рабочей группы. Передача почты через Mail возможна только в пределах одной рабочей группы. Как правило, в небольших фирмах имеется одна рабочая группа.


Понятие среды передачи данных

Под средой передачи данных следует понимать набор оборудования с помощью которого осуществляется взаимодействие между участниками соединения в рамках сеанса связи.

В самом простом случае среда передачи может быть реализована в виде кабеля (единственного или в составе группы) и/или использовать какой либо из видов беспроводных технологий.

Для использовании кабеля в компьютерной сети должны быть однозначно описаны:

· тип кабельной системы и ее физические характеристики;
· формы и уровни информационного сигнала;
· способы разветвления среды передачи и подключения к ней;
· требования, выставляемые к сетевому оборудованию.

При использовании беспроводных технологий ограничений и требований еще больше, поскольку каждая из этих сред имеет особые способы кодирования, декодирования и применения сигнала в среде.

Обычно среда передачи работает в одном из следующих режимов:

Симплексная передача. Однонаправленный канал, сигналы проходят по нему всегда только в одном направлении.

Полудуплексная передача. Сигналы могут передаваться в обоих направлениях по единственному каналу связи, но в каждый момент времени сигналы передаются только в одну сторону.

Дуплексная передача. Данный способ реализует полноценную двустороннюю связь по единственному каналу связи.

Свойства среды передачи определяют уровень защиты передаваемых сигналов от помех. Помехи бывают следующих типов:

Электромагнитные помехи представляют собой вторжение постороннего электромагнитного сигнала, нарушающего форму полезного сигнала. Когда в полезный сигнал добавляются внешние помехи, принимающий компьютер не может правильно интерпретировать сигнал.

Радиочастотные помехи представляют собой сигналы радиопередатчиков и других устройств, генерирующих сигналы на радиочастотах. К ним относятся также процессоры и дисплеи компьютеров. Радиочастотным считается электромагнитное излучение на частотах от 10 КГц до 100 ГГц. Излучение на частотах от 2 до 10 ГГц называется также микроволновым.

Влияние радиочастотных помех устраняется с помощью помехозащитных фильтров, применяемых в различных типах сетей.

Перекрестные помехи. К этому типу помех относятся сигналы проводов, расположенных на расстоянии нескольких миллиметров друг от друга. Протекающий по проводу электрический ток создает электромагнитное поле, которое генерирует сигналы в другом проводе, расположенном рядом. Довольно часто, разговаривая по телефону, можно услышать приглушенные разговоры других людей. Причиной этого являются перекрестные помехи.

Перекрестные помехи значительно уменьшаются, если скрутить два провода, как это сделано в витой паре. Чем больше витков приходится на единицу длины, тем меньше влияние помех.

Затухание сигналов. Проходя по кабелю, электрические и оптические сигналы становятся все слабее. Чем больше расстояние до источника, тем слабее сигнал. Такое ослабление сигнала с расстоянием называется затуханием сигнала. Затухание является причиной того, что в спецификациях различных сетевых архитектур указывается ограничение на длину кабеля. Если это ограничение соблюдается, то эффект затухания не повлияет на нормальную работу канала связи.

Различные кабельные системы имеют различные допуски по диапазону рабочих частот и скорости затухания сигнала (рисунок 1).

Рисунок 1 -

Характеристики витой пары, коаксиального кабеля и оптоволокна

При увеличении частоты затухание увеличивается, потому что, чем выше частота сигнала, тем интенсивнее рассеивание его электромагнитной энергии в окружающее пространство. При увеличении частоты сам провод превращается из носителя сигнала в антенну, рассеивающую его энергию в пространство.

Все стандарты относящиеся к среде передачи данных описываются на физическом уровне модели OSI.


Понятие топологии

Структура вычислительной сети делится на две составные части: логическую и физическую.

Логическая структура сети подчинена структуре информационных потоков. Она является первичной и ключевой при разработке физической структуры сети.

Под термином физическая структура сети следует понимать базовый принцип, который используется при размещении узлов и рабочих станций, а также активного оборудования сети на территории (в здании, группе зданий и между ними), то есть топологию компьютерной сети.

С точки зрения проектирования компьютерных сетей топология – это описание основной компоновки сети.

Топология определяет следующие свойства:

· тип кабельной системы;
· тип и характеристики передающего оборудования, применяемого для передачи данных;
· физическое размещение: компьютеров, силовых и информационных кабелей, а также других компонентов сети;
· способ прокладки кабеля;
· возможность расширения сети;
· способ управления сетью.

На текущий момент наиболее популярными являются четыре типа базовых топологий, называемых «чистыми»: шина, кольцо, звезда, ячейка, два типа комбинированных: «звезда-шина», «звезда-кольцо», остальные относят к сложным или смешанным топологиям.

Некоторые варианты сложных топологий представлены на рисунке 1. Вариант 1.а является примером нерегулярной топологии, а вариант 1.б - иерархический случай связи (древовидная топология).

а)

б)

Рисунок 1 -

Примеры сложных топологий вычислительных сетей

Если топологии шина, кольцо, звезда, ячейка, звезда-шина, звезда-кольцо», чаще применимы для локальных сетей, то более сложные схемы типичны для региональных и глобальных сетей. Некоторые современные вычислительные сети используют и другие сетевые структуры: решетки, кубы, гипердеревья, гиперкубы и т.д. (рисунок 2).

а)

б)

в)

Рисунок 2 -

Структуры топологий сложных вычислительных систем

а) топология «решетка»

б) топология «гипердерево»

в) топология «куб»

Сложные топологии – это топологии с программируемой структурой, которые настраиваются под решаемую задачу.

Топология часто определяет способ взаимодействия компьютеров в сети. В частности – метод доступа к среде.

Выбор топологии локальной или региональной сети существенно сказывается на ее стоимости и рабочих характеристиках. При этом важной характеристикой при однородной сети является среднее число шагов между узлами D.

,

где n - полное число узлов в сети; α - расстояние между узлами сети,
Nd - число узлов сети на расстоянии α.

Как правило, обычная локальная сеть, которая проектируется с нуля, подчинена одному из четырех типов «чистых» топологий. После проведения модификации и/или адаптационных работ ее топология становится сложной или смешанной.

Требования топологий дополняются положениями закрепленными в стандартах структурированных кабельных систем.


Почтовые протоколы

Протокол SMTP (Simple Mail Transfer Protocol - простой почтовый протокол, RFC-821, RFC -822) представляет собой почтовый сервис, смоделированный на основе файлового сервиса FTP. SMTP обеспечивает передачу почтовых сообщений между системами и уведомления о входящей почте. SMTP - довольно независимая субсистема, требующая только надежного канала связи. Средой для SMTP может служить отдельная локальная сеть, система сетей или вся сеть Internet.

Протокол SMTP обеспечивает передачу почтового сообщения непосредственно конечному получателю, когда они соединены друг с другом. В противном случае пересылка может выполняться через одну (или более) промежуточную “почтовую станцию”.

SMTP-сервера могут вести диалог с несколькими оконечными пользователями. Любое почтовое сообщение завершается специальной последовательностью символов. Если получатель успешно завершил прием и обработку почтового сообщения, он посылает положительный отклик.

Протокол POP3 (Post Office Protocol version 3) позволяет рабочим станциям динамически забирать почту с сервера. Для небольших организаций невыгодно держать у себя систему для передачи сообщений (message transport system). Это связано с тем, что в небольших, не специализирующихся на компьютерных технологиях организациях, как правило, рабочие станции клиентов сети не имеют достаточно ресурсов (производительности или дискового пространства) для обеспечения работы полного SMTP-сервера. Кроме того, таким пользователям электронной почты может быть просто невыгодно держать персональный компьютер постоянно подключенным к Internet.

РОР3 позволяет только забрать почту из почтового ящика сервера на рабочую станцию клиента и удалить ее из почтового ящика на сервере. Всю дальнейшую обработку почтовое сообщение проходит на компьютере клиента. РОР3-сервер не отвечает за отправку почты, он работает только как универсальный почтовый ящик для группы пользователей. Когда пользователю необходимо отправить сообщение, он должен установить соединение с каким-либо SMTP-сервером и отправить туда свое сообщение по SMTP. Этот SMTP-сервер может быть тем же хостом, где работает РОР3 -сервер, а может располагаться совсем в другом месте.

Протокол Х.400 – общий стандарт, для управления и обработкой сообщениями. Система обработки сообщений Х.400 построена в соответствии с принципами эталонной модели взаимосвязи открытых систем. СОС может быть построена с использованием любой сети, относящейся к области распространения взаимосвязи открытых систем. Назначение системы обработки сообщений состоит в том, чтобы дать возможность пользователям обмениваться сообщениями на основе их промежуточного накопления.

Сообщение, предоставленное одним отправителем, передаётся через систему передачи сообщений и доставляется одному или нескольким другим получателям. Модель этого приведена на рисунке 1.

Рисунок 1 -

Модель системы передачи сообщений

Протокол IMAP4 (Internet Message Access Protocol, Version 4rev1) обеспечивает клиентам доступ и возможность манипуляций с почтовыми сообщениями на сервере. IMAP4 поддерживает операции с удаленными папками сообщений, называемыми почтовыми ящиками (mailbox) как при работе с локальными почтовыми ящиками. Протокол IMAP4 обеспечивает также поддержку offline-клиентов для ресинхронизации с сервером.

IMAP4 включает операции создания, удаления и переименования почтовых ящиков, просмотра новых сообщений, удаления сообщений навсегда, установки и снятия флагов, грамматического разбора (parsing), поиска и выборки атрибутов сообщений, текстов и их частей. Сообщения в IMAP4 допускают использование номеров, являющихся порядковыми номерами или уникальными идентификаторами сообщений.


Применение брандмауэров

Брандмауэр представляет собой барьер между двумя сетями - в большинстве случаев между внутренней сетью, часто называемой защищенной (trusted network), и внешней, незащищенной сетью (untrusted network), в данном случае Internet. В брандмауэре входящие и исходящие пакеты проверяются на соответствие комплексу правил, определенных администратором, а затем в зависимости от результатов проверки они либо пересылаются по назначению, либо блокируются.

В большинстве современных брандмауэров используется один или более из трех способов проверки пакетов. Во многих маршрутизаторах применяется распространенный в брандмауэрах метод, называемый фильтрацией пакетов, который основан на анализе адресов источника и приемника, а также портов входящих TCP- и UDP-пакетов; решение о пересылке или блокировании сообщений принимается на основе набора заранее определенных правил. Фильтры пакетов довольно дешевы, прозрачны для пользователей, а их влияние на пропускную способность сети пренебрежимо мало. Однако настройка конфигурации пакетных фильтров представляет собой относительно сложную процедуру. Еще одна проблема, связанная с фильтрами пакетов, это их уязвимость для IP-спуфинга (IP spoofing), приема, применяемого хакерами для получения доступа к корпоративным сетям путем замены адресов IP (Internet Protocol) в заголовках пакетов на допустимые.

Более совершенный и надежный тип брандмауэра - шлюз прикладного уровня. В большинстве таких систем, в том числе в популярном семействе продуктов Eagle фирмы Raptor и изделии Gauntlet компании Trusted Information Systems, используются программы-посредники (proxies) прикладного уровня, называемые агентами. Эти программы, составленные для конкретных служб Internet, таких, как HTTP, FTP и telnet, работают на сервере с двумя сетевыми соединениями и выполняют роль сервера для клиента и роль клиента для сервера приложений.

Поскольку программы-посредники прикладного уровня служат для проверки сетевых пакетов на наличие достоверных данных, специфических для конкретной программы, они считаются в целом более надежным средством защиты, нежели фильтры пакетов. В большинстве брандмауэров - шлюзов прикладного уровня имеется функция, получившая название трансляции сетевых адресов (network address translation), которая скрывает внутренние IP-адреса от пользователей, находящихся за пределами защищенной сети.

Один из основных недостатков шлюзов прикладного уровня - снижение уровня производительности из-за повторной обработки в программе-посреднике. Второй недостаток заключается в том, что, возможно, придется в течение нескольких месяцев ждать от поставщика брандмауэра выпуска программы-посредника прикладного уровня для новой службы Internet, такой, как RealAudio. Но, как правило, возможности внешнего канала связи с узкой полосой пропускания будут исчерпаны прежде, чем ресурсы брандмауэра.

При использовании программ-посредников прикладного уровня внутри учреждения, то следует обратить внимание на быстродействующие аппаратные решения, например PIX Firewall фирмы Cisco или Seattle Software компании Firebox. В качестве альтернативы можно рассмотреть возможность инсталляции программы-брандмауэра на многопроцессорной системе.

Третий тип технологии брандмауэров, названный компанией Check Point Software Technologies комбинированным (stateful inspection), реализован в пакетах Firewall-1 компании Check Point, PIX Firewall фирмы Cisco, ON Guard фирмы ON Technology и Firewall/Plus фирмы Network-1. Как и при использовании метода фильтрации пакетов, сначала происходит перехват пакетов на сетевом уровне, однако затем пакеты анализируются целиком, их содержимое сравнивается с известными последовательностями битов (состояниями) проверенных пакетов. Комбинированный метод, как правило, имеет немного более высокую производительность, чем у программ - посредников прикладного уровня, однако вопрос о том, обеспечивает ли он такую же степень безопасности или чуть менее надежен, остается открытым.

Крупные поставщики брандмауэров применяют в своих продуктах дополнительные методы защиты информации и заключают партнерские соглашения с другими поставщиками средств защиты, с тем чтобы предложить потребителям исчерпывающее решение проблемы безопасности в Internet. Большинство таких функциональных средств обсуждается ниже. Среди них шифрование данных, аутентификация, защита от вирусов и плохо отлаженных апплет Java и ActiveX, загружаемых из сети, и даже равномерное распределение нагрузки между серверами. Если вы только приступаете к делу, то обратите внимание, какой подход к построению надежной системы защиты информации избран вашим поставщиком.


Применение браузеров

Браузер, обозреватель, навигатор (от английского browser - человек, перелистывающий книги) - программа для просмотра визуализации объектов, например, веб страниц. За более чем 15 лет со дня появления первого браузера - эти программы стали, пожалуй, наиболее востребованными и значимыми для всех пользователей интернета, превратившись из неказистых, способных отображать только текст приложений в удобные и функциональные программы, открывающие нам красочный, наполненный бесценной информацией виртуальный мир Всемирной сети.

Обычное применение браузера - просмотр содержимого документов HTML, расположенных в каталогах серверов Web. Однако браузер способен передавать файлы и в обратном направлении - с локального диска посетителя на сервер.

Возможность передачи файлов на Web-сервер предусмотрена протоколом RFC1867 с названием Form-based file Upload in HTML (типовой файл на HTML для переписи на Web-сервер).

Потребность в браузерах возникла практически сразу после рождения Всемирной сети: без специализированного инструментария трудно выудить из недр интернета необходимую информацию. Конечно, это всего лишь компьютерные программы, созданные человеком с использованием одного из языков программирования.

Первые браузеры обладали вполне достаточной функциональностью. Благодаря тому, что многие сетевые протоколы появились задолго до рождения собственно интернета, браузеры получили возможность использовать их для получения и передачи данных. Вы могли просматривать локальные и удалённые файлы, обмениваться данными по протоколу FTP, осуществлять поиск страниц по ключевому слову и даже читать интернет-новости, размещённые на соответствующих серверах. Естественно, уже тогда появились и гиперссылки, позволяющие переходить с одной страницы на другую не занимаясь утомительным вводом прямого адреса.

На сегодняшний день существует большое количество браузеров, написанных практически для любых платформ (операционных систем). Их популярность представлена в таблице 1. Для выбора браузера главными критериями могут служить удобство использования и функциональность (таблица 2).

Таблица 1 – Популярность различных версий браузеров на конец 2004 года

Таблица 2 – Сравнительные тесты наиболее популярных браузеров для Windows

Прим.: конфигурация: 800 MHz Intel Pentium III, 256 Mb RAM.

Использование различных типов браузеров является головной болью для web-мастеров. Если писать web-интерфейс только под один из браузеров, то нет гарантии, что на других программах-обозревателях страница будет отображаться так как была задумана. Различия отображения страницы могут быть столь разительными (сдвиги таблиц, неправильное выравнивание, страница просто может не загрузиться), что посетитель сразу уйдет со страницы.


Применение коммутаторов

Ключевой проблемой проектирования и эксплуатации локальных сетей является распределение пропускной способности кабеля между всеми станциями, подключенными к сети. Например, в сети 10BASE-T при подключении 100 рабочих станций каждая из них получает возможность передавать данные в среднем со скоростью:

Иначе говоря, пропускная способность канала для одной станции в такой сети составляет 100 Кбит/с. С развитием мультимедийных приложений, позволяющих передавать звук, видео и статические изображения высокого качества, значительно возросли требования к параметрам локальных сетей.

Коммутаторы – устройства канального и физического уровня.

Схема соединения двух сегментов локальной сети Ethernet с помощью коммутирующего концентратора показана на рисунке 1.

а) б)

Рисунок 1 -

Логическая структура коммутатора

а – одновременная передача по двум каналам

б – широковещательная рассылка

Обратите внимание, что подключение двух файловых серверов (Data) к отдельным портам коммутатора позволяет одновременно устанавливать два канала связи между рабочими станциями и файловыми серверами, что увеличивает максимальную скорость передачи данных в стандартной сети 100BASE-T Ethernet вдвое.

Другими словами в коммутаторе выполняется функция трансляции сигнала конкретному порту назначения (виртуальный канал или коммутируемая линия), а при наличии более одной коммутируемой линии – организовывать несколько одновременных сеансов обмена.

Ключевым звеном коммутатора является архитектура без блокирования (non-blocking), которая позволяет установить множественные связи Ethernet между разными парами портов одновременно, причем кадры не теряются в процессе коммутации.

При этом параллельный трафик между взаимодействующими сетевыми устройствами остается локализованными. Локализация осуществляется с помощью адресных таблиц, устанавливающих связь каждого порта с адресами сетевых устройств, относящихся к сегменту этого порта. Таблица заполняется в процессе анализа коммутатором адресов станций отправителей в передаваемых ими кадрах.

Кадр передается через коммутатор локально в соответствующий порт только тогда, когда адрес станции назначения, указанный в поле кадра, уже содержится в адресной таблице этого порта. В случае отсутствия в таблице адреса станции назначения, кадр рассылается во все остальные сегменты. Если коммутатор обнаруживает, что MAC-адрес станции назначения приходящего кадра находится в таблице MAC-адресов, приписанной за портом, то этот кадр сбрасывается – его получит станция назначения, находящаяся в исходном сегменте.

Если приходящий кадр является широковещательным (broadcast), то есть если все биты поля MAC-адреса получателя в кадре задаются равными 1, то такой кадр будет размножен коммутатором (подобно концентратору), т.е. направляются во все остальные порты.

Рисунок 2 -

Примеры коммутаторов

Максимальное количество коммутируемых линий в коммутаторе можно рассчитать по формуле: m = div (n/2), где m – число коммутируемых линий, а n – число портов коммутатора.

Именно технология коммутации позволила увеличить скорость передачи данных в сетях до стабильного значения в 10 Гбит/с.


Применение концентраторов

Концентратор (hub, mau) - это также многопортовый повторитель, с функцией автосегментации.

Концентраторы можно использовать как автономные устройства. Но, в отличие от повторителей их можно каскадировать, т.е. соединять друг с другом, увеличивая тем самым размер сети и создавая сложные топологии.

Недостатком такой технологии является то, что трафик получаемой системы будет общим, т.е. увеличивается вероятность возникновения ошибок. Ограничение на число подключенных узлов может распространяться на всю объединенную систему.

Все порты концентратора равноправны. Получив сигнал от одной из подключенных к нему станций, концентратор транслирует его на все свои активные порты. При этом, если на каком-либо из портов обнаружена неисправность, то этот порт автоматически отключается (сегментируется), а после ее устранения снова делается активным.

Автосегментация необходима для повышения надежности сети. Обработка ошибок и текущий контроль состояния каналов связи обычно осуществляется самим концентратором.

Концентраторы могут быть активными и пассивными, то есть без функции восстановления формы сигнала.

Простейшие концентраторы представляют собой единую точку подключения к сети, позволяющую физически реализовать в виде звезды логическую шинную сеть Ethernet или маркерное кольцо. Такие концентраторы также называются неуправляемыми и предназначены они для очень маленьких сетей, содержащих до 12 узлов.

Концентраторы применяются в сетевых топологиях «звезда», «звезда-шина», «звезда-кольцо». В зависимости от конкретной топологии внутренняя логическая начинка, а значит и механизм работы устройства будут разными (рисунок 1).

Рисунок 1 -

Примеры внутренней структуры концентраторов

Концентраторы топологии «звезда-шина», применяемые в Ethernet (HUB) работают по принципу «один ко многим», то есть:

· являются центральным устройством, через которое соединяется множество узлов сети
· позволяют большое количество компьютеров соединять в одну или несколько локальных сетей
· обеспечивают связь различных протоколов (например, преобразование протокола Ethernet в протокол FDDI и обратно)
· соединяют вместе сегменты сетевой магистрали
· обеспечивают соединение между различными типами передающей среды
· позволяют централизовать сетевое управление и структуру.

Модель, применяемая в топологии «звезда-кольцо» имеет внутреннюю логическую организацию – кольцо, которую можно сравнить с эстафетой. Т.е. информация передвигается последовательно от одного порта к другому по кольцу. Принцип используется в сети Token Ring, концентратор называется модуль множественного доступа (multistation access unit, MAU), также встречается термин интеллектуальный модуль множественного доступа (smart multistation access unit, SMAU), последний применяется если модуль обладает возможностью находить неисправности в соединениях с рабочими станциями и изолировать неисправные станции от всей сети.

Модуль MAU также может выполнять функции пассивного или активного концентратора. Активный концентратор работает как повторитель, что более чем в два раза увеличивает количество поддерживаемых узлов.

В иерархических схемах допускается применение сложных и гибридных устройств (на уровнях объединения сегмента), что расширяет число функций сети.

Например, усовершенствование технологии модулей MAU позволило создать новые типы устройств – блок управления доступом (Controlled Access Unit, CAU), который позволяет несколько соединенных между собой наращиваемых блоков рассматривать как единый модуль MAU сети с маркерным кольцом. Блоки CAU также имеют возможность сбора информации, необходимой для управления производительностью сети.

Большинство концентраторов были выпущены для сетей со скоростью обмена 10 Мбит/с (HUB Ethernet), 20 Мбит/с (MAU TokenRing). Сейчас практически полностью исчезли с рынка.


Применение маршрутизаторов

Маршрутизатор (router) – устройство, предназначенное для определения и назначения наиболее оптимального маршрута продвижения пакетов при их перемещении по сети с несколькими вариантами маршрутов доставки.

Маршрутизатор выполняет некоторые функции моста, такие как анализ топологии, фильтрация и пересылка пакетов. Однако, в отличие от мостов, маршрутизаторы могут направлять пакеты в конкретные сети, анализировать сетевой трафик и быстро адаптироваться к изменениям сети.

Маршрутизатор использует функции сетевого уровня модели OSI, что позволяет им анализировать в пакетах больше информации, чем это возможно для мостов. Его структуру отражает рисунок 1.

Маршрутизаторы подразделяются на два основных типа:

· статические (static), здесь необходимо, чтобы администратор вручную создал и сконфигурировал таблицу маршрутизации, а также указал каждый маршрут для передачи данных через сеть
· динамические (dynamic) – автоматически определяют маршруты и поэтому требуют минимальной настройки. Они сложнее статических, так как анализируют информацию от других маршрутизаторов и для каждого пакета принимают отдельное решение о маршруте передачи данных через сеть.

Рисунок 1 -

Функциональная схема блоков маршрутизатора

Процедура маршрута состоит в оценке и сравнении между собой нескольких вариантов, вычисленных согласно «метрикам» маршрутизации, значения которых хранятся в таблицах маршрутизации. Таблицы маршрутизации этих устройств намного сложнее, чем таблицы маршрутизации мостов.

Метрика маршрутизации – это свойство каналов связи, согласно которому в числовом эквиваленте определяется оптимальность данного маршрута в текущий момент времени. К примерам таких метрик можно отнести: цена аренды канала связи за единицу времени, скорость пропускания канала связи, длина сегмента, число заявок в единицу времени, длина очереди на обслуживание в текущий момент времени ...

Часть характеристик может быть статическими, а некоторые изменяются и требуют обновления. Обновление осуществляется также как у мостов – широковещательными пакетами, что отрицательно сказывается на сетевом трафике.

Положительный момент в применении маршрутизаторов – локализация трафиков, т.е. в соседней части сети будут транслироваться только те пакеты, которые не могут быть обслужены в пределах данного сегмента сети.

Отрицательным моментом является возможность попадания пакета в «адресную петлю». Например, в сети есть 6 узлов маршрутизации (рисунок 2). Необходимо доставить пакет от первого к шестому.

Рисунок 2 -

Пример передачи пакетов с помощью маршрутизаторов между компьютерами, принадлежащими к разным сетям

В этой сети 2 маршрута продвижения: «1–3–4–6» и «1–2–5–4–6».

При оценке маршрутизатором один может быть оптимальным, маршрутизатором выбран первый путь. Пакет отправляется маршрутизатору 3, а на маршруте три может сложиться ситуация когда оптимальным маршрутом доставки пакета шестому маршрутизатору будет выбран маршрут «3–1–2–5–4–6». Таким образом, пакет возвращается на первый маршрутизатор и может блуждать по кольцу, пока не истечет время его жизни (актуальности).


Применение модемов

Модем (модулятор-демодулятор) служит для передачи информации на большие расстояния, недоступные локальным сетям. Модемы используют выделенные и коммутируемые телефонные линии.

Ранние модели модемов передавали данные асинхронно, работая на скоростях до 18000 бит/с с FSK (frequency shift keying - манипуляция сдвигом частоты) - модуляцией, используя две частоты для передачи и две для приёма. Асинхронная передача не сопровождается сигналами таймера, и модемы ориентируются на номинальную скорость передачи. Для предотвращения потерь данных они группируются в очень короткие блоки (символы) с ограничительными битами (старт и стоп биты). Наиболее распространённая система для этого - ASCII кодировка с контролем по чётности. Синхронные модемы требуют две выделенные пары проводов для синхронизации и данных и требуют установки в слот системной шины специального контроллера.

Синхронные модемы работают на скоростях до 56Кбит/с на аналоговых линиях. Данные при синхронной передаче сопровождаются сигналами таймера и почти всегда сгруппированы в блоки. Передающее устройство собирает данные в блоки и сопровождает их дополнительными кодами, необходимыми для обнаружения и/или коррекции ошибок в соответствии с одним из протоколов (BISYNC, SDLC, HDLC и т.д.). Источник и приёмник данных полагают, что модем прозрачен для этих типов данных, соответственно модем может игнорировать группирование данных. Обычными методами модуляции являются фазовая модуляция и интегрированная фаза с амплитудой.

Применение модема зависит от числа функций, которые реализованы в нем аппаратно, либо с помощью ПО (софт-модемы).

Факс-модемы позволяют передавать и принимать факсимильные изображения, совместимы с обычными факс-машинами.

Голосовые модемы (Voice Modem) преобразуют звуковое сообщение в файл данных, аудиосигнал сжимается по методу ADPCM (Adaptive Differential Pulse Code Modulation). Сообщение может передаваться по электронной почте или в режиме реального времени. Звук воспроизводится через внутренний динамик самого модема или через мультимедийные средства компьютера.

DSL-модемы (Digital Subscriber Line - цифровая линия подписки), разработаны телефонными компаниями для предоставления услуг кабельного телевидения. Популярность завоевал асимметричный подвид стандарта – ADSL.

ADSL-модем передаёт данные одновременно с голосом, используя обычную пару медных телефонных проводов. Для этого создаются три раздельных частотных канала. Первый набор частот передаёт обычный телефонный сигнал. Второй канал передаёт (upstream) данные на скорости от 64Кбит/с до 640Кбит/с, в зависимости от качества линии, расстояния и диаметра провода. Третий канал - высокоскоростной принимающий (downstream) канал, работающий на скоростях от 1,5Мбит/с до 6,3Мбит/с. Каждый канал работает только в одном направлении. Схема работы с ADSL-модемом приведена на рисунке 1.

Рисунок 1 -

Применение ADSL-модема

Скоростные параметры модемов можно определять по-разному:

· cps - скорость передачи символов, байт/с;
· bps - скорость передачи, бит/с;
· baud - количество изменений сигнала в линии за 1 секунду (этот параметр ограничен полосой пропускания линии).

Реальная скорость обмена данными зависит от различных обстоятельств. К их числу относят: скорость последовательного порта, типы модемов на передающей и принимающей стороне, а также состояние телефонной линии.

Для повышения эффективной скорости работы при ограниченной полосе линии применяют различные методы кодирования и модуляции, при которых bps превышает baud.

Конструктивно модемы для PC выпускаются в двух вариантах исполнения: внутренние - Internal и внешние – External (рисунок 2).

а) [image] б)

Рисунок 2 Внешний вид Internal (а) и External (б) модемов


Применение мостов

Мост (bridge) – это сетевое устройство, соединяющее между собой сегменты локальной сети или, в некоторых случаях, целые сети.

Мосты являются устройствами канального уровня и позволяют решать следующие задачи:

· расширить локальную сеть в случае, когда достигнут лимит на максимальное количество соединений (например, если сегмент Ethernet имеет 30 узлов)
· объединять две однородные сети через промежуточный канал другого типа связи (например, модемный мост между сегментами сети)
· расширить локальную сеть и обойти ограничения на длину сегментов (например, если нужно нарастить сегмент Ethernet на тонком кабеле, который уже имеет длину 185 м)
· сегментировать локальную сеть для ликвидации узких мест в сетевом трафике
· объединять две сети разных сетевых архитектур (например, сеть с топологией «кольцо» можно объединить с топологией «шина»)
· предотвратить неавторизованный доступ к сети

Часто мосты применяют для объединения более двух сетей одновременно.

Рисунок 1 -

Объединение сетей с помощью моста

Мосты функционируют в так называемом беспорядочном режиме (promiscuous mode), что подразумевает просмотр физического целевого адреса каждого фрейма перед его пересылкой. Этим мосты отличаются от повторителей, которые не имеют возможности анализа адресов фреймов. Мосты принято разделять на прозрачные и транслирующие.

Прозрачные мосты – это простые устройства. Они считывают исходный и целевой физические адреса фрейма. Мост перехватывает весь сетевой трафик и анализирует целевой адрес каждого фрейма, определяя, следует ли пересылать данный фрейм в следующую сеть. В процессе своей работы мост просматривает МАС-адреса передаваемых через него фреймов и строит таблицу известных целевых адресов (таблица маршрутизации).

Если мост знает, что фрейм предназначен для узла, который находится в том же сегменте, что и отправитель фрейма, он отбрасывает сегмент, поскольку тот не нуждается в дальнейшей пересылке. Если мост знает, что целевой адрес располагается в другом сегменте, он транслирует фрейм только в нужный сегмент. Если мосту не известен целевой сегмент, он передает фрейм во все сегменты, за исключением исходного сегмента, и этот процесс называется лавинной маршрутизацией (лавинной адресацией) (flooding). Главным достоинством мостов является то, что они сосредотачивают трафик в конкретных сетевых сегментах. Мост может выполнять фильтрацию и пересылку с довольно высокой скоростью, поскольку он просматривает информацию только на Канальном уровне и игнорирует информацию на более высоких уровнях.

Транслирующие мосты могут дополнительно преобразовывать фреймы, относящиеся к одному методу доступа и передающей среде, во фреймы другого стандарта (например, из стандарта Ethernet в стандарт Token Ring) и наоборот. Такой мост должен уметь изменять или добавлять: очередность битов в адресах; формат МАС-адреса; элементы маршрутной информации; функции, имеющиеся во фреймах Token Ring, не имеющие эквивалентов во фреймах Ethernet; зондирующие (explorer) пакеты Token Ring, которые не используются в сетях Ethernet.

К достоинству мостов относится то, что они могут использоваться еще и как брандмауэры (сетевые экраны), ограничивая доступ к сети.

Важно знать что, если в сети присутствует более одного моста, может возникнуть ситуация, когда они не смогут правильно опознать какой компьютер к какой из сети относится, т.к. механизм регистрации узлов сети в таблице маршрутизации не лишен некоторых недостатков.


Применение поисковых систем

Практика показывает, что в настоящий момент эффективно и правильно использовать поисковые системы умеют не более 3% пользователей. В основном люди слишком полагаются на отнюдь несовершенные возможности автоматики и в результате на запрос из 1-2 слов получают совершенно бесполезную для себя информацию.

Дело в том, что современные поисковые системы Интернет не обладают искусственным интеллектом. Все они построены на принципах 50-летней давности, заложенных австрийским ученым Ципфом.

Подавляющее большинство доступных пользователям поисковых систем умеют искать лишь по ключевым словам, которые вводят пользователи и ничего более.

Поисковые системы обычно состоят из трех компонент: агент (паук или кроулер), который перемещается по сети и собирает информацию; база данных, которая содержит всю информацию, собираемую пауками; поисковый механизм, используемый как интерфейс взаимодействия с базой данных.

Средства поиска типа агентов, пауков, кроулеров и роботов – специальные программы, занимающиеся поиском страниц в Сети, извлекают гипертекстовые ссылки на этих страницах и автоматически индексируют информацию, которую они находят для построения базы данных. Каждый имеет собственный набор правил, определяющих, как собирать документы (следуют за каждой ссылкой на каждой найденной странице; игнорируют ссылки, ведущие к графическим и звуковым файлам и т.д.).

Агенты – самые "интеллектуальные" из поисковых средств, они могут выполнять даже транзакции от Вашего имени, могут искать сайты специфической тематики и возвращать списки сайтов, отсортированных по их посещаемости и т.д.

Пауки сообщают о содержании найденного документа, индексируют его и извлекают итоговую информацию. Также просматривают заголовки, некоторые ссылки и посылают проиндексированную информацию базе данных поискового механизма.

Кроулеры просматривают заголовки и возвращают только первую ссылку.

Роботы могут быть запрограммированы так, чтобы переходить по ссылкам различной глубины вложенности, выполнять индексацию и даже проверять ссылки в документе.

База данных отыскивает предмет запроса, согласно информации, указанной в заполненной форме, и выводит соответствующие документы, подготовленные базой данных. Чтобы определить порядок, в котором список документов будет показан, база данных применяет алгоритм ранжирования. Например, время (как долго страница находится в базе поискового сервера) или индекс цитируемости (как много ссылок на данную страницу ведет с других страниц, зарегистрированных в базе поисковика.)

В идеале процесс поиска должен выглядеть примерно так. Сначала делается общий запрос. На запрос получается ответ с результатами поиска, в котором нужно выделить описания более-менее подходящих ссылок. Затем необходимо добавить к запросу общие ключевые слова, которые есть в описании нужных ссылок и повторить процесс.

Корректировка запроса осуществляется изменением состава и вариантов ключевых слов в виде простой текстовой строки, либо с использованием специального языка операторов, поддерживаемого поисковой машиной. Вот операторы, общие для поисковых систем:

Первый оператор, который нужно отметить - оператор строгого соответствия, как правило, в современных поисковых системах это кавычки "". Сочетание слов, которые вы укажете в кавычках, будет учитываться системой как единое целое, то есть таким образом вы задаете порядок следования слов друг за другом.

Следующие очень важные операторы - оператор обязательного наличия слова "+" и оператор обязательного отсутствия слова "-".

Достаточно часто бывает полезно, чтобы искомые ключевые слова присутствовали в пределах одного документа. Для этого необходимо использовать оператор логического И AND. Однако, во всех поисковых системах это же можно сделать, поставив обычный пробел. К примеру, запросы «компьютерные журналы» и «компьютерные AND журналы», как правило, дадут один и тот же результат. Оператор логического ИЛИ, в качестве которого используется логический оператор OR позволяет найти хотя бы одно слово из запроса. Например, с помощью запроса «компьютерные OR журналы» можно найти документы, в которых встречается слово «компьютерные» или слово «журналы».

Вообще с языками запросов конкретной поисковой системы можно всегда ознакомиться в ее разделе помощи. При этом нужно отметить, что многие из них обладают собственными дополнительными операторами, которые могут помочь опытным пользователям.


Применение репитеров

Повторитель (репитер, repeater) соединяет два или несколько кабельных сегментов и ретранслирует любой входящий сигнал на все другие сегменты.

Сегмент кабеля – это один отрезок кабеля, удовлетворяющий спецификациям IEEE (например, отрезок кабеля 10Base2 длиной 185 м, к которому подключено не более 30 узлов, включая терминаторы и сетевое оборудование).

Основная функция повторителей – восстановление формы сигнала, транслируемого по сети до исходных параметров, как правило, восстанавливается амплитуда сигнала и форма фронтов.

Рисунок 1 -

Обработка сигналов повторителем

Повторитель – устройство физического уровня. Чаще всего упоминаемое при описании топологии «шина», но и другие топологии применяют схожие устройства. При этом стоит сказать, для каждой кабельной системы разрабатывается свой тип повторителя.

Повторители позволяют соединять пользователей, находящихся в удаленных концах здания – на расстояниях, не отвечающих требованиям; IEEE на длину отдельного кабельного сегмента. Повторитель может выполнят следующие функции Физического уровня:

· фильтровать искажения сигнала или шум, вызванный радио или электромагнитными помехами
· усиливать входящий сигнал и восстанавливать его форму для более точной передачи
· синхронизировать сигнал (в сетях Ethernet)
· воспроизводить сигнал на всех кабельных сегментах.

Синхронизация позволяет избегать конфликтов сигналов в сети Ethernet, когда сигнал передается в кабель. Повторители позволяют выполнить следующие задачи:

· удлинить кабельную систему (например, на расстояние более 185 м для сегмента 10Base2 и свыше 500 м - для 10Base5)
· увеличить количество подключенных узлов и обойти ограничения, налагаемые на отдельный сегмент (например, подключить свыше 30 узлов в сети Ethernet)
· распознать сетевую ошибку и отключить сегмент кабеля
· подключиться к компонентам в других сетевых устройствах, таких как концентраторы и коммутаторы, а также усилить и синхронизировать сигналы
· соединить сегменты, работающие с разной передающей средой (например, коаксиальный кабель, витая пара и оптоволокно)
· удлинить сегменты магистрального кабеля в локальных и глобальных сетях
· удлинить сегменты оптоволоконного кабеля
· увеличить рабочее расстояние для Т-линий.

Если повторитель ретранслирует сигнал в два и более кабельных сегмента, он называется многопортовым повторителем. Например, повторитель может иметь порты для 2 - 8 дополнительных сегментов. Такой повторитель сети 10Base2 может передавать сигнал в несколько кабелей длиной 185 м. Каждый кабель может иметь до 29 подключенных узлов, включая терминаторы на своих концах.

В случае ошибки повторитель перестает передавать данные в неисправный сегмент. Такой способ отключения сегмента называется изолированием, или секционированием (partitioning).

Рисунок 1 -

Восьмипортовй Ethernet Repeater 10base2

Функции повторителя являются настолько необходимыми, что они включаются в состав любого вида активного оборудования сети.

По своей сути многопортовый повторитель практически уже мало чем отличается от концентратора.


Применение сетевых адаптеров

Сетевой адаптер или сетевая карта (netcard) - это интерфейсная карта ввода-вывода информации, которая обеспечивает преобразование информационных сигналов, поступающих от системной шины компьютера в форму, пригодную для ретрансляции в соответствующей среде передачи (рисунок 1). Внутреннее строение сетевого адаптера и его физические интерфейсы зависят от типа топологии, среды передачи и сетевого стандарта, для работы с которыми предназначен данный сетевой адаптер.

Рисунок 1 -

Схема преобразования данных в сетевом адаптере Ethernet на физическом уровне

Современные мини - и суперминикомпьютеры, а также большие ЭВМ (Mainframes), все еще могут иметь встроенные адаптеры с AUI-разъемами. Ряд современных системных плат персональных компьютеров тяготеет ко встроенным адаптерам с разъемом RJ-45.

Сетевые адаптеры или сетевые интерфейсные карты (Network Interface Card, NIC) для PC, выпускаемые многими производителями в широком ассортименте, различаются поддерживаемыми средами передачи, типом системной шины (ISA, EISA, MCA, PCI, реже VLB), архитектурой и производительностью. Для мобильных ПК существуют адаптеры Ethernet в стандарте PCMCIA (PC CARD). Выпускаются также адаптеры, подключаемые к стандартному LPT-порту PC ("Paraport"), их главное преимущество - отсутствие потребностей в системных ресурсах (порты, прерывания и т. п.) и легкость подключения без вскрытия компьютеров - оборачивается и существенным недостатком - при обмене они очень сильно загружают процессор.

На текущий момент широко распространены сетевые карты с интерфейсом 100Base-TX на шину PCI. Выпускаются также сетевые карты с оптическим интерфейсом. Например, 100Base-FX – с основным оптическим разъемом SC на многомодовое волокно.

а)

б)

Рисунок 2 -

Внешний вид сетевого адаптера

а) сетевой адаптер 100Base-TX

б) сетевые адаптеры 100Base-FX

Каждый адаптер имеет свой уникальный 6-байтный физический адрес (MAC-Address), зашитый в одну из микросхем. Области адресов поделены между фирмами-производителями. Некоторые адаптеры и драйверы позволяют изменять адрес, при этом ответственность за его уникальность в сети перекладывается на администратора.

Настройка сетевого адаптера заключается в первую очередь в настройке ОС, которая может быть успешно осуществлена только при условии отсутствия конфликтов по оборудованию между сетевым адаптером и любым другим устройством системы.

Конфликт может быть по прерыванию, по диапазону адресов ввода-вывода, а в некоторых случаях по каналу DMA. Учитывая все это, производители перевели все современные модели сетевых адаптеров в режим PnP.

Этапы настройки сетевого адаптера можно изложить в следующей последовательности:

1 Физически установить устройство в слот расширения (порт).
2 Протестировать систему на возможные конфликты по параметрам с уже установленным оборудованием.
3 Установить драйвера для сетевого устройства в состав операционной системы
4 Установить программы обслуживающие сетевой обмен.
5 Протестировать систему на корректность работы оборудования.

Необязательными, но крайне желательными, функциями современных сетевых карт являются автоконфигурирование 10/100/1000 Мбит/с и поддержка дуплексного режима.


Применение сетевых операционных систем

Однако и "дружественный" интерфейс, и сетевые функции появились у операционных систем персональных компьютеров не сразу. Первая версия наиболее популярной операционной системы раннего этапа развития персональных компьютеров — MS-DOS компании Microsoft — не предоставляла таких возможностей. Недостающие функции для MS-DOS и подобных ей ОС компенсировались внешними программами, предоставлявшими пользователю удобный графический интерфейс (например, Norton Commander) или средства тонкого управления дисками (например, PC Tools). Наибольшее влияние на развитие программного обеспечения для персональных компьютеров оказала операционная среда Windows компании Microsoft, представлявшая собой надстройку над MS-DOS.

Вместе с версией MS-DOS 3.1 в 1984 году компания Microsoft выпустила продукт Microsoft Networks, который обычно называют MS-NET. Некоторые концепции, заложенные в MS-NET, такие как введение в структуру базовых сетевых компонентов — редиректора и сетевого сервера, успешно перешли в более поздние сетевые продукты Microsoft: LAN Manager, Windows for Workgroups, а затем и в Windows NT.

Иной путь выбрали разработчики Novell. Они изначально сделали ставку на создание операционной системы со встроенными сетевыми функциями и добились на этом пути больших успехов. Сетевые операционные системы NetWare производства Novell на долгое время стали эталоном производительности, надежности и защищенности для локальных сетей.

В 1987 г. в результате совместных усилий Microsoft и IBM появилась первая многозадачная операционная система для персональных компьютеров с процессором Intel 80286, в полной мере использующая возможности защищенного режима — OS/2.

Сетевые разработки компаний Microsoft и IBM привели к появлению NetBIOS — очень популярного транспортного протокола и одновременно интерфейса прикладного программирования для локальных сетей, нашедшего применение практически во всех сетевых операционных системах для персональных компьютеров. Этот протокол и сегодня применяется для создания небольших локальных сетей.

Не очень удачная судьба OS/2 не позволила системам LAN Manager и LAN Server захватить заметную долю рынка, но принципы работы этих сетевых систем во многом нашли отражение в более успешной Microsoft Windows NT, содержащей встроенные сетевые компоненты (некоторые из них имеют приставку LM — от LAN Manager).

На персональные компьютеры устанавливались специально для них разработанные операционные системы, подобные MS-DOS, NetWare и OS/2, а также адаптировались существующие ОС. Появление процессоров Intel 80286 и особенно 80386 с поддержкой мультипрограммирования позволило перенести на платформу персональных компьютеров ОС Unix. Наиболее известной системой этого типа была версия Unix компании Santa Cruz Operation (SCO Unix).

В 90-е годы практически все операционные системы, занимающие заметное место на рынке, стали сетевыми. Сетевые функции сегодня встраиваются в ядро ОС и являются его неотъемлемой частью. Операционные системы получили средства для работы со всеми основными технологиями локальных (Ethernet, Fast Ethernet, Gigabit Ethernet, Token Ring, FDDI, ATM) и глобальных (X.25, frame relay, ISDN, ATM) сетей, а также средства для создания составных сетей (IP, IPX, AppleTalk, RIP, OSPF, NLSP). В операционных системах используются средства мультиплексирования нескольких стеков протоколов, что позволяет компьютерам поддерживать сетевую работу с разнородными клиентами и серверами. Появились специализированные ОС, предназначенные исключительно для выполнения коммуникационных задач. Например, сетевая операционная система IOS компании Cisco Systems, работающая в маршрутизаторах, организует в мультипрограммном режиме выполнение набора программ, каждая из которых реализует один из коммуникационных протоколов.

Во второй половине 90-х годов все производители операционных систем резко усилили поддержку средств работы с Internet (кроме производителей Unix-систем, в которых эта поддержка всегда была существенной). Кроме самого стека TCP/IP в комплект поставки начали включать утилиты, реализующие такие популярные сервисы Internet как telnet, ftp, DNS и Web. Влияние Internet проявилось и в том, что компьютер превратился из вычислительного устройства в средство коммуникаций с развитыми вычислительными возможностями.

На современном этапе развития операционных систем на передний план вышли средства обеспечения безопасности. Это обусловлено возросшей ценностью информации, обрабатываемой компьютерами, а также повышенным уровнем риска, связанного с передачей данных по сетям, особенно по общедоступным, таким как Internet. Многие операционные системы обладают сегодня развитыми средствами защиты информации, основанными на шифровании данных, аутентификации и авторизации.

Современным операционным системам присуща многоплатформенность, то есть способность работать на компьютерах различного типа. Многие операционные системы имеют специальные версии для поддержки кластерных архитектур, обеспечивающих высокую производительность и отказоустойчивость. Исключение пока составляет ОС NetWare, все версии которой разработаны для платформы Intel, а реализация функций NetWare в виде оболочки для других ОС, например NetWare for AIX, успеха не имела.

В последние годы получила дальнейшее развитие тенденция повышения удобства работы с компьютером. Эффективность работы пользователя становится основным фактором, определяющим эффективность вычислительной системы в целом. Усилия человека не должны тратиться на настройку параметров вычислительного процесса, как это происходило в ОС предыдущих поколений. Например, в системах пакетной обработки для мэйнфреймов каждый пользователь должен был с помощью языка управления заданиями определить большое количество параметров, относящихся к организации вычислительных процессов в компьютере. Так, для системы OS/360 язык управления заданиями JCL предусматривал возможность определения пользователем более 40 параметров, среди которых были приоритет задания, требования к основной памяти, предельное время выполнения задания, перечень используемых устройств ввода-вывода и режимы их работы.

Современная операционная система берет на себя выбор параметров операционной среды, с помощью различных адаптивных алгоритмов. Например, тайм-ауты в коммуникационных протоколах часто определяются в зависимости от условий работы сети. Распределение оперативной памяти между процессами осуществляется автоматически с помощью механизмов виртуальной памяти в зависимости от активности этих процессов и информации о частоте использования ими той или иной страницы. Мгновенные приоритеты процессов определяются динамически в зависимости от предыстории, включающей, например, время нахождения процесса в очереди, процент использования выделенного кванта времени, интенсивность ввода-вывода и т. п. Даже в процессе установки большинство ОС предлагают режим выбора параметров по умолчанию, который гарантирует пусть не оптимальное, но всегда приемлемое качество работы систем.

Постоянно повышается удобство интерактивной работы с компьютером путем включения в операционную систему развитых графических интерфейсов, использующих наряду с графикой звук и видео. Это особенно важно для превращения компьютера в терминал новой общедоступной сети, которой постепенно становится Internet, так как для массового пользователя терминал должен быть по простоте использования подобен телефонному аппарату. Пользовательский интерфейс операционной системы становится все более интеллектуальным, он направляет действия человека в типовых ситуациях и выполняет многие задачи автоматически.

Уровень удобства в работе с ресурсами, которые сегодня предоставляют пользователям, администраторам и разработчикам приложений операционные системы изолированных компьютеров, для сетевых операционных систем является только заманчивой перспективой. Пока же пользователи и администраторы сети тратят значительное время на попытки выяснить, где находится тот или иной ресурс, а разработчики сетевых приложений прилагают много усилий для определения местоположения данных и программных модулей в сети. Операционные системы будущего должны обеспечить высокий уровень прозрачности сетевых ресурсов, взяв на себя задачу организации распределенных вычислений, превратив сеть в виртуальный компьютер. Именно такой смысл вкладывают в лаконичный лозунг "Сеть — это компьютер" специалисты компании Sun, но чтобы претворить лозунг в жизнь, разработчикам операционных систем предстоит пройти еще долгий путь.

Хронологическая последовательность важнейших событий в истории развития компьютерных сетей

Первые ламповые компьютеры

Начало 40-х

Первые компьютеры на полупроводниковых схемах (транзисторах)

Середина 50-х

Первые компьютеры на интегральных схемах. Первые мультипрограммные ОС

Середина 60-х

Первые глобальные связи компьютеров

Конец 60-х

Начало передач по телефонным сетям голоса в цифровой форме

Конец 60-х

Появление больших интегральных схем. Первые мини-компьютеры

Начало 70-х

Первые нестандартные локальные сети

Начало 70-х

Создание сетевой архитектуры IBM SNA

1974

Создание технологии Х.25

1974

Появление персональных компьютеров

Начало 80-х

Создание Internet в современном виде. Установка на всех узлах стека TCP/IP

Начало 80-х

Появление стандартных технологий локальных сетей

Ethernet – 1980

Token Ring – 1985

FDDI – 1989

Начало коммерческого использования Internet

Конец 80-х

Изобретение Web

1991

Рисунок 1 -

Взаимодействие программных компонентов при связи двух сетевых операционных систем

В идеале средства управления сетями (и в том числе сетевые операционные системы) представляют собой систему, осуществляющую наблюдение, контроль и управление каждым элементом сети — от простейших до самых сложных устройств, при этом такая система рассматривает сеть как единое целое, а не как разрозненный набор отдельных устройств. Модели сетевого управления рассматриваются в главе 12.


Применение шлюзов

Шлюз (gateway) обеспечивает связь между различными архитектурами и сетевыми средами.

Шлюзы распаковывают и преобразуют данные, передаваемые из одной среды в другую, чтобы каждая среда могла понимать сообщения других сред. В частности, шлюз изменяет формат данных, иначе прикладная программа на принимающей стороне не сможет их распознать. Например, шлюзы электронной почты (такие, как Х.400) принимают сообщение в одном формате, транслируют его и пересылают в формате Х.400, используемом получателем, и наоборот.

Шлюз связывает две системы, которые применяют разные:

· коммуникационные протоколы
· структуры и форматы данных
· языки
· архитектуры

Шлюзы связывают разные сети, например Microsoft Windows NT Server с SNA (Systems Network Architecture фирмы IВМ).

Шлюзы – это самые сложные устройства, они включают в себя функции прикладного уровня модели ISO и поэтому являются самыми медленными, зато позволяют реализовать любую обработку и преобразование передаваемой информации.

Например, обеспечение безопасности информации, шифрование данных на входе и выходе, антивирусная профилактика, объединение трафика нескольких пользователей «Proxy».

Некоторые шлюзы используют все семь уровней модели OSI, но обычно шлюзы выполняют преобразование протоколов только на Прикладном уровне.

Шлюзы создаются для выполнения определенного типа задач, то есть для конкретного типа преобразования данных. Часто их и называют в соответствии со специализацией (например, Windows NT Server To SNA Gateway).

Шлюз принимает данные из одной среды, удаляет старый протокольный стек и переупаковывает их в протокольный стек системы назначения.

Рисунок 2 -

Преобразование пакета данных шлюзом

Обрабатывая данные, шлюз выполняет следующие операции:

· извлекает данные из приходящих пакетов, пропуская их снизу вверх через полный стек протоколов передающей сети
· заново упаковывает полученные данные, пропуская их сверху вниз через стек протоколов сети назначения

Обычно в качестве шлюза используют выделенный сервер. Если шлюз используется для обеспечения возможности работы гетерогенной сети, то шлюз исполняет функцию переводчика и конвертора. Естественно для его работы необходимо ведение таблиц адресации и маршрутизации.

Самая актуальная задача, решаемая современными шлюзами – это защита информации, в частности, функция брандмауэра (сетевого экрана, межсетевого фильтра). Более подробное описание данной функции приведено в главе 11.

Еще одно назначение шлюзов – связывать локальную сеть персональных компьютеров и среду мэйнфреймов или мини-компьютеров, которые непосредственно взаимодействовать с персональными компьютерами в пределах однородной сети не могут.


Процессы и нити в распределенных системах

Нити делают возможным сохранение идеи последовательных процессов, которые выполняют блокирующие системные вызовы (например, RPC для обращения к диску), и в то же время позволяют достичь параллелизма вычислений. Блокирующие системные вызовы делают проще программирование, а параллелизм повышает производительность.

В традиционных ОС понятие нити тождественно понятию процесса. В действительности желательно иметь несколько нитей управления, разделяющих единое адресное пространство, но выполняющихся квазипараллельно.

Предположим, например, что файл-сервер блокируется, ожидания выполнения операции с диском. Если сервер имеет несколько нитей управления, вторая нить может выполняться, пока первая нить находится в состоянии ожидания. Это повышает пропускную способность и производительность. Эта цель не достигается путем создания двух независимых серверных процессов, потому что они должны разделять общий буфер кэша, который требуется им, чтобы быть в одном адресном пространстве.

Различные способы организации вычислительного процесса с использованием нитей:

1 Нить-диспетчер читает приходящие запросы на работу из почтового ящика системы. После проверки запроса диспетчер выбирает простаивающую (то есть блокированную) рабочую нить, передает ей запрос и активизирует ее, устанавливая, например, семафор, который она ожидает. (рисунок 1 а)

Когда рабочая нить активизируется, она проверяет, может ли быть выполнен запрос с данными разделяемого блока кэша, к которому имеют отношение все нити. Если нет, она посылает сообщение к диску, чтобы получить нужный блок (предположим, это READ), и переходит в состояние блокировки, ожидая завершения дисковой операции. В этот момент происходит обращение к планировщику, в результате работы которого активизируется другая нить, возможно, нить-диспетчер или некоторая рабочая нить, готовая к выполнению.

2 В модели "команда" все нити эквивалентны, каждая получает и обрабатывает свои собственные запросы. Иногда работы приходят, а нужная нить занята, особенно, если каждая нить специализируется на выполнении одного работ. В этом случае может создаваться очередь незавершенных работ. При такой организации нити должны вначале просматривать очередь работ, а затем почтовый ящик. (Рисунок 1 б)

3 Нити могут быть также организованы в виде конвейера. В этом случае первая нить порождает некоторые данные и передает их для обработки следующей нити и т.д. Хотя эта организация и не подходит для файл-сервера, для других задач, например, задач типа "производитель-потребитель", это хорошее решение. (Рисунок 1 в)

Нити полезны и для клиентов. Например, если клиент хочет растиражировать файл на много серверов, он может создать по одной нити для копирования на каждом сервере. Использование нитей может сократить необходимое количество прерываний пользовательского уровня.

Существует два подхода к управлению нитями: статический и динамический. При статическом подходе вопрос, сколько будет нитей, решается уже на стадии написания программы или на стадии компиляции. Каждой нити назначается фиксированный стек. Более общим является динамический подход, который позволяет создавать и удалять нити оперативно по ходу выполнения. Системный вызов для создания нити обычно содержится в нити главной программы в виде указателя на процедуру с указанием размера стека, а также других параметров, например, диспетчерского приоритета.

Завершаться нити могут одним из двух способов: по своей инициативе, когда завершается работа, и извне. Во многих случаях, например, при конвейерной модели, нити создаются сразу же после старта процесса и никогда не уничтожаются.

Рисунок 1 -

Три способа организации нитей

Обычно в распределенных системах используются как RPC-запросы, так и нити.


Проект IEEE 802.x*

Особый интерес для специалистов в области сетевых технологий представляют спецификации, составляющие проект IEEE 802. Его название отражает дату заседания комитета: число 80 означает год (1980), а 2 — месяц (февраль). Стандарты семейства IEEE 802.x охватывают только два нижних уровня модели OSI - физический и канальный. Это связано с тем, что именно эти уровни в наибольшей степени отражают специфику локальных сетей. Такая специфика нашла свое отражение в разделении канального уровня на два подуровня, которые часто называют также уровнями. Канальный уровень (Data Link Layer) делится в локальных сетях на два подуровня:

· логической передачи данных (Logical Link Control, LLC);
· управления доступом к среде (Media Access Control, MAC).

Уровень MAC появился из-за существования в локальных сетях разделяемой среды передачи данных. Именно этот уровень обеспечивает корректное совместное использование общей среды, предоставляя ее в соответствии с определенным алгоритмом в распоряжение той или иной станции сети.

После того как доступ к среде получен, ею может пользоваться более высокий уровень - уровень LLC. Этот уровень отвечает за передачу кадров данных между узлами с различной степенью надежности, а также реализует функции интерфейса с прилегающим к нему сетевым уровнем. Именно через уровень LLC сетевой протокол запрашивает у канального уровня нужную ему транспортную операцию с нужным качеством. На уровне LLC существует несколько режимов работы, отличающихся наличием или отсутствием на этом уровне процедур восстановления кадров в случае их потери или искажения, то есть отличающихся качеством транспортных услуг этого уровня.

Таким образом 802-спецификации распространяются:

· на платы сетевых адаптеров
· на аппаратные компоненты глобальных вычислительных сетей
· на компоненты кабельных и беспроводных сетей.

То есть, спецификации данного проекта определяют способы, в соответствии с которыми платы сетевых адаптеров осуществляют доступ к физической среде и передают по ней данные. Сюда относятся соединение, поддержка и разъединение сетевых устройств.

Список рабочих и исследовательских групп IEEE 802

Активные группы

802.1 | Рабочая группа по протоколам верхних уровней локальных сетей
802.3 | Рабочая группа по Ethernet
802.11 | Рабочая группа по беспроводным локальным сетям (Wireless LAN)
802.15 | Рабочая группа по беспроводным персональным сетям (Wireless Personal Area Network, WPAN)
802.16 | Рабочая группа по системам широкополосного беспроводного доступа (Broadband Wireless Access)
802.17 | Рабочая группа по динамическому пакетному кольцу (Resilient Packet Ring)
802.18 | Техническая консультативная группа по обязательным требованиям к радио (Radio Regulatory)
802.19 | Техническая консультативная группа по смешанным структурам (Coexistence)
802.20 | Рабочая группа по мобильным системам широкополосного беспроводного доступа (Mobile Broadband Wireless Access MBWA)
802.21 | Рабочая группа по реализации переключения вызова без прерывания соединения (Media Independent Handoff Working Group)
802.22 | Рабочая группа по беспроводным региональным сетям (Wireless Regional Area Networks)
Link Security | Исследовательская группа по безопасности каналов (с 2005 г. вошла в состав рабочей группы 802.1)

Неактивные группы

802.2 | Рабочая группа по управлению логическим каналом (Logical Link Control)
802.5 | Рабочая группа по сети маркерное кольцо (Token Ring)
802.12 | Рабочая группа по протоколу обработка запросов по приоритету (Demand Priority)

Расформированные группы

802.4 | Рабочая группа по сети маркерная шина (Token Bus)
802.6 | Рабочая группа по городским сетям (Metropolitan Area Network)
802.7 | Техническая консультативная группа по широкополосной связи (Broadband)
802.8 | Техническая консультативная группа по волоконной оптике (Fiber Optic)
802.9 | Рабочая группа по изохронным локальным сетям (Isochronous LAN)
802.10 | Рабочая группа по безопасности (Security)
802.14 | Рабочая группа по кабельным модемам (Cable Modem)
QOS/FC | Исследовательская группа по контролю качества обслуживания (QoS/Flow Control Study Group)


Простейшие схемы соединения компьютеров в сеть

Для того чтобы организовать сетевое взаимодействие или сеанс связи между двумя компьютерами можно использовать один из двух методов:

· использование стандартных портов ввода-вывода;
· использование специализированных устройств связи.

Практически любой внешний информационный порт компьютера можно применять для организации сеанса связи. К их числу относятся: СОM, LPT, USB, IEEE 1394. Данный вид связи поддерживается на уровне операционной системы, может быть интегрирован в оболочку управления файлами или реализован в виде отдельного программного модуля.

Связать два компьютера через последовательный порт – задача достаточно простая. Для этого необходимо соединить COM-порты компьютеров по следующей схеме:

Рисунок 1 -

Схема соединения через последовательный порт

Соединение получило название null-modem и позволяет получить скорость информационного обмена до 115 000 бит/с.

Широкая полоса пропускания и высокая производительность IEEE 1394 обеспечивают одновременное функционирование в сети видеомагнитофонов, видеокамер, DVD/CD-проигрывателей, аудио-комплексов, телевизоров HDTV, кабельного и спутникового телевидения, спутниковых терминалов связи, модемов xDSL, охранных систем, компьютеров и других устройств. Скорость передачи до 1 600 Мбит/с. Для сравнения Hi-Speed USB – 480 Мбит/с

Рисунок 2 -

Портативный FireWire-коммутатор и кабельные разъемы

В качестве специализированного оборудования средств организации связи также могут быть использованы модемы, сетевые адаптеры, свитчеры.

одна сторона | цвет провода | другая сторона
1 | бело/зеленый | 3
2 | зеленый | 6
3 | бело/оранжевый | 1
4 | синий | 4
5 | бело/синий | 5
6 | оранжевый | 2
7 | бело/коричневый | 7
8 | коричневый | 8

Рисунок 3 -

Схема «расшивки» кабеля «витая пара» для прямого соединения между сетевыми адаптерами Ethernet

В беспроводных сетях всегда необходима установка дополнительного оборудования. Исключение составляют классы компьютеров в которых оно установлено по умолчанию, например мобильные и портативные системы. Примером такой связи является технология Bluetooth, которая, являясь стандартом для беспроводного подключения различных устройств, включает в себя поддержку многих функций (передача голоса, синхронизация данных, передача файлов, использование факса и модема и других) на скорости до 11 Мбит/с.

Рисунок 4 -

Внешний вид Bluetooth-модуля и способ его применения

В Bluetooth адаптеры выступают не в качестве сетевых плат, а в роли последовательных портов, через которые средствами операционной системы организуется прямое подключение. При этом одна сторона выступает в качестве сервера доступа, а вторая – удаленного клиента. Хотя возможна работа одного сервера одновременно с несколькими клиентами (до 7), но два клиента, подключенных к одному серверу, друг друга не видят.


Протоколы преобразования адресов

TCP/IP- это семейство протоколов. Часть из них обеспечивает выполнение “низкоуровневых” сетевых функций для множества приложений, таких, как работа с аппаратными протоколами, поддержка механизма доставки пакета по адресу назначения через множество сетей и узлов, обеспечение достоверности и надежности соединения и др. Другая часть протоколов предназначена для выполнения прикладных задач, таких, как передача файлов между компьютерами, отправка электронной почты или чтение гипертекстовой страницы WWW-сервера.

Задачей TCP является доставка всей информации компьютеру получателя, контроль последовательности передаваемой информации, повторная отправка недоставленных пакетов в случае сбоев работы сети. Если сообщение достаточно большое, чтобы его отправить в одном пакете, TCP делит и отправляет его несколькими блоками.

Подобно тому как почтовый протокол использует TCP, сам TCP использует протокол IP, который обеспечивает доставку пакета по адресу, т.е. адресацию и маршрутизацию. При передаче пакета протокол IP добавляет к маршруту заголовок, для того чтобы его можно было маршрутизировать по сети, используя таблицы маршрутизации. IP не ориентирован на соединения и посылает пакеты, не ожидая подтверждения об их получении. Кроме этого, IP отвечает за сборку и разборку пакета (фрагмента, дефрагментацию). Каждый пакет состоит из адресов отправителя и получателя, идентификатора протокола, контрольной суммы (вычисляемого значения) и TTL. Time To Live — время жизни — указывает каждому маршрутизатору на пути от отправителя до получателя долго пакет может находится в сети, и похож на таймер обратного отсчета. Когда пакет проходит через маршрутизатор, тот вычитает из TTL большую из величин: одну секунду или время (в секундах), которое пакет провел в его очереди.

В стеке TCP/IP определены 4 уровня:

1) Прикладной уровень стека TCP/IP соответствует 3-м верхним уровням модели OSI: прикладному, представления и сеансовому. К протоколам прикладного уровня относятся- протокол передачи файлов (File Transfer Protocol, FTP), протокол эмуляции терминала (Telnet), простой протокол передачи электронной почты (Simple Mail Transfer Protocol, SMTP), протокол передачи гипертекста (HyperText Transfer Protocol, HTTP) и многие другие. Протоколы прикладного уровня развертываются на хостах (конечный узел в Интернете).
2) Транспортный уровень стека TCP/IP может предоставлять вышележащему уровню 2 типа сервиса:
· Гарантированную доставку обеспечивает протокол управления передачей (Transmisson Control Protocol, TCP);
· Доставку по возможности обеспечивает протокол пользовательских дейтаграмм (User Datagram Protocol, UDP).
3) Сетевой уровень-стержень всей архитектуры TCP/IP. Основным протоколом сетевого уровня является межсетевой протокол (Internet Protocol, IP). Его задача- продвижение пакета между сетями- от одного маршрутизатора до другого до тех пор, пока пакет не попадет в сеть назначения. Протокол IP развертывается не только на хостах, но и на всех шлюзах.

К сетевому уровню TCP/IP относятся протоколы, выполняющие вспомогательные функции по отношению к IP. Это протоколы маршрутизации RIP и OSPF, которые определяют маршрут, составляют таблицу маршрутизации, а также протокол межсетевых управляющих сообщений (Internet Control Message Protocol, ICMP) и протокол групповой адресации (Internet Group Management Protocol, IGMP).

4) Уровень сетевых интерфейсов. Он поддерживает все популярные технологии; для локальных сетей- это Ethernet, Token Ring, FDDI, Fast Ethernet; для глобальных сетей- протоколы двухточечных соединений SLIP и PPP, технологии X.25, Frame Relay, ATM.


Протоколы удаленного контроля и управления.

Протокол DNS (Domain Name Service - служба доменных имен) обеспечивает поиск имен хостов, используя распределенную по сетевым серверам имен базу данных.

Протокол IPDC (IP Device Control - управление устройствами IP) представляет собой семейство протоколов, компоненты которого можно использовать совместно или по отдельности для управления соединениями, средой и передачей сигнализации. Этот протокол решает задачи одного или нескольких протоколов управления шлюзами, расположенными на границе между коммутируемой телефонной сетью и сетью internet, а также завершающих коммутируемые транки. Примерами таких устройств могут служить серверы доступа и шлюзы VoIP (голос через IP). Необходимость разделения протоколов управления от системы сигнализации возникает в тех случаях, когда требуется, чтобы логика управления сервисом для обработки соединений полностью или частично была реализована за пределами шлюзов. Протокол IPDC был построен на базе структуры, обеспечиваемой протоколом DIAMETER, который был специально разработан для аутентификации, авторизации и ведения учета.

Протокол NTP (Network Time Protocol) представляет собой систему синхронизации компьютерных часов через сеть Internet, обеспечивающую механизм синхронизации и координацию распространения информации в больших сетях, использующих каналы с различными скоростями. Протокол использует структуру распространения информации между серверами точного времени, образующими самоорганизующуюся иерархическую структуру "ведущий-ведомый" (master-slave) для синхронизации локальных часов подсети с национальными стандартными часами по проводам или радиоканалу.

Протокол RADIUS представляет собой, протокол управляющий распределенными последовательными линиями для большого числа пользователей.

Протокол SNMP разработан для того, чтобы различные объекты сетей могли участвовать в глобальной архитектуре управления сетью. Системы сетевого управления могут опрашивать (сканировать) сетевые объекты, реализующие протокол SNMP для получения информации, имеющей отношение к частной реализации системы управления сетью.

Система управления сетью узнает о проблемах, получая прерывания (trap) или уведомления об изменениях от сетевых устройств, реализующих SNMP.

Протокол TELNET представляет собой протокол эмуляции терминала в стеке TCP/IP. Современные варианты TELNET обеспечивают эмуляцию практически всех функций терминалов различных типов, разработанных в течение последних 20 лет. Набор опций позволяет протоколу TELNET поддерживать передачу двоичных данных, макросы, эмуляцию графических терминалов и передачу информации для поддержки централизованного управления терминалами.

TELNET использует транспортный протокол TCP для организации виртуальных соединений между серверами и клиентами. После организации соединения сервер и клиент TELNET входят в фазу согласования параметров, определяющих режим работы каждой из сторон соединения. В течение сеанса любая из сторон может заново инициализировать старые параметры или согласовать новый набор параметров. В общем случае каждая сторона TELNET-соединения пытается реализовать максимально возможный набор поддерживаемых опций.

Протокол X-Window обеспечивает удаленный оконный интерфейс для распределенных сетевых приложений. Это протокол уровня приложений, использующий в качестве транспортного протокола TCP/IP или DECnet.

Сетевой протокол X-Window основан на архитектуре клиент-сервер, где сервер представляет собой управляющую программу на рабочей станции пользователя, а клиентские приложения могут размещаться в любом месте сети. Управляющая программа X-сервер на рабочей станции пользователя может одновременно поддерживать множество окон для различных сетевых приложений с асинхронным обновлением содержимого окон в соответствии с информацией протокола X-Window.

Для обеспечения взаимодействия пользователя с удаленными приложениями программа X-сервер на станции пользователя генерирует события в ответ на действия пользователей. В некоторых случаях приложения могут также генерировать события, передаваемые управляющей программе X-сервер.


Протоколы файлового обмена

Протокол FTP (File Transfer Protocol - протокол переноса файлов) обеспечивает базовые элементы системы совместного использования файлов хостами сети. Протокол FTP использует TCP для создания виртуальных соединений, обеспечивающих поддержку управления. Для операций переноса файлов организуется отдельное соединение TCP. Управляющие соединения используют образ протокола TELNET для обмена командами и сообщениями между хостами сети.

Кадры управления FTP используют обмен TELNET и могут содержать команды TELNET или опции согласования параметров. Однако, большинство управляющих кадров FTP является просто текстовыми строками ASCII и может классифицироваться как команды или сообщения FTP.

Сообщения FTP являются откликами на команды FTP и содержат код отклика, за которым следует пояснительный текст.

Протокол TFTP (Trivial File Transfer Protocol - тривиальный протокол переноса файлов) использует дейтаграммы UDP. TFTP поддерживает операции записи и чтения файлов, но не поддерживает служб каталогов и проверки полномочий (авторизации) пользователей.

Протокол Internet Gopher и одноименная программа используют модель клиент-сервер. Этот протокол предполагает использование надежного протокола доставки TCP. Серверы Gopher прослушивают порт 70 (этот номер порта выделен для протокола Gopher комитетом IANA). Документы Gopher могут располагаться на множестве хостов Internet. Пользователи запускают клинетскую программу на своем компьютере, подключаются к серверу Gopher и посылают ему селектор (строка текста, которая может быть пустой) через соединение TCP с использованием пердопределенного порта. Сервер отвечает на запрос текстовым блоком, завершающимся точкой в пустой строке и разрывает соединение.

Первый символ каждой строки говорит о том, что описывает строка - документ, каталог или поисковый сервис. Следующие символы (до знака табуляции) формируют строку вывода на пользовательский экран, служащую для выбора данного документа (или каталога). Первый символ строки реально определяет тип элемента, отображаемого этой строкой. Почти во всех случаях клиент Gopher предоставляет пользователю некоторое представление о том, чему соответствует данный элемент (выводится пиктограмма, короткий текст или нечто подобное).

Символы после знака табуляции (до следующего символа табуляции) формируют строку селектора, которую клиентская программа должна передать серверу для получения документа (или списка содержимого каталога). Клиент никогда не меняет строку селектора, которая зачастую является маршрутом доступа или другим селектором, используемым сервером для доступа к желаемому элементу. Следующие два символа табуляции обозначают имя домена для хоста и номер порта. При наличии других символов табуляции клиент Gopher должен игнорировать их. Символы CR LF обозначают переход на новую строку.

Символы типа элементов

Клиент Gopher решает вопрос доступности объекта для просмотра по первому символу каждой строки в списке содержимого каталога. Увеличение этого списка может расширять протокол.

Протокол HTTP (Hypertext Transfer Protocol - протокол передачи гипертекста) представляет собой протокол уровня приложений, обеспечивающий простой и быстрый способ организации распределенных гиперсред для совместного использования в сети. Сообщения передаются в формате, похожем на форматы Internet Mail и MIME (Multipurpose Internet Mail Extensions).

Протокол S-HTTP (Secure HTTP) обеспечивает механизм защищенной связи между парами клиент-сервер HTTP для того, чтобы можно было выполнять коммерческие транзакции с помощью широкого класса приложений. S-http обеспечивает гибкое решение для поддержки множества ортогональных режимов работы, механизмов управления ключами, моделей доверия, криптографических алгоритмов и форматов инкапсуляции путем согласования опций между участниками каждой транзакции. Сообщения Secure HTTP синтаксически совпадают с сообщениями HTTP и состоят из строк запроса или состояния, за которыми следует заголовок и текст сообщения. Однако заголовки S-HTTP отличаются от заголовков HTTP, а тело сообщений обычно зашифровано.


Разграничение прав доступа к сетевым ресурсам

В сетевых операционных системах при управлении сетевыми ресурсами должна быть реализована модель системы безопасности с разграничением прав доступа на разных уровнях. В том числе:

· полный доступ для всех пользователей на все виды действий;
· ограничения на уровне пользователей;
· ограничения на уровне узлов сети;
· ограничения на уровне анализа содержимого запросов;
· полный запрет для всех пользователей на все виды действий.

Если доступ к сетевым ресурсам регламентируется на уровне пользователей - это означает, что пользователь сможет получить доступ к объектам системы только после того, как он будет аутентифицирован и авторизован. В процессе аутентификации система удостоверяет личность пользователя (идентифицирует его) на основании факта знания пароля, соответствующего его учетной записи. Авторизация подразумевает назначение пользователю прав доступа к объектам системы, на основании его членства в различных группах.

Например, согласно сетевой политике Microsoft, виды прав доступа к файловой системе могут быть следующие:

Рисунок 1 -

Модель отдельного домена («лес») системы Windows 2000

Совместное использование файлов (жарг. расшаривание, от англ. File sharing) — предоставление файлов, находящихся на компьютере, в общий доступ так, что другие пользователи компьютерной сети могут получить к ним доступ.

Возможно разделение доступа — предоставление доступа только определенным пользователям или компьютерам, разделение прав доступа — только чтение, чтение и изменение и т. п..

Второе значение: одновременная правка фаила несколькими пользователями.Используется в современных системах разработки.

В файловой системе NTFS вы можете индивидуально назначать права доступа созданным вами папкам и файлам; если же вы войдёте в систему с правами администратора, то сможете изменить атрибуты доступа любого файла, в том числе и созданного.


Свойства протокола NetBIOS/SMB

Этот стек широко применяется в продуктах компаний IBM и Microsoft. На его физическом и канальном уровнях используются все наиболее распространенные протоколы Ethernet, Token Ring, FDDI и другие. На верхних уровнях работают протоколы NetBEUI и SMB.

Протокол NetBIOS (Network Basic Input/Output System) появился в 1984 году как сетевое расширение стандартных функций базовой системы ввода/вывода (BIOS) IBM PC для сетевой программы PC Network компании IBM. В дальнейшем этот протокол был заменен так называемым протоколом расширенного пользовательского интерфейса NetBEUI — NetBIOS Extended User Interface. Для обеспечения совместимости приложений в качестве интерфейса к протоколу NetBEUI был сохранен интерфейс NetBIOS. Протокол NetBEUI разрабатывался как эффективный протокол, потребляющий немного ресурсов и предназначенный для сетей, насчитывающих не более 200 рабочих станций.

Протокол NetBEUI выполняет много полезных сетевых функций, которые можно отнести к сетевому, транспортному и сеансовому уровням модели OSI, однако он не обеспечивает возможность маршрутизации пакетов. Это ограничивает применение протокола NetBEUI локальными сетями, не разделенными на подсети, и делает невозможным его использование в составных сетях.

Некоторые ограничения NetBEUI снимаются в реализации этого протокола NBF (NetBEUI Frame), которая включена в операционную систему Microsoft Windows NT.

Протокол SMB (Server Message Block) выполняет функции сеансового, представительного и прикладного уровней. На основе SMB реализуется файловая служба, а также службы печати и передачи сообщений между приложениями.

Протокол NetBIOS (Network Basic Input/Output System - сетевая базовая система ввода/вывода) был создан фирмой IBM для работы в локальных сетях и предназначен для передачи данных между рабочими станциями. Система NetBIOS используется в качестве интерфейса, независящего от фирмы-производителя. NetBIOS использует в качестве транспортных протоколов TCP и UDP.

Приложения могут через NetBIOS найти нужные им ресурсы, установить связь и послать или получить информацию. NetBIOS использует для службы имен порт - 137, для службы дейтограмм - порт 138, а для сессий - порт 139.

Любая сессия начинается с NetBIOS-запроса, задания IP-адреса и определения TCP-порта удаленного объекта, далее следует обмен NetBIOS-сообщениями, после чего сессия закрывается. Сессия осуществляет обмен информацией между двумя netbios-приложениями. Длина сообщения лежит в пределах от 0 до 131071 байт. Допустимо одновременное осуществление нескольких сессий между двумя объектами.

Стек с протоколом WINS

Протокол обладает высоким быстродействием и служит для объединения небольших локальных сетей (20-200 ЭВМ) друг с другом или с главной ЭВМ. Этот протокол соответствует связному, сетевому и транспортному уровню модели OSI. В новых версиях NetBEUI (3.0 и выше) снято ограничение на число одновременных сессий (254). Среди ограничений NetBEUI следует назвать отсутствие внутренней маршрутизации и серьезные ограничения при работе в региональных сетях. По этой причине NetBEUI рекомендуется для локальных сетей (здесь они предпочтительнее других протоколов), а для внешних связей использовать, например, TCP/IP.


Свойства протокола X.25

Протокол Х.25 (CCITT Recommendation X.25) был разработан компаниями общественных линий связи. Позднее протокол X.25 был включен в более полную модель взаимодействия открытых систем (рекомендации Х.200, Х.220), разработанную тем же комитетом.

Заголовок Х.25 Уровня 3 образован из "идентификатора универсального формата" - general format identifier - (GFI), "идентификатора логического канала"- logical channel identifier - (LCI) и "идентификатора типа пакета"- packet type identifier - (PTI). GFI представляет собой 4-х битовое поле, которое указывает на универсальный формат заголовка пакета. LCI представляет собой 12-битовое поле, которое идентифицирует виртуальную цепь. Поле LCI является логически значимым в интерфейсе DTE/DCE. Другими словами, для организации виртуальной цепи PDN соединяет два логических канала, каждый из которых имеет независимый LCI, двумя интерфейсами DTE/DCE. Поле PTI идентифицирует один из 17 типов пакетов Х.25.

Поля адресации в пакетах установления обращения обеспечивают адреса DTE источника и пункта назначения. Они используются для организации виртуальных цепей, включающих передачу Х.25. Recommendation Х.121 CCITT определяет форматы адресов источника и пункта назначения. Адреса Х.121 (называемые также International Data Numbers, или IDN) имеют разную длину, которая может доходить до 14 десятичных знака. Четвертый байт в пакете организации обращения определяет длину адресов DTE источника и назначения. Первые четыре цифры IDN называются "код идентификации сети" - data network identification code - (DNIC). DNIC поделен на две части; первая часть (3 цифры) определяет страну, где находится PSN, вторая часть определяет саму PSN. Остальные цифры называются "номером национального терминала" - national terminal number - (NTN); они используются для идентификации определенного DTE в сети PSN. Формат адреса Х.121 представлен на Рис. 13-4.

X.25 представляет собой рекомендации CCITT для интерфейса между устройствами DTE и DCE через телефонную сеть общего пользования (Public Switched Telephone Network- PSTN). В общем случае X.25 функционирует на уровнях 1 - 3 эталонной модели OSI, однако в данной главе термин X.25 используется только применительно к сетевому уровню модели OSI. Пакеты протокола X.25 передаются по сетям общего пользования в информационном поле кадров LAPB.

Поля адресации, образующие адрес Х.121, необходимы только при использовании SVC, да и то только на время установления обращения. После того, как вызов организован, PSN использует поле LCI заголовка пакета данных для назначения конкретной виртуальную цепь отдаленному DTE.

Х.25 Уровня 3 использует три рабочих процедуры организации виртуальной цепи:

Установления обращения

Передача данных

Раз'единение вызова

Выполнение этих процедур зависит от использованного типа виртуальной цепи. Для PVC Уровень 3 Х.25 всегда находится в режиме передачи данных, т.к. цепь организована перманентно. Если применена SVC, то используются все три процедуры.

Процедура передачи данных зависит от пакетов DATA. Х.25 Уровня 3 сегментирует и подвегает операции "обратный ассеблер" сообщения пользователя, если длина их превышает максимальный размер пакета для данной цепи. Каждому пакету DATA присваивается номер последовательности, поэтому можнo управлять неисправностями и потоком информации через интерфейс DTE/DCE.

Протокол Х.25 (официально называемый CCITT Recommendation X.25 - "Рекомендация "Х.25 CCITT) был разработан компаниями общественных линий связи (в основном телефонными компаниями), а не каким-то отдельным коммерческим предприятием. Поэтому спецификация разработана так, чтобы обеспечить хорошую работоспособность независимо от типа системы пользователя или изготовителя. Пользователи заключают контракты с общедоступными сетями передачи данных, чтобы пользоваться их сетями с коммутацией пакетов (PSN), и им пред'является счет в зависимости от времени пользования PDN. Предлагаемые услуги (и взимаемая плата) регулируются Федеральной Комиссией по Связи (FCC).

Oдним из уникальных свойств Х.25 является его международный характер. Х.25 и связанными с ним протоколами управляет одно из агентств Организации Об'единненых Наций, называемое "Международный Союз по Телекоммуникациям (ITU). Комитет ITU, ответственный за передачу голоса и данных, называется Международным консультативным комитетом по телеграфии и телефонии (CCITT). Членами CCITT являются FCC, Европейские PTT, общедоступные сети передачи данных и множество компаний, занимающихся компьютерами и передачей данных. То, что Х.25 стал стандартом подлинно глобального значения, является прямым следствием присущих ему свойств.

Х.25 определяет характеристики телефонной сети для передачи данных. Чтобы начать связь, один компьютер обращается к другому с запросом о сеансе связи. Вызванный компьютер может принять или отклонить связь. Если вызов принят, то обе системы могут начать передачу информации с полным дублированием. Любая сторoнa может в любой момент прекратить связь.

Спецификация Х.25 определяет двухточечное взаимодействие между терминальным оборудованием (DTE) и оборудованием завершения действия информационной цепи (DCE). Устройства DTE (терминалы и главные вычислительные машины в аппаратуре пользователя) подключаются к устройствам DCE (модемы, коммутаторы пакетов и другие порты в сеть PDN, обычно расположенные в аппаратуре этой сети), которые соединяются с "коммутаторами переключения пакетов" (packet switching exchange) (PSE или просто switches) и другими DCE внутри PSN и, наконец, к другому устройству DTE. Взаимоотношения между об'ектами сети Х.25 показаны на Рис. 13-1.

DTE может быть терминалом, который не полностью реализует все функциональные возможности Х.25. Такие DTE подключаются к DCE через трансляционное устройство, называемое пакетный ассемблер/дизассемблер - packet assembler/disassembler - (РAD). Действие интерфейса терминал/PAD, услуги, предлагаемые PAD и взаимодействие между PAD и главной вычислительной машиной определены соответственно CCITT Recommendations X.28, X3 и Х.29.

Спецификация Х.25 составляет схемы Уровней 1-3 эталонной модели OSI. Уровень 3 Х.25 описывает форматы пакетов и процедуры обмена пакетами между равноправными об'ектами Уровня 3. Уровень 2 Х.25 реализован Протоколом Link Access Procedure, Balanced (LAPB). LAPB определяет кадрирование пакетов для звена DTE/DCE. Уровень 1 Х.25 определяет электрические и механические процедуры активации и дезактивации физической среды, соединяющей данные DTE и DCE. Это взаимоотношение представлено на Рис. 13-2. Необходимо отметить, что на Уровни 2 и 3 также ссылаются как на стандарты ISO - ISO 7776 (LAPB) и ISO 8208 (пакетный уровень Х.25).

Сквозная передача между устройствами DTE выполняется через двунаправленную связь, называемую виртуальной цепью. Виртуальные цепи позволяют осуществлять связь между различными элементами сети через любое число промежуточных узлов без назначения частей физической среды, что является характерным для физических цепей. Виртуальные цепи могут быть либо перманентными, либо коммутируемыми (временно). Перманентные виртуальные цепи обычно называют PVC; переключаемые виртуальные цепи- SVC. PVC обычно применяются для наиболее часто используемых передач данных, в то время как SVC применяются для спорадических передач данных. Уровень 3 Х.25 отвечает за сквозную передачу, включающую как PVC, так и SVC.

После того, как виртуальная цепь организована, DTE отсылает пакет на другой конец связи путем отправки его в DCE, используя соответствующую виртуальную цепь. DCE просматривает номер виртуальной цепи для определения маршрута этого пакета через сеть Х.25. Протокол Уровня 3 Х.25 осуществляет мультиплексную передачу между всеми DTE, которые обслуживает устройство DCE, расположенное в сети со стороны пункта назначения, в результате чего пакет доставлен к DTE пункта назначения.

В данной главе описываются следующие протоколы: LAPB, X.25, X.75, MLP, HDLC.

На рисунке показано распо оложение протоколов X.25 в эталонной модели OSI.


Сеансовый, представительский и прикладной уровни OSI

Сеансовый уровень отвечает за установление и поддержку коммуникационного канала между двумя узлами, он обеспечивает очередность работы узлов: определяет, какой из узлов первым начинает передачу данных. Сеансовый уровень определяет продолжительность работы узла на передачу, а также способ восстановления информации после ошибок передачи. Если сеанс связи был ошибочно прерван на более низком уровне, сеансовый уровень пытается восстановить передачу данных. По окончанию сеанса связи этот уровень подает команды отключения узлов.

В процессе сеанса обмена информацией по сети между передающим и принимающим абонентами происходит обмен информационными и управляющими пакетами по установленным правилам, называемым протоколом обмена. Это позволяет обеспечить надежную передачу информации при любой интенсивности обмена по сети (рисунок 1).

Рисунок 1 -

Пример обмена пакетами при сеансе связи

Сеанс обмена начинается с запроса передатчиком готовности приемника принять данные. Для этого используется управляющий пакет "Запрос". Если приемник не готов, он отказывается от сеанса специальным управляющим пакетом. В случае, когда приемник готов, он посылает в ответ управляющий пакет "Готовность". Затем начинается собственно передача данных. При этом на каждый полученный информационный пакет приемник отвечает управляющим пакетом "Подтверждение". В случае, когда пакет данных передан с ошибками, в ответ на него приемник запрашивает повторную передачу. Заканчивается сеанс управляющим пакетом "Конец", которым передатчик сообщает о разрыве связи.

Примером связи на сеансовом уровне может быть подключение рабочей станции к некоторому серверу Интернета. Станция и сервер имеют уникальные адреса протокола Интернет (IP-адреса) и сеансовый уровень использует эти адреса для установки соединения между узлами. После того как подключение осуществлено и рабочая станция зарегистрировалась на сервере, на данном уровне устанавливается сеанс передачи данных.

Сеансовый уровень позволяет так выполнять передачу данных по сети, что ее производительность можно увеличить в два раза. Например, устройства, работающие на сеансовом уровне, могут передавать и принимать данные, однако не одновременно. Для сеансового уровня этот способ передачи называется двусторонним альтернативным режимом для управления диалогом. Но кроме этого, сеансовый уровень позволяет соединить эти устройства для одновременного приема-передачи, что вдвое увеличивает скорость передачи данных при сеансовом диалоге между двумя узлами. Этот режим называется двусторонним одновременным.

Представительский уровень управляет форматированием данных, поскольку прикладные программы нередко используют различные способы представления информации. В некотором смысле он выполняет функции программы проверки синтаксиса. Он гарантирует, что числа и символьные строки передаются именно в том формате, который понятен принимающему узлу. Также он отвечает за шифрование данных. Шифрование – это процесс засекречивания информации, который не позволяет неавторизованным пользователям прочистить данные в случае их перехвата. Еще одна функция – сжатие данных после их формирования между символами и строками может оставаться свободное место. При сжатии эти промежутки удаляются.

Прикладной уровень управляет доступом к приложениям и сетевым службам. Примером таких служб являются передача файлов, управление файлами, удаленный доступ к файлам, управление сообщениями электронной почты. На прикладном уровне работает редиректор систем Microsoft Windows. Редиректор – это служба, позволяющая видеть компьютер в сети и обращаться к нему. Если в сети разрешается общий доступ к некоторой папке, то при помощи редиректора другие компьютеры могут видеть эту папку и использовать ее.

Подробнее службы и протоколы, реализующие функции этих уровней рассмотрены в главах 10-11.


Сетевой и транспортный уровни модели OSI

Сетевой уровень управляет прохождением пакетов по сети. Все сети содержат физические маршруты передачи информации (кабельные тракты). Сетевой уровень анализирует адресную информацию протокола передачи пакетов и посылает их по более подходящему маршруту – физическому или логическому, обеспечивая максимальную эффективность сети. Также этот уровень обеспечивает пересылку пакетов между сетями через маршрутизаторы.

Контролируя прохождение пакетов, сетевой уровень выступает в роли «управляющего трафиком»: он направляет пакеты по наиболее эффективному из нескольких возможных трактов передачи данных. Для определения наилучшего маршрута сетевой уровень постоянно собирает информацию о расположении различных сетей и узлов, этот процесс называется обнаружением маршрута (discovery).

Сетевой уровень может направлять данные по разным маршрутам, создавая виртуальные каналы (virtual circuit). Виртуальные каналы, представляют собой логические коммуникационные линии для передачи и приема данных. Виртуальные каналы, представленные только на сетевом уровне, образуются между сетевыми узлами, обменивающимися информацией. Поскольку сетевой уровень управляет данными, поступающими по нескольким виртуальным каналам, то эти данные могут поступать в неправильной очередности. Для устранения этих издержек сетевой уровень проверяет и при необходимости корректирует порядок передачи пакетов перед отправкой их следующему уровню стека. Также на сетевом уровне фреймы получают адреса и выполняется форматирование фреймов в соответствии с сетевым протоколом принимающей стороны. Кроме того, обеспечивается передача фреймов с такой скоростью, чтобы принимающий уровень успевал обрабатывать их.

Транспортный уровень – подобно канальному и сетевому уровням выполняет функции, обеспечивающие надежную пересылку данных от передающего узла к принимающему. Транспортный уровень гарантирует, что данные передаются и принимаются в одном и том же порядке. Кроме этого, по завершении пересылки принимающий узел может послать подтверждение. Когда в сети используются виртуальные каналы, транспортный уровень отслеживает уникальные идентификаторы, назначенные каждому каналу. Эти значения называются портами, идентификаторами соединения или сокетами, они назначаются сеансовым уровнем. Также транспортный уровень обеспечивает проверку пакетов. При этом на самом верхнем уровне контроля гарантируется безошибочная передача пакетов от узла к узлу в заданный промежуток времени.

назначаются сеансовым уровнем. Также транспортный уровень обеспечивает проверку пакетов. При этом на самом верхнем уровне контроля гарантируется безошибочная передача пакетов от узла к узлу в заданный промежуток времени.

Рисунок 1 -

Доставка и сборка информации сетевым и транспортным уровнями

Таким образом два этих уровня являются ключевыми в решении задачи безошибочной доставки сообщения. Поскольку на этих уровнях принимаются решения о необходимости:

- повтора кадра данных в случае сбоя при его передачи
- ограничения числа маршрутов по доставке сообщений
- обеспечения правильной сборки сообщения после доставки всех его составляющих для его передачи более высоким уровням

Для выполнения своих функций протоколы этих двух уровней внедряют дополнительные поля в каждый передаваемый кадр данных, а в некоторых случаях порождаются дополнительные пакеты для сбора информации.

Особенности работы протоколов этих двух уровней серьезно различаются в существующих сетевых архитектурах. Подробнее эти вопросы рассматриваются в главах 8-10.


Синхронизация в распределенных системах

Синхронизация необходима процессам для организации совместного использования ресурсов, таких как файлы или устройства, а также для обмена данными.

В централизованных системах синхронизация, особенно при использовании блокирующих/резервирующих ресурсов алгоритмов решается с помощью разделяемой памяти. Последовательность событий установить несложно, т.к. в системе присутствует единственный таймер.

Если используются распределенные вычисления таймеров в системе намного больше, у каждого своя степень точности. В результате последовательность событий, которая необходима для решения синхронизации бывает довольно сложно установить.

Применяются следующие подходы:

1 Алгоритм синхронизации логических часов. В этом случае используется предпосылка, что для соблюдения правильности выполнения операции необходимо и достаточно соблюдение общесистемной последовательности событий. При этом все процессы в системе должны быть согласны с тем временем, которое указывает любой из серверов при обработке запроса.

Рассмотрим механизм, который предложил Лампорт.

Рисунок 1 -

Пример работы алгоритма синхронизации логических часов

В системе имеется 3 узла. Проблема в том, что уже запрос С по последовательности событий отправлен позже с сервера 2, чем получен сервером 1. Момент отправки запроса - 60, момент его получения - 56. Поскольку сообщение может быть доставлено не ранее того момента времени, когда оно было отправлено, системный таймер принимающей стороны корректируется, т. е. сообщение С может придти не раньше, чем в момент времени 61.

2 Алгоритмы взаимного исключения. Параллельно выполняющиеся процессы даже в распределенной системе проще программировать, используя понятие критической секции. Для этого необходимо обеспечить, чтобы в критической секции в каждый момент времени находился только один процесс. Способы реализации:

а) Централизованный алгоритм. Используется единый диспетчер, отвечающий за доступ процессов к критической секции. Этот диспетчер или координатор физически реализуется в виде отдельного вычислительного блока и к нему переадресовываются все запросы процессов системы, связанные с критическими секциями. Недостаток: уровень надежности центрального элемента, т.е. координатора системы.

б) Распределенный алгоритм. Когда процесс хочет войти в критическую секцию, он формирует сообщение, содержащее номер критической секции, свой номер и текущее значение времени. Затем пересылает это сообщение всем другим. Если процесс получает такое сообщение, и не собирается использовать эту критическую секцию, он посылает в ответ разрешение на вход процессу в критическую секцию. Cуществует 2 варианта действия: - если процесс-получатель уже находится в этой критической секции, он ставит запрос в очередь до тех пор, пока не покинет критическую секцию, после чего посылает в ответ разрешение; - если он только собирается войти в критическую секцию он сравнивает временные метки поступившего и собственного запроса (чей раньше), после чего либо разрешает процессу войти в критическую секцию, либо ставит поступивший запрос в очередь.

в) Алгоритм Token Ring. Для того, чтобы получить доступ к критической секции он ожидает, когда наступит его очередь ее использования, которая передается по кольцу.

Считается, что из этих трех алгоритмов централизованный наиболее эффективный. Второй насыщен широковещательными сообщениями. Все три алгоритма плохо защищены от отказов.

Также вышеописанные процедуры не исключают возможности возникновения эффекта гонок. Для того, чтобы его исключить, в распределенных системах также используют механизм неделимых транзакций. Неделимые транзакции позволяют увеличить степень синхронизации в распределенных системах, поскольку позволяют однозначно установить последовательность выполняемых действий в пределах одной транзакции. Транзакция обладает следующими свойствами: упорядочиваемость, неделимость и постоянство.


Система адресации AppleTalk

Для обеспечения минимальных затрат, связанных с работой администратора сети, aдреса узлов AppleTalk назначаются динамично. Когда компьютер Macintosh начинает работу в сети AppleTalk, он выбирает какой-нибудь адрес протокола (сетевого уровня) и проверяет его, чтобы убедиться, что этот адрес используется в данный момент. Если это не так, то этот новый узел успешно присваивает себе какой-нибудь адрес. Если этот адрес используется в данный момент, то узел с конфликтным адресом отправляет сообщение, указывающее на наличие проблемы, а новый узел выбирает другой адрес и повторяет этот процесс. На рисунке 1 представлен процесс выбора адреса AppleTalk.

Рисунок 1 -

Выбор адреса AppleTalk

AppleTalk идентифицирует несколько сетевых объектов. Самым простым является узел (node), который является просто любым устройством, соединенным с сетью AppleTalk. Следующим объектом является сеть. Сеть AppleTalk представляет собой просто отдельный логический кабель. Хотя этот логический кабель часто является отдельным физическим кабелем, некоторые вычислительные центры используют мосты для объединения нескольких физических кабелей. И наконец, зона (zone) АppleTalk является логической группой из нескольких сетей. Объекты AppleTalk изображены на рисунке 2.

Рисунок 2 -

Объекты AppleTalk

Основным протоколом сетевого уровня AppleTalk является протокол DDP. Адреса AppleTalk, назначаемые DDP, состоят из двух компонентов: 16-битового номера сети (network number) и 8-битового номера узла (node number). Эти два компонента обычно записываются в виде десятичных номеров, разделенных точкой (например, 10.1 означает сеть 10, узел 1). Если номер сети и номер узла дополнены 8-битовым гнездом (socket), обозначающим какой-нибудь особый процесс, то это означает, что в сети задан уникальный процесс.

AppleTalk Phase II делает различие между нерасширенными (nоnextended или сетями AppleTalk Phase I) и расширенными (extended) сетями. В нерасширенных сетях, таких как LocalTalk, номер каждого узла AppleTalk уникален. В расширенных сетях (EtherTalk, TokenTalk), уникальной является комбинация номер каждой сети/номер узла.


Система адресации IPX

Протоколы IPX/SPX, разработанные компанией Novell, образуют набор (стек), используемый в сетевых программных средствах довольно широко распространенных локальных сетей Novell (NetWare). Это сравнительно небольшой и быстрый протокол, поддерживающий маршрутизацию. Прикладные программы могут обращаться непосредственно к уровню IPX, например, для посылки широковещательных сообщений, но значительно чаще работают с уровнем SPX, гарантирующим быструю и надежную доставку пакетов. Если скорость не слишком важна, то прикладные программы применяют еще более высокий уровень, например, протокол NetBIOS, предоставляющий удобный сервис. Компанией Microsoft предложена своя реализация протокола IPX/SPX, называемая NWLink. Протоколы IPX/SPX и NWLink поддерживаются операционными системами NetWare и Windows. Выбор этих протоколов обеспечивает совместимость по сети любых абонентов с данными операционными системами.

Протокол IPX является низкоуровневым (относительно уровней модели OSI), поэтому он непосредственно инкапсулирует свою информацию, называемую дейтаграммой, в поле данных передаваемого по сети пакета (рисунок 1).

Рисунок 1 -

Инкапсуляция данных

При этом в заголовок дейтаграммы входят адреса абонентов (отправителя и получателя) более высокого уровня, чем MAC-адреса, – это IPX-адреса для протокола IPX или IP-адреса для протокола IP. Эти адреса включают номера сети и узла, хоста (индивидуальный идентификатор абонента). При этом IPX-адреса довольно просты и имеют всего один формат (рисунок 2).

Рисунок 2 -

Формат IPX- адреса

Номер сети – это код, присвоенный каждой конкретной сети, то есть каждой широковещательной области общей, единой сети. Под широковещательной областью понимается часть сети, которая прозрачна для широковещательных пакетов, пропускает их беспрепятственно.

Для маршрутизации пакетов в объединенных сетях IPX использует протокол динамической маршрутизации, называемый RIP (Routing Information Protocol - протокол маршрутной информации). В настоящее время RIP является наиболее часто используемым протоколом для внутренних роутеров (interior gateway protocol-IGP) в сообществе Internet.

По протоколу RIP все сети имеют номера (способ образования номера зависит от используемого в сети протокола сетевого уровня), а все маршрутизаторы - идентификаторы. Протокол RIP широко использует понятие "вектор расстояний". Вектор расстояний представляет собой набор пар чисел, являющихся номерами сетей и расстояниями до них в хопах.

Вектора расстояний итерационно распространяются маршрутизаторами по сети, и через несколько шагов каждый маршрутизатор имеет данные о достижимых для него сетях и о расстояниях до них. Если связь с какой-либо сетью обрывается, то маршрутизатор отмечает этот факт тем, что присваивает элементу вектора, соответствующему расстоянию до этой сети, максимально возможное значение, которое имеет специальный смысл - "связи нет". Таким значением в протоколе RIP является число 16.

При использовании протокола RIP работает эвристический алгоритм динамического программирования Беллмана-Форда, и решение, найденное с его помощью является не оптимальным, а близким к оптимальному. Преимуществом протокола RIP является его вычислительная простота, а недостатками - увеличение трафика при периодической рассылке широковещательных пакетов и неоптимальность найденного маршрута.


Система адресации IP v.4

Адресация в IP-сетях проходит несколько этапов преобразования видов адресов для однозначного соответствия адреса приемника приемнику, адреса источника источнику. Это преобразование производится соответственно уровнем модели OSI.

На физическом уровне адресация не производится. MAC-адреса позволяют перенаправить пакет конкретному сетевому адаптеру или модему или другому активному сетевому оборудованию. Все MAC-адреса уникальны и назначаются фирмой-изготовителем.

Адреса верхнего уровня предназначены для конкретных процессов. Второе назначение адресов верхнего уровня - легкая читаемость программистами или пользователями при адресации сетевых ресурсов.

Адреса сетевого уровня IP назначаются и используются операционной системой. У работающей ОС может быть один и более IP-адресов. При этом, если используется несколько интерфейсных карт, то ОС должна назначить однозначное соответствие каждого IP-адреса конкретному порту сетевого обмена, например, сетевому адаптеру.

Механизм адресации IP v.4 предполагает деление адреса на 2 части. Эта информация занимает 4 байта, и обычно разделяется по границе байта. Спецификации IP v.4 разделяют IP-адреса на 5 классов:

 | 1 байт |  | 2 байт | 3 байт | 4 байт
6 A | 0 | № сети | № узла
B | 10 | № сети |  | № узла
C | 110 | № сети |  |  | № узла
D | 1110 | Адрес группы Multicast
E | 11110 | 5 Зарезервирован

Классу A соответствует диапазон адресов 1.0.0.0 - 127.255.255.255.
Классу B соответствует диапазон адресов 128.0.0.0 - 191.255.255.255.
Классу С соответствует диапазон адресов 192.0.0.0 - 223.255.255.255.
Классу D соответствует диапазон адресов 224.0.0.0 - 239.255.255.255.
Классу E соответствует диапазон адресов 240.0.0.0 - 247.255.255.255.

Класс А используется для самых крупных сетей, насчитывающих до 16677216 узлов. Таких сетей максимальное количество 126.

В классе В максимально - 65536 узлов, количество сетей - 2142.

Класс С оперирует количеством адресов, не превышающим 254 узла. Это наиболее распространенный и эффективный класс адресов.

Беcклассовая адресация (Classless InterDomain Routing - CIDR) - метод IP-адресации, позволяющий гибко управлять пространством IP-адресов, не используя жёсткие рамки классовой адресации. Способ основывается на переменной длине маски подсети (Variable Lenght Subnet Mask - VLSM), в то время, как в классовой адресации длина маски строго фиксирована 0,1,2 или 3 установленными байтами.

Вот пример записи IP-адреса с применением беcклассовой адресации: 10.1.2.33/27. В данном примере видно, что в маске подсети 27 бит слева выставлены в единицу. В таком случае говорят о длине маски подсети в 27 бит.

октеты IP-адреса | 10 |  |  |  |  |  |  |  | 1 |  |  |  |  |  |  |  | 2 |  |  |  |  |  |  |  | 33
биты IP-адреса | 0 | 0 | 0 | 0 | 1 | 0 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 1 | 0 | 0 | 0 | 1 | 0 | 0 | 0 | 0 | 1
биты маски подсети | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 0 | 0 | 0 | 0 | 0
октеты маски подсети | 255 |  |  |  |  |  |  |  | 255 |  |  |  |  |  |  |  | 255 |  |  |  |  |  |  |  | 224

Вот ещё один пример записи адреса в бесклассовой нотации: 172.16.0.1/12.

октеты IP-адреса | 172 |  |  |  |  |  |  |  | 16 |  |  |  |  |  |  |  | 0 |  |  |  |  |  |  |  | 1
биты IP-адреса | 1 | 0 | 1 | 0 | 1 | 1 | 0 | 0 | 0 | 0 | 0 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 1
биты маски подсети | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0
октеты маски подсети | 255 |  |  |  |  |  |  |  | 240 |  |  |  |  |  |  |  | 0 |  |  |  |  |  |  |  | 0

Особые IP-адреса.

Для технических нужд система адресации IP v.4 использует адреса, которые по синтаксису одинаковые для всех типов сети:

· если весь IP-адрес состоит из двоичных нулей- это адрес того узла, который сгенерировал этот пакет;
· если нулевым является только номер сети по умолчанию считается, что узел назначения принадлежит той же сети, что и узел, отправивший пакет;
· адрес состоит из одних единиц. Ограниченное широковещательное сообщение BroadCast. Пакет доставляется всем узлам, принадлежащим к той же сети, что и передатчик;
· если поле номера узла состоит из одних единиц, пакет доставляется всем узлам, находящимся в сети с заданным номером.

Помимо этих адресов существует набор специализированных (отладочных) адресов. Например: 127.0.0.0, 127.0.0.1 и некоторые другие адреса, начинающиеся со 127. Такие адреса принято называть Loopback. Данные не передаются по сети, а передаются модулям верхнего уровня узла-отправителя как только что принятые.


Система адресации IP v.6

Система адресации Ipv.4 - прозрачная, но малоэффективная практически исчерпала свои возможности. Для продолжения ее использования в копьютерной промышленности необходим определенный базовый набор знаний и серьезный опыт работы. Однако последним камнем в ее огород стала угроза дефицита IP- адресов. В середине 90-х специалисты приступили к разработке новой версии- Ipv.6(RFC 1883).

Свойства адресации Ipv.6:

· 128-разрядная адресация;
· связь одного адреса с несколькими интерфейсами;
· автоматическое назначение адреса и CIDR-адресация.

Размер в 128 разрядов позволяют организовать адресное пространство из 340 289 366 920 938 463 463 374 607 431 762 211 456 уникальных адресов.

В Ipv.6 определяется несколько типов адресов: AnyCast, UniCast, MultiCast. Они отличаются по префиксу формата (10, 110, 1110, …).

UniCast - уникальный адрес.

MultiCast - групповой адрес.

AnyCast (в некоторых источниках - Claster) - это тип адреса, при котором пакет доставляется ближайшему узлу из группы интерфейсов, имеющих этот адрес.

Структура агрегированного уникального адреса Ipv.6.

3 | 13 | 8 | 24 | 10 | 64
FP | TLA |  | NLA | SLA | Interfase ID

Поле префикса формата FP назначено для определения типа адреса, для глобального агрегированного уникального адреса имеет значение 001.

TLA-префикс верхнего уровня, предназначен для агрегирования верхнего уровня, который используют при назначении сети провайдеры самого верхнего уровня(by, com, ru).

Поле 8 бит - предназначено в дальнейшем для расширения TLA, если 8196 сетей будет исчерпано.

NLA-префикс следующего уровня, предназначен для размещения номеров сетей средних и мелких провайдеров. Значительный размер поля (24 бита) позволяет построить сложную структуру номеров сетей, т.е. использует технологию SIDR в пределах данного поля.

SLA-префикс местного уровня, предназначен для адресации подсетей отдельного компонента, например, подсетей одной корпоративной сети. 16 бит этого поля также позволяет агрегировать адресное подпространство в пределах поля SLA.

Идентификатор интерфейса Interface ID (64 бита) позволяет использовать в качестве адреса узла:

· MAC- адрес сетевого адаптера (48 бит);
· адрес X.25 (60 бит);
· адрес конечного узла ATM (48 бит);
· IP-адрес в системе IP v.4.

А также использует локальные адреса технологий, которые появятся в будущем.


Система адресации NetBEUI

NetBIOS (Network Basic Input/Output System) был разработан Sytek Corporation в 1983 году по заказу IBM в качестве прикладного программного интерфейса (API) с помощью которого клиентское ПО могло обращаться к ресурсам локальной сети. Поддерживает обмен данными как с помощью установления соединения так и без него. Имеет собственную службу имён.

Протокол NetBIOS (сетевая базовая система ввода/вывода) был разработан компанией IBM для сетей IBM PC Network и IBM Token-Ring по образцу системы BIOS персонального компьютера. С тех пор этот протокол стал фактическим стандартом (официально он не стандартизован), и многие сетевые операционные системы содержат в себе эмулятор NetBIOS для обеспечения совместимости. Первоначально NetBIOS реализовывал сеансовый, транспортный и сетевой уровни, однако в последующих сетях на более низких уровнях используются стандартные протоколы (например, IPX/SPX), а на долю эмулятора NetBIOS остается только сеансовый уровень. NetBIOS обеспечивает более высокий уровень сервиса, чем IPX/SPX, но работает медленнее.

На основе протокола NetBIOS был разработан протокол NetBEUI, который представляет собой развитие протокола NetBIOS до транспортного уровня. Однако недостаток NetBEUI состоит в том, что он не поддерживает межсетевое взаимодействие и не обеспечивает маршрутизацию. Поэтому данный протокол используется только в простых сетях, не рассчитанных на подключение к Интернет. Сложные сети ориентируются на более универсальные протоколы TCP/IP и IPX/SPX. Протокол NetBEUI в настоящее время считается устаревшим, хотя даже в операционной системе Windows XP предусмотрена его поддержка, правда, только как дополнительная опция.

Рисунок 1 -

Выбор адреса NetBEUI / NetBIOS

Имена NetBIOS могут включать до 16 символов. Первые 15 символов можно использовать для указания понятного имени компьютера, а шестнадцатый символ зарезервирован для указания службы компьютера, которая передает информацию. Например, шестнадцатый символ сервера сообщений (службы, отсылающей и принимающей сообщения) представляет собою шестнадцатеричное число 03.

Чаще всего NetBIOS-адресация используется поверх протокола TCP/IP. Чтобы разрешить NetBIOS имена компьютера-получателя в IP-адрес используется протокол NetBT. Это многоступенчатая процедура:

- В основу адресации NetBIOS изначально заложен широковещательный запрос. Если сервер WINS (Windows Internet Naming Service - служба имен Интернета для Windows) не может разрешить имя NetBIOS в IP-адрес, протокол NetBT отсылает компьютеру-получателю широковещательный запрос на отсылку широковещательного сообщения с IP-адресом.

- Сервер WINS записывает все имена NetBIOS в динамическом режиме. Для разрешения имен NetBIOS в IP-адреса клиенты WINS могут напрямую связываться с сервером WINS. В основном, сервер WINS используется для поддержки обратной совместимости со старыми системами Windows.

- Когда имя NetBIOS разрешается в IP-адрес, информация сохраняется в кэш-памяти в течение двух минут. Если в течение двух минут имя используется хотя бы один раз, оно сохраняется в кэше в течение десяти минут.

- Если задействовать сервер DNS, протокол NetBT направляет запрос на разрешения имен NetBIOS в IP-адреса на сервер DNS.

- Информация о соответствии имен NetBIOS IP-адресам может храниться в файлах. Это файлы HOSTS и LMHOSTS. Они находятся в каталоге операционной системы \\..\System32\drivers\еtс\ и не может, иметь расширения имени.

Файл LMHOSTS. Файл LMHOSTS представляет собою текстовый файл, в котором перечислены IP-адреса и соответствующие им имена NetBIOS. Если в конце записи поместить суффикс #PRE, имя NetBIOS и IP-адрес будут навсегда помещены в кэш имен NetBIOS.

Файл HOSTS. Если задействовать файл HOSTS, протокол NetBT применит его для разрешения имени NetBIOS в IP-адрес.

Структура файла HOSTS

Формат и способы назначения IP-адресов рассматриваются далее.


Система адресации на уровне MAC

Подуровень MAC канального уровня модели OSI работает с физическими адресами, которые называются МАС-адресами. Они применяются в сетях Ethernet, Fast Ethernet, Token-Ring, FDDI, 100VG-AnyLAN и представляют собой 12 шестнадцатеричных цифр (48 бит), записанных в микросхему сетевого адаптера (например, 17:A4:2C:43:2F:09). Эти 48 бит структурированы (рисунок 1):

· младшие 24 разряда кода адреса называются OUA (Organizationally Unique Address) – организационно уникальный адрес. Именно их присваивает каждый из зарегистрированных производителей сетевых адаптеров. Всего возможно свыше 16 миллионов комбинаций, то есть каждый изготовитель может выпустить 16 миллионов сетевых адаптеров;
· следующие 22 разряда кода называются OUI (Organizationally Unique Identifier) – организационно уникальный идентификатор. IEEE присваивает один или несколько OUI каждому производителю сетевых адаптеров. Это позволяет исключить совпадения адресов адаптеров от разных производителей. Всего возможно свыше 4 миллионов разных OUI, это означает, что теоретически может быть зарегистрировано 4 миллиона производителей. Вместе OUA и OUI называются UAA (Universally Administered Address) – универсально управляемый адрес или IEEE-адрес;
· два старших разряда адреса управляющие, они определяют тип адреса, способ интерпретации остальных 46 разрядов. Старший бит I/G (Individual/Group) указывает на тип адреса. Если он установлен в 0, то индивидуальный, если в 1, то групповой (многопунктовый или функциональный). Пакеты с групповым адресом получат все имеющие этот групповой адрес сетевые адаптеры. Причем групповой адрес определяется 46 младшими разрядами. Второй управляющий бит U/L (Universal/Local) называется флажком универсального/местного управления и определяет, как был присвоен адрес данному сетевому адаптеру. Обычно он установлен в 0. Установка бита U/L в 1 означает, что адрес задан не производителем сетевого адаптера, а организацией, использующей данную сеть. Это случается довольно редко.

Рисунок 1 -

Структура МАС-адреса международной организации IEEE

Для широковещательной передачи (то есть передачи всем абонентам сети одновременно) применяется специально выделенный сетевой адрес, все 48 битов которого установлены в единицу. Его принимают все абоненты сети независимо от их индивидуальных и групповых адресов.

Недостатком MAC-адресации – считается сложность структуры сетевых адаптеров, а также большая доля служебной информации в передаваемом пакете (адреса источника и приемника вместе требуют уже 96 битов пакета или 12 байт).

Во многих сетевых адаптерах предусмотрен так называемый циркулярный режим. В этом режиме адаптер принимает все пакеты, приходящие к нему, независимо от значения поля адреса приемника. При этом один компьютер принимает и контролирует все пакеты, проходящие по сети, но сам ничего не передает. В данном режиме работают сетевые адаптеры мостов и коммутаторы, которые должны обрабатывать перед ретрансляцией все пакеты, приходящие к ним.

Данной системы адресов придерживаются такие сети, как, Ethernet, Fast Ethernet, Token-Ring, FDDI, 100VG-AnyLAN.

Теоретически во всем мире не должно быть двух сетевых адаптеров с одинаковыми MAC-адресами. Однако на практике иногда происходят ошибки у производителей, присваивающих адаптерам уже использованные адреса. Кроме того, некоторые поставщики исчерпали выделенные им номера и начали нумерацию сначала. Повторяющиеся МАС-адреса вызывают проблемы, если два сетевых адаптера с одинаковым МАС-адресом принадлежат одной и той же сети.

Если два сетевых адаптера в одной и той же сети имеют одинаковый адрес, то необходимо заменить один из них или изменить у одного из них МАС-адрес. В сетевых адаптерах некоторых поставщиков МАС-адрес можно изменить программно – как динамический параметр «перезаписываемой» микросхемы. В частности, интегрированные в материнские платы отдельных производителей, сетевые адаптеры имеют подобную настройку в CMOS-настройках самой материнской платы.


Системы обмена сообщениями

По своей сути, платформа обмена сообщениями - это технология, позволяющая двум разнесенным объектам обмениваться любыми видами информации. Эти приложения могут располагаться и работать независимо на различных аппаратных платформах.

Остановимся подробнее на тех видах систем обмена сообщениями, которые реализуют информационный обмен между пользователями:

- Мгновенный сообщениями

В данном случае используется технология on-line обмена. В сети выделяется сервер, который доставляет данные между узлами, участвующими в текущем соединении. Сервер кэширует сообщения на случай перерывах в сеансах связи, которые часто случаются в глобальной сети. Некоторые сравнивают эту модель общения с моделью виртуального пространства. В локальных и корпоративных сетях могут использоваться безсерверные многопользовательские on-line соединения (chat-системы). В этом случае кэширование данных осуществляется средствами самого узла. А каналы связи считаются абсолютно надежными.

· Обмен почтовыми сообщениями

Служба электронной почты предназначена для обеспечения возможности обмена персональными сообщениями между пользователями информационных сетей. Данная служба состоит из объектов клиентов службы (клиентских программ доступа) и серверов электронной почты. Серверы электронной почты, взаимодействуя друг с другом, образуют сеть электронной почты. Данная сеть по принципам построения напоминает ранее существовавшие сети с коммутацией сообщений. Каждый пользователь сети закреплен за своим сервером и имеет в нем электронный “почтовый ящик” под определенным именем. Для отправки сообщения достаточно передать его в определенном формате на свой почтовый сервер с указанием адреса получателя. Почтовый сервер, проанализировав адрес получателя, отправит сообщение через сеть почтовых серверов серверу, содержащему почтовый ящик получателя, куда это сообщение и будет положено. Для получения своих сообщений достаточно обратиться к своему почтовому серверу и считать из почтового ящика все свои сообщения.

Существует несколько типов служб электронной почты, базирующихся на различных протоколах обмена, однако наибольшее распространение получила сетевая служба, используемая в сети Internet, базирующаяся на протоколе SMTP.

· Cлужба обмена новостями

Internet-сообщество уже много лет пользуется системой тиражирования объявлений, рекламы, сообщений и другой информации. Всю подобным образом тиражируемую информацию называют новостями — "news". Новости делятся на группы новостей — "newsgroups". Группы новостей организованы в определенном порядке, основанном на распределении дискуссий по темам, например, отдых, спорт, новости, информация, религия и др. Внутри каждой из этих групп может быть до нескольких тысяч подгрупп, которые, в свою очередь, обладают такой же иерархической структурой. Принцип этой организации подобен структуре размещения каталогов и подкаталогов на жестком диске.

Механизм передачи статей пользователю заключается в следующем. Предположим, что какое-либо сообщение попадает в конференцию на одной машине, например, оно поступило от пользователя. Это сообщение принимается данным хостом в локальную базу данных и передается всем его соседям, которые "подписаны" по крайней мере на одну из конференций, к которой относится данная статья. Этот процесс будет продолжаться до тех пор, пока все хосты подсети данной конференции не будут располагать этой статьей.

Для небольшого количества пользователей идеальной схемой построения обмена новостями была бы структура, состоящая из одного News-сервера и пользователей, обращающихся к нему для отправки или получения новых статей. В системах с большим количеством клиентов, например, масштаба университета или крупного предприятия, необходимо использовать так называемые промежуточные серверы новостей — intermediate news server.

Для обмена сообщениями между серверами, а также для доступа к серверам используется протокол NNTP.

· Подписки на рассылку
· Форумы

Также здесь следует упомянуть о современных технологиях обмена сообщениями, применяемыми компаниями сотовой связи. Например, SMS, EMS, MMS и прочие.


Смешанные топологии, технологии их использования

Смешанная топология, как правило, является продуктом объединения разнородных сетей в рамках общей информационно-вычислительной системы.

К свойствам сетей со смешанной топологией можно отнести следующие технические моменты, которые невозможно реализовать в рамках других топологий:

· использование сетевого оборудования различных сетевых архитектур в рамках единой сети;
· использование разнородных сред передачи данных (за исключением случаев описанных спецификациями сетевых стандартов);
· возможность объединения в одну информационно-вычислительную систему архитектурнонесовместимых вычислительных комплексов и машин;
· организация эффективного обмена информацией в сетях с несколькими вариантами маршрутов доставки сообщений от узла-отправителя к узлу-получателю;
· организация эффективного обмена данными с клиентом сети, находящимся в состоянии движения.

Для локальных сетей применение смешанных топологий является дорогостоящим и, на текущий момент времени, редко применяемым решением. Причиной этого является сложность разработки системы управления и поддержки работоспособности подобной структуры.

Для сетей масштаба города (SAN) смешанная топология является удобным решением при организации обмена данными, которое максимально соответствует всем задачам сетей данного масштаба.

Для глобальных и виртуальных частных сетей – это единственный возможный вариант реализации обмена данными.

Чаще всего для объединения разнородных сегментов применяется специализированное оборудование, осуществляющее трансформацию пакетов из вида приемлемого для сети отправителя в сеть назначения. К числу такого оборудования относятся мосты, маршрутизаторы, шлюзы.

При использовании иерархических схем объединения сетевых сегментов одна из используемых топологий будет считаться сетеобразующей, а остальные будут выступать в качестве расширения.

Например, топология звезда является сетеобразующей для следующей сети (рисунок 1).

Рисунок 1 -

Иерархическая сеть с централизованным управлением

В других случаях сеть верхнего уровня не считается сетеобразующей, а выполняет только функцию общей информационной магистрали (рисунок 2).

Рисунок 2 -

Локальная сеть Ethernet с использованием скоростной магистрали дальнего действия FDDI

Таким образом можно видеть, что смешанные топологии могут быть изначально заложены в проект сети, чтобы иметь возможность воспользоваться лучшими из их характеристик.

Практика построения и эксплуатации сетевых технологий показала, что иногда смешанная топология может также стать средством применения специализированного оборудования, несовместимого с сетевым стандартом основной сети. Например, в банковских сетях, построенных по стандарту Ethernet, до сих пор могут применяться быстродействующие системы матричной печати, которые подключаются к сети по стандарту Xerox Network System. Промежуточным звеном объединения в этом случае может служить дополнительный узел сети, выполняющий функции шлюза.


Стек протоколов IPX/SPX

Стек разработан корпорацией Novell, которая нуждалась в протоколах, на работу которых требовалось бы минимальное количество оперативной памяти (ограниченной в IBM-совместимых компьютерах тех лет под управлением ОС MS-DOS 640 Кбайтами) и которые бы быстро работали на процессорах небольшой вычислительной мощности (рисунок 1).

Основой этого стека протоколов являются следующие протоколы:

Протокол IPX (Internetwork Packet Exchange - протокол межсетевой передачи пакетов) является базовым в Novell NetWare. Он определяет формат передаваемых по сети пакетов и интерфейс с сетевым программным обеспечением.

Протокол SPX (Sequenced Packet Exchange - протокол последовательного обмена пакетами) предполагает, что перед началом обмена данными рабочие станции устанавливают между собой связь. На уровне протокола SPX гарантируется доставка передаваемых по сети пакетов. При необходимости выполняются повторные передачи пакетов.

Рисунок 1 -

Стек IPX / SPX в эталонной модели OSI

На физическом и канальном уровнях в сетях Novell используются все популярные протоколы этих уровней (Ethernet, Token Ring, FDDI и другие).

На сетевом уровне в стеке Novell работает протокол IPX, а также протоколы обмена маршрутной информацией RIP и NLSP. IPX является протоколом, который занимается вопросами адресации и маршрутизации пакетов в сетях Novell. Маршрутные решения IPX основаны на адресных полях в заголовке его пакета, а также на информации, поступающей от протоколов обмена маршрутной информацией. Например, IPX использует информацию, поставляемую либо протоколом RIP, либо протоколом NLSP (NetWare Link State Protocol) для передачи пакетов компьютеру назначения или следующему маршрутизатору. Протокол IPX поддерживает только дейтаграммный способ обмена сообщениями, за счет чего экономно потребляет вычислительные ресурсы.

Транспортному уровню модели OSI в стеке Novell соответствует протокол SPX, который осуществляет передачу сообщений с установлением соединений.

На верхних прикладном, представительном и сеансовом уровнях работают протоколы NCP и SAP.

Протокол NCP (NetWare Core Protocol) является протоколом взаимодействия сервера NetWare и оболочки рабочей станции. С помощью функций этого протокола рабочая станция производит подключение к серверу, отображает каталоги сервера на локальные буквы дисководов, просматривает файловую систему сервера, копирует удаленные файлы, изменяет их атрибуты и т.п., а также осуществляет разделение сетевого принтера между рабочими станциями.

SAP (Service Advertising Protocol) - протокол объявления о сервисе. SAP позволяет маршрутизаторам обмениваться маршрутной информацией и дает возможность сетевым устройствам обмениваться информацией об имеющихся сетевых сервисах.

Он позволяет сетевым устройствам постоянно корректировать данные о том, какие сервисные услуги имеются сейчас в сети. При старте серверы используют SAP для оповещения оставшейся части сети о своих услугах. Когда сервер завершает работу, то он использует SAP для того, чтобы известить сеть о прекращении действия своих услуг.

Особенности стека IPX/SPX обусловлены характеристиками ОС NetWare, а именно ориентацией ее ранних версий (до 4.0) на работу в локальных сетях небольших размеров, состоящих из персональных компьютеров со скромными ресурсами. В результате, протоколы стека IPX/SPX до недавнего времени хорошо работали в локальных сетях и хуже - в больших корпоративных сетях, так как слишком перегружали медленные глобальные связи широковещательными пакетами, которые интенсивно используются несколькими протоколами этого стека (например, для установления связи между клиентами и серверами).


Стек протоколов TCP/IP

Агентство DARPA (Defense Advance Research Projects Agency) разработало протоколы TCP/IP (Transmission Control Protocol/Internet Protocol) для объединения в сеть компьютеров различных подразделений министерства обороны США. Международная распределенная сеть Internet использует стек протоколов TCP/IP для объединения компьютерных ресурсов всей планеты. Достаточно часто эти протоколы используются также в частных и коммерческих сетях.

Стек TCP/IP включает следующие протоколы:

· IP/IP v.4/IP v.6 - Internet Protocol;
· TCP - Transmission Control Protocol;
· UDP - User Datagram Protocol.

Рисунок 1 -

Стек TCP/IP в эталонной модели OSI

IP (Internet Protocol) представляет собой протокол уровня маршрутизируемых дейтаграмм в стеке TCP/IP. Все другие протоколы стека TCP/IP (кроме ARP и RARP) используют протокол IP для маршрутизации кадров между хостами. Заголовок кадров IP содержит маршрутную и управляющую информацию, связанную с доставкой дейтаграмм. IPv6 представляет собой обновленную версию протокола Internet, разработанную на основе IPv4. Оба протокола (IPv6 и IPv4) различаются на уровне среды. Например, пакеты IPv6 передаются через сеть Ethernet с использованием идентификатора типа 86DD вместо 0800 для IPv4. Структура заголовков IPv6 показана на рисунке.

Протокол TCP обеспечивает надежную доставку потоков и сервис поддержки виртуальных соединений за счет использования подтверждений и повторной передачи пакетов при возникновении необходимости. Структура заголовка TCP показана на рисунке.

Протокол UDP (User Datagram Protocol - протокол пользовательских дейтаграмм) обеспечивает простой сервис передачи сообщений без гарантии доставки для ориентированных на транзакции услуг. Каждый заголовок UDP содержит идентификаторы портов отправителя и получателя, которые позволяют протоколам вышележащих уровней связать указанные приложения и услуги с хостами. Структура заголовков UDP показана на рисунке.


Структурированные кабельные системы

В настоящее время по мере того, как все большее количество пользователей переходят к применению открытых систем, выпускаемое активное оборудование проектируется на основе положения, что кабельная часть информационной инфраструктуры соответствует требованиям стандартов, то есть является гарантированно надежной и способной обеспечивать определенные рабочие характеристики.

К различным рискам, являющимися следствием нестандартных кабельных систем, можно отнести следующие - сетевые рабочие характеристики ниже определенных стандартами, повышенная стоимость внесения изменений в систему и неспособность системы поддерживать новые технологии. По мере распространения принципов структурированного кабелирования стоимость устанавливаемого сетевого оборудования падает, а эффективность передачи данных растет с экспоненциальной зависимостью.

Проектирование структурированной кабельной системы (СКС) разделяется на две основные стадии: архитектурную и телекоммуникационную. Основной задачей архитектурной стадии является определение общей структуры СКС, оптимальной по комплексу технико-экономических характеристик в процессе создания и последующей эксплуатации. Телекоммуникационная стадия чаще всего начинается после окончания архитектурной, а иногда и после завершения капитальных строительно-монтажных работ. В этот период уточняется конкретная структура СКС, составляется перечень необходимого оборудования, планы его размещения и .т.д.

В самом общем случае СКС включает в себя три подсистемы:

· подсистема внешних магистралей (первичная) – является основой для построения сети связи между компактно расположенными на одной территории зданиями (кампус);
· подсистема внутренних магистралей (вторичная или вертикальная) связывает между собой отдельные этажи здания и/или пространственно разнесенные помещения в пределах одного здания;
· горизонтальная (третичная) подсистема образована внутренними информационными кабелями между сетевым оборудованием и информационными розетками рабочих мест, самими информационными розетками, коммутационным оборудованием и соединительными кабелями.

Для размещения оборудования используется стандарт включающий в себя способы коммутации, энергообеспечения и защиты оборудования от несанкционированного доступа. Одним из центральных элементов этого стандарта (как с точки зрения топологии сетей, так и с точки зрения организации энергоснабжения, коммутации и защиты) являются коммутационные шкафы.

Коммуникационные шкафы (рисунок 1) в общем случае рассматриваются как конструкции, предназначенные для обслуживания горизонтальной распределительной системы. Кроме этой основной функции, они могут выполнять и дополнительные - в них допускается размещение промежуточных и главных кроссов.

Рисунок 1 -

Пример коммуникационного шкафа

Коммутационные шкафы для успешного размещения в них оборудования ограничивают разработчиков всех видов сетевого оборудования по геометрическим размерам создаваемых элементов.

Современный размер коммуникационных шкафов предписывает размер ~ 465 мм по горизонтали и шаг ~ 17 мм по вертикали межосевое для крепежных отверстий. Габарит шкафа определяется как 19”.

Все виды промышленного сетевого активного оборудования либо геометрически совместимо с этим стандартам, либо имеют крепежные элементы, делающие их совместимыми с ним.

Системы энергоснабжения оборудования и источники бесперебойного питания размещаются внутри коммуникационных шкафов, так что следует учитывать этот факт при выборе размеров коммуникационного шкафа для конкретного проекта сети.


Топология звезда

Звездообразная топология (star topology), или просто «звезда», является старейшим способом передачи сигналов, имеющим свое начало в коммутационных телефонных станциях. Несмотря на возраст, достоинства при использовании в сетях делают звездообразную топологию удачным выбором для современных сетей.

В этом случае все компьютеры, подключаемые к сети, соединяются кабелем с «центральным элементом» в качестве которого может использоваться специальный компьютер – узел сети.

Сигналы от передающего компьютера поступают через центральный элемент (например, сервер) ко всем остальным, что является основой терминальных систем.

Звезда является частным случаем дерева, поэтому сети с топологией звезда образуют иерархически подчиненную систему.

Несмотря на большие размеры кабеля, чем у топологии шина топология звезда считается дешевой, а поэтому – довольно распространенной. Максимальная скорость передачи ограничена типом центрального элемента и возможностями передающей среды. Надежность центрального элемента является узким местом и основным недостатком сети.

Рисунок 1 -

Передача информации в топологии «звезда»

Расширяемость такой сети, то есть степень простоты добавление новых элементов, довольно высокая. Достаточно соединить новый узел с центральным элементом сети. Если свободных портов в центральном элементе нет его можно заменить или установить дополнительный специализированный многопортовый сетевой адаптер (рисунок 2).

Рисунок 2 -

Многопортовый сетевой адаптер Ethernet NEXLAN

Недостатком звезды является то, что центральный элемент является единственной точкой отказа и при выходе его из строя все подключенные узлы теряют возможность передачи данных.

Другим недостатком является то, что для звезды требуется больше кабеля, чем для шины, но этот недостаток уже считается несущественным, поскольку кабельные системы топологии «звезда», как правило, поддерживают гораздо более высокие скорости информационного обмена.

Несмотря на то, что прямая физическая коммутация «рабочая станция»⇒«сервер» позволяет получить пользователю максимальную скорость обслуживания сетевых запросов сервером на практике такая схема применяется редко. Причиной этого можно считать сложность в обеспечении эффективной связи между клиентами сети, либо одновременную связь рабочих станций с несколькими серверами.

Более дешевой практической реализацией топологии «звезда» стали комбинированные варианты топологий «звезда-шина» и «звезда-кольцо» со специализированным центральным элементом.


Топология кольцо

При топологии «кольцо» компьютеры подключаются к кабелю, замкнутому в кольцо. Поэтому у кабеля просто нет свободного конца, на который надо поставить терминатор.

Продвижение информации осуществляется от первому ко второму, от второго к третьему и так далее, а от последнего к первому (рисунок 1).

Рисунок 1 -

Пример сети, построенной топологии «кольцо»

Кольцевой топологией легче управлять, чем шинной, поскольку оборудование, используемое для построения кольца, упрощает локализацию дефектного узла или неисправного кабеля. Данная топология хорошо подходит для передачи сигналов в локальных сетях, поскольку она справляется с большим сетевым трафиком лучше, чем шинная топология. В целом можно сказать, что по сравнению с шинной топологией, кольцевая обеспечивает более надежную передачу данных.

Сигналы передаются по кольцу в одном направлении и проходят через каждый компьютер. В отличие от пассивной топологии «шина», здесь каждый компьютер выступает в роли повторителя, усиливая сигналы и передавая их следующему компьютеру. Поэтому, если выйдет из строя один компьютер, прекращает действовать вся сеть.

Интерфейс связи может быть реализован в виде внешнего трансивера, либо встроен в сетевой адаптер. Для обеспечения бесперебойной работы он должен быть всегда включен и иметь возможность взаимодействия кольца при отключении узла сети (рисунок 2).

Рисунок 2 -

Способ продвижения информации в топологии «кольцо»

Кольца изначально разрабатывались для однонаправленной передачи, позднее были разработаны двунаправленные модификации. В результате этого, если разрывается кольцо передачи в одном направлении, данные все же могут достигнуть пункта назначения, перемещаясь в обратном направлении по другому кольцу.

Расширяемость сети, то есть степень простоты добавление новых элементов, в отличие от топологии «шина» достаточно трудоемкий процесс, особенно если вновь подключаемый элемент расположен в стороне от уже существующей кабельной проводки.

На текущий момент топологией «кольцо» пользуются сетевые архитектуры Token Ring (рисунок 3) и FDDI.

Рисунок 3 -

Сетевые адаптеры Token Ring, для топологии «кольцо»

Самый популярный из принципов реализации передачи данных в кольцевой сети TokenRing использует передачу маркера, этот метод описывается в главе 5.

Перспективы применения этой топологии в чистом виде – довольно туманны (в том числе для FDDI), но ее принципы наследуются в одной из комбинированных схем.


Топология шина

Шинная топология представляет собой кабель, последовательно соединяющий компьютеры и серверы в виде цепочки. Как и обычная цепь, сеть с шинной топологией имеет начальную и конечную точки, и к каждому концу сегмента шинного кабеля подключается терминатор. Передаваемый пакет принимается всеми узлами сегмента и на прохождение всего сегмента требуется некоторое количество времени, называемое задержкой (смотри рисунок 1).

В качестве среды передачи в данной топологии применяется коаксиальный кабель.

Расширяемость такой сети, то есть степень простоты добавления новых элементов – хорошая, поскольку новый узел можно «врезать» (подключить) в любой точке общей шины.

Уровень надежности, то есть вероятность сохранения работоспособности при выходе из строя узла сети или разрыва передающей среды этой топология очень низкая. Обрыв кабеля в любой точке может блокировать весь сетевой обмен.

Наличие терминатора обязательно для шинной топологии поскольку терминатор указывает на физическое окончание сегмента. На практике терминатор представляет собой электрическое сопротивление, гасящее сигнал, когда тот достигает конца сети. Без терминатора сегмент не соответствовал бы спецификациям IEEE и сигналы могли бы отражаться обратно возвращаться в этот кабель, по которому они были переданы. Отраженный сигнал сбивает синхронизацию сети и может сталкиваться с новыми сигналами, передаваемыми по сети.

В некоторых источниках утверждается, что топология «шина» может быть использована только для устаревших сетей, поскольку она не в состоянии поддерживать скоростные режимы выше 10 Мбит/c. Однако коаксиальный кабель, являющийся основой этой топологии, позволяет передавать данные на гораздо более высокой скорости.

Кроме классических стандартов сетевых архитектур с использованием данной топологии – ArcNet и Ethernet, следует упомянуть и сетевые архитектуры для данной топологии, разработанные в СССР, такие как FishNet (100 Ом) и Iola (75 Ом).

Сети кабельного телевидения и системы CaTV также используют шинную топологию для подключения отдельных пользователей к общей информационной среде.

Рисунок 1 -

Доставка данных адресату в топологии «шина»

Рисунок 2 -

Структура сети, построенной по топологии «шина» с использованием тонкого коаксиального кабеля

В целом, данную топологию еще рано списывать с рынка сетевых технологий. Сети и сегменты сетей на ее основе еще довольно долго будут существовать, а также вновь проектироваться и создаваться для решения целого ряда специфичных задач.


Физический и канальный уровни модели OSI

Физический уровень описывает: все физические среды передачи данных (кабель, оптоволокно, радиоволны и др.), сетевые разъемы, компоновку сети, методы передачи и кодирования сигналов, устройства передачи, методы распознавания ошибок при передаче сигналов. Сетевые сигналы могут быть представлены в аналоговом или цифровом виде. Аналоговый сигнал может изменяться непрерывно и выглядит как волна с положительными и отрицательными перепадами напряжения. В цифровом сигнале для представления единиц и нулей используются фиксированные уровни напряжения.

Рисунок 1 -

Примеры цифровых сигналов

Физический уровень управляет скоростью передачи данных, анализом потока ошибок и уровнями напряжения, используемыми для передачи сигнала.

Задача канального уровня в локальной сети – компоновать передаваемые биты данных в виде фреймов, или кадры. Каждый фрейм должен быт сформирован таким образом, чтобы после передачи данных от узла к узлу их можно было бы собрать в исходном порядке. Этот уровень кодирует данные в виде фреймов, после чего отформатированные фреймы поступают на физический уровень, где передающий узел может отправить их в коммуникационную среду.

Принимающий узел получает фрейм от физического уровня, декодирует электрический сигнал, преобразует отдельные разряды во фрейм и проверяет наличие ошибок во фрейме.

Обычно фрейм содержит:

· признак начала фрейма;
· адрес устройства или передающего узла, отправляющего фрейм;
· адрес устройства или передающего узла, получающего переданный фрейм;
· административную или управляющую информацию;
· данные;
· информацию для обнаружения ошибок;
· трейлер или признак конца фрейма.

Канальный уровень содержит два подуровня: более высокий - управление логическим соединением (LLC) и более низкий - протокол управления доступом к передающей среде (MAC). Подуровень LLC обеспечивает надежность коммуникаций путем установки канала передачи данных между двумя узлами и поддержки устойчивости этого канала. Подуровень MAC распознает физический адрес, содержащий в каждом фрейме. Он управляет совместной работой множества устройств внутри одной сети.

Два типа сервисов используются для взаимодействия подуровня LLC и сетевого уровня. Первый тип представлен службой без установки соединения, которая не требует наличие логического соединения между передающим и принимающим узлами. В этом случае не выполняется проверка очередности фреймов. Второй тип представлен службой с установкой соединения, для которой перед началом передачи данных устанавливается логическая связь между передающим и принимающим узлами. Каждый фрейм содержит порядковый номер, который проверяется принимающим узлом, и это гарантирует то, что фреймы обрабатываются в том же порядке, в котором они были посланы. Установленный канал связи обеспечивает скорость передачи информации. Принимающий узел дает подтверждение передающему узлу в получении посланной информации. При возникновении ошибок данные передаются повторно.

Стандарты, касающиеся совместной работы этих двух уровней модели OSI, и их свойства рассматриваются далее в этой главе, а также в главах 3-7.


Функции протоколов

Протоколы (protocols) – это набор правил и процедур, регулирующих порядок реализации некоторой связи. В компьютерной среде протоколы – это правила и технические процедуры, позволяющие нескольким компьютерам, объединенным в сеть, общаться друг с другом.

Коммуникационные задачи, которые возложены на сеть, позволяют выделить три типа протоколов:

· прикладные
· транспортные
· сетевые

Каждый из типов реализует функции одного или нескольких уровней модели OSI. На рисунке показано как эти три типа протоколов приблизительно соответствуют модели OSI.

Уровни модели OSI | Уровни протоколов
Прикладной | Прикладные протоколы
Представительский
Сеансовый
Транспортный | Транспортные протоколы
Сетевой | Протоколы сетевого уровня
Канальный
Физический

Рисунок 1 -

Соответствие типов протоколов модели OSI

Прикладные протоколы работают на верхнем уровне модели OSI. Они обеспечивают взаимодействие приложений и обмен данными между ними.

Транспортные протоколы поддерживают сеансы связи между компьютерами и гарантируют надежный обмен данных между ними.

Сетевые протоколы обеспечивают связь. Они имеют дело с адресной и маршрутной информацией, проверкой ошибок и запросами на повторную передачу. Сетевые протоколы, кроме того, определяют правила для осуществления связи в конкретных сетевых средах, например Ethernet или Token Ring.

Многие протоколы разрабатывались задолго до того, как стала широко использоваться модель OSI, поэтому нечасто можно встретить стек протоколов, который точно соответствует модели OSI.

В рамках модели OSI взаимодействие двух систем представляется фактически в виде двух моделей - горизонтальной и вертикальной:

· в рамках горизонтальной модели рассматривается прямое взаимодействие (обмен данными) одинаковых уровней в двух конечных точках (хостах); для организации такого взаимодействия в каждой из конечных точек должны поддерживаться одинаковые протоколы для данного уровня;
· в вертикальной модели рассматривается обмен информацией (взаимодействие) между соседними уровнями одной системы с использованием интерфейсов API; в этой модели каждый уровень может предоставлять свои услуги вышележащему уровню и пользоваться услугами нижележащего уровня (крайние уровни модели в этом смысле представляют исключение - прикладной уровень предоставляет свои услуги пользователю, а сетевой уровень не пользуется сервисом других уровней)

Передача данных по сети с технической точки зрения должна быть разбита на ряд последовательных действий, каждому из которых соответствуют свои правила и процедуры, составляющие протокол. Таким образом, сохраняется строгая очередность их выполнения. Кроме того, они должны выполняться в одной и той же последовательности на каждом сетевом компьютере. На компьютере-отправителе это происходит в направлении сверху вниз, а на компьютере-получателе – снизу вверх.

Далее перечислены основные функции, выполняемые сетевыми протоколами на каждом из уровней модели OSI.

Уровни модели OSI | Уровни протоколов
Прикладной | Инициирует или принимает запрос
Представительский | Определяет формат, преобразование применяемого набора символов (кодовой таблицы) и шифрование пакетов
Сеансовый | Добавляет информацию управления потоком данных, чтобы определить отослан ли пакет
Транспортный | Добавляет информацию для обработки ошибок
Сетевой | Добавляет адресную информацию и нумерацию пакетов
Канальный | Добавляет информацию для обнаружения ошибок и передачи по физическому соединению
Физический | Посылает пакет как поток бит


Частные сети

Сферу действия частной сети можно ограничить сферой деятельностью частного провайдера, предоставляющего сетевые услуги конечным пользователям. Максимальный охват такой сети ограничива-ется территорией одного города и его окрестностей (частная муници-пальная сеть). Спектр услуг, как правило, ограничен организацией почтового обмена и предоставлением доступа в Internet. Технологии связи между клиентами сети и центральным оборудованием частной сети чаще всего такие же самые, которые используются в глобальных сетях, но встречаются и оригинальные системы.

Нередко частная сеть возникает на основе существующей системы каналов связи. К числу подобных примеров относятся следующие:

· Сети на основе каналов кабельного телевидения.

Доставка информации конечному пользователю производится также как и доставка телевизионного сигнала (рисунок 1). Адаптер пользователя декодирует смешанный сигнал, выделяет информационную составляющую, транслируемую как обычный телевизионный канал посредством мультиплексирования (рисунок 2). Скорость трансляции от 384 Кбит/с до 1,5 Мбит/с, если запросы пользователя передаются провайдеру одним из стандартных способов, например, через модем. Скорость доступа 56 Кбит/с. Если используется кабель с двусторонней трансляцией пользователь может получить 1,5 Мбит/с в обе стороны. Пример технологии – сети Coomunity Antenna TeleVision – CATV.

· Сети на основе систем энергоснабжения.

Перспективная система доставки информации. Поскольку электросеть проникает в каждую комнату любого дома и компьютер пользователя получает достаточный уровень мобильности. Для передачи сигнала через электросеть используется мультиплексирование OFDM. Существующие образцы позволяют организовать сетевое подключение от 14 до 85 Мбит/с на удалении до 2 000 м (рисунок 3).

· Сети сотовых операторов.

Собственником системы связи и поставщиком услуг в данном случае является компания мобильной связи. Сотовые системы используют три различных метода мультиплексирования: FDMA, TDMA и CDMA. Скорость обслуживания сетевых запросов колеблется от 9,6 Кбит/с до 76,8 Кбит/с (по технологии TDMA) и от 100 Кбит/с до 2 Мбит/с (по технологии CDMA).

Рисунок 1 -

Сеть каналов частной беспроводной сети

Рисунок 2 -

Мультиплексирование полосы пропускания технологией FDMA

а – первоначальные полосы частот каждого канала; б – смещение по частоте

в – результат мультиплексирования

Рисунок 3 -

Оборудование сетей на основе сетей энергопотребления